Getting no audio output with Pulseaudio and Equalizer

Hello,

I'm having trouble with Pulseaudio and it's built-in Equalizer. I've followed the instructions here https://wiki.archlinux.org/index.php/PulseAudio#Load_equalizer_sink_and_dbus-protocol_module, however I am not getting any audio output when I switch to 'FFT based qualizer'?

Anyone with any expierence with this sorta setup?

Regards

EDIT: Here is my pulseaudio configuration: https://dpaste.de/uRB0

Since today you might have more than one soundcard, and audio most likely gets played with your primary sound card, you might not have audio output at all, cos pulseaudio is configured to use a different sound card as you want it to use. aplay -l shows you all the available cards. Go to Sound preferences and there on the hardware tab.

Check all listed sound cards and select the Off profile for those you don't use.

Yes, correct. I do have more than one sound card (2), and I use them both:

Even so, I am not getting any audio output from either of them when I select FFT..... Hmm, I am not sure how to fix this issue.

Check Alsamixer in the terminal ... that may not be on the right card ..

also check that the settings for volume are turned up on that..

Hmm..


I can understand what you mean, the sound must be going somewhere... hmmm. Why isn't this working :expressionless:

Here's a output of pactl when I am playing audio:

Sink #1
    State: RUNNING
    Name: alsa_output.pci-0000_00_14.2.analog-stereo
    Description: Built-in Audio Analog Stereo
    Driver: module-alsa-card.c
    Sample Specification: s16le 2ch 44100Hz
    Channel Map: front-left,front-right
    Owner Module: 7
    Mute: no
    Volume: front-left: 54009 /  82% / -5.04 dB,   front-right: 54009 /  82% / -5.04 dB
            balance 0.00
    Base Volume: 65536 / 100% / 0.00 dB
    Monitor Source: alsa_output.pci-0000_00_14.2.analog-stereo.monitor
    Latency: 89898 usec, configured 90000 usec
    Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY

Sink #2
    State: RUNNING
    Name: alsa_output.pci-0000_00_14.2.analog-stereo.equalizer
    Description: FFT based equalizer on Built-in Audio Analog Stereo
    Driver: module-equalizer-sink.c
    Sample Specification: float32le 2ch 44100Hz
    Channel Map: front-left,front-right
    Owner Module: 25
    Mute: no
    Volume: front-left: 54009 /  82%,   front-right: 54009 /  82%
            balance 0.00
    Base Volume: 65536 / 100%
    Monitor Source: alsa_output.pci-0000_00_14.2.analog-stereo.equalizer.monitor
    Latency: 195078 usec, configured 90000 usec
    Flags: HW_MUTE_CTRL LATENCY 
    Properties:

There are running..

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

In previous post, digital doesn't even show up in sound preferences.

Install pavucontrol. Even if the default sound card is right, applications might not be directed into the right soundcard. So the process will be like this:

  1. Install pavucontrol, launch it.
  2. Open up the application you want to output the sound, for example mpv player.
  3. Play whatever you want and don't stop the media.
  4. In pavucontrol, open the leftmost tab (Playback if I remember correctly) and you'll see the application which is having output, in this case mpv player. Choose the soundcard you want to output and the sound should be now there.
    Good luck :slight_smile:

One of my machines also sees anything like speakers plugged in as Headphones in Pulse audio........or it did ...
so if i plugged in my speakers to the laptop it used to cancel the sound in Alsa and i had to regulate sound as headphones in Pulse......
That comp is 1000s miles away and I dont remember if i fixed it or lived with it sorry

A bit of ...tricky question.

Are you sure your speakers are powered on, not muted by a switch ...and not covered by a blanket?

It has happenned to me many times :sunglasses:

There is a bug I came across once that you need to unplug and plug again the speakers cable to the laptop to make them work.

I will give that a try, one moment

UPDATE: Pavucontrol was already installed and the output was already set to the equalizer sink. In fact, I saw volume gain coming from the application itself and outgoing to the equalizer sink. It seems that the stream stops there. However, switching back to the analog device did produce audio. As far as I can see, nothing is muted,

I did come across this thread on Arch froums: https://bbs.archlinux.org/viewtopic.php?id=168553. I'll give his solution a shot.

This is a PC but I'll try that anyway.

If you haven't solve the problem yet, you wanna give JACK a shot? My tutorial about jack: How to replace Pulseaudio with Jack, Jack and PulseAudio Together as Friend
:slight_smile:

Thanks, I'll look into it, for now I work on this another time :smile:. I have other work to work on!

1 Like

after following guide from @crazyg4merz my manjaro sound is alive..
I'm using cadence after failing with cadence-git..

here some usefull link..
archwiki

askubuntu
plese make sure pavucontrol>configuration>build in audio>profile-TURN OFF
and your username added to "audio" group

this work for me

1 Like

Forum kindly sponsored by