Getting stuck after entering login details

Hi, I just got a new laptop with the following stats:

16gb Ram, intel i7 8750h, 1050ti 4gb.

I just finished installing manjaro on it although it gets stuck after entering the password.

ctrl alt f2 - ctrl alt f7 doesnt change anything
Adding additional monitor doesnt change anything either.

I tried to follow:

But the result was the same.
I was able to login once after installing.
After rebooting it stopped working.

sudo mhwd -a pci nonfree 0300 gets stuck as well, as well as all pci commands I tried.

My initial suggestion would be to try PRIME instead of bumblebee. bumblebee is becoming more unreliable as hardware and the NVIDIA driver moves along.

If you're not worried about power use, try display offloading with nvidia:

If you want lower power consumption, then you want render offloading with nouveau (free drivers; video-linux and DRI_PRIME).

Otherwise, some people have found success with video-hybrid-intel-nvidia-390xx-bumblebee instead of video-hybrid-intel-nvidia-bumblebee.


Tried another way, ran into this now and stuck.

I meant, I tried another time to reinstall it and it ended up here

Now its getting stuck after the login again, I installed it in several manners but I never got where I would be able to enter the command you suggested.

Okay, after booting live, shutting down and rebooting the normal system I got in.
But, any of the commands:

# Bumblebee/Optimus:
sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

# Single card/PRIME:
sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

Just resulted in the command getting stuck and me having to kill the console.
Anything I can do?

The first thing you need to do is full update. Have you done it?

Be specific and systematic in your steps.

All I read from your post is that you've scatter-gunned several commands without knowing what they do, then asked for help without saying what you did.

I installed the system with drivers on nonefree and Noveau. Modeset =1. + systemd.mask=mhwd-live.service this way the installation went through.

Then I added the window 2009 line to the boot.

I got in after shutting down the live CD and then trying to start manjaro.

I did a full update and installed the kernel headers. Still doesn't boot well.

Okay after adding acpi_osi=! acpi_osi="Windows 2009" it now starts succesfully.
A0lthough two problems remain:

a) I'm unable to execute the commands to set up the GPU.
b) After leaving the computer alone for some time, when it turns off the display, it gets stuck there forever and I have to force shut it down.

Next time try this workaround (old known issue)
Ctrl+Alt+F2 and then Ctrl+Alt+F7
Have you installed a system or are you talking about a Live ISO?

I am talking about the installed system. I was able to install the system following the steps I explained above.

Unfortunately, I tried Ctrl+Alt+F2 and then Ctrl+Alt+F7 when it gets stuck there but it didn't help.

Can you run one or all of these commands:

inxi -SGxxz
mhwd -li

Sure here it comes:

System:    Host: ray-laptop Kernel: 4.14.44-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.1.0 Desktop: N/A 
           dm: lightdm Distro: Manjaro Linux 17.1.10 Hakoila 
Graphics:  Card-1: Intel driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:1c8c 
           Display: x11 server: N/A driver: modesetting unloaded: fbdev,intel,nouveau,nv,vesa 
           resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT2) v: 4.5 Mesa 18.0.4 compat-v: 3.0 
           direct render: Yes 
Warning: No installed PCI configs!
Warning: No installed USB configs!
> 0000:03:00.1 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:00:02.0 (0300:8086:3e9b) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-bumblebee            2018.05.04               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.05.04               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:01:00.0 (0300:10de:1c8c) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-bumblebee            2018.05.04               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.05.04               false            PCI
          video-nvidia            2018.05.04               false            PCI
    video-nvidia-390xx            2018.05.04               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI
Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
eDP-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080    120.00*+  60.01    59.97    59.96    59.93  
   1680x1050     59.95    59.88  
   1400x1050     74.76    59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     85.02    75.02    60.02  
   1400x900      59.96    59.88  
   1280x960      85.00    60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      75.00  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      85.00    75.05    60.04    85.00    75.03    70.07    60.00  
   1024x768i     86.96  
   960x720       85.00    75.00    60.00  
   928x696       75.00    60.05  
   896x672       75.05    60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   832x624       74.55  
   960x540       59.96    59.99    59.63    59.82  
   800x600       85.00    75.00    70.00    65.00    60.00    85.14    72.19    75.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       74.76    59.98  
   800x450       59.95    59.82  
   640x512       85.02    75.02    60.02  
   700x450       59.96    59.88  
   640x480       85.09    60.00    85.01    72.81    75.00    59.94  
   720x405       59.51    58.99  
   720x400       85.04  
   684x384       59.88    59.85  
   640x400       59.88    59.98    85.08  
   576x432       75.00  
   640x360       59.86    59.83    59.84    59.32  
   640x350       85.08  
   512x384       85.00    75.03    70.07    60.00  
   512x384i      87.06  
   512x288       60.00    59.92  
   416x312       74.66  
   480x270       59.63    59.82  
   400x300       85.27    72.19    75.12    60.32    56.34  
   432x243       59.92    59.57  
   320x240       85.18    72.81    75.00    60.05  
   360x202       59.51    59.13  
   360x200       85.04  
   320x200       85.27  
   320x180       59.84    59.32  
   320x175       85.27  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080     60.00*+  50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1400x1050     59.95  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.90  
   1280x800      59.91  
   1152x864      59.97  
   1280x720      60.00    50.00    59.94  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       60.00    59.94  
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-1-2 disconnected (normal left inverted right x axis y axis)

Try installing video-linux without auto

sudo mhwd -i pci video-linux

Okay, that ran through, but after restarting I'm stuck after login again.

which means your Xorg is fine. Something about your session is in trouble.
As a quick check you could try creating a new user and login with it, to see if it works.
Else you should check logs for some error

journalctl -b-1 -p 3
cat /var/log/Xorg.*.log
sudo cat /var/log/lightdm/*.log.old

and think of configuring PRIME

How can I access these files without being able to login?

How did you manage to get the previous reports?
In TTY, not in GUI.
The commands I suggested are aiming to the previous boot, so after a hard reboot, don't login to DM. Go to TTY and take the logs.

Hey, the other I had gotten, because I was able to get in by chance.

These logs now:


The other log file didnt exist.

Install bumblebee and bbswitch

sudo pacman -Sy bumblebee bbswitch

Didn't help. During the installation I noticed this:

After installation I tried to reboot and it got stuck at this:

Have you enabled bumblebeed?
Well, this goes far from my skills. You are trying to do what mhwd automatically.
I still suggest to use the PRIME method as proposed many times.

Forum kindly sponsored by