Getting the second graphics card (Nvidia GTX 1650) on my laptop to work, instead of the Intel on-board. Overwhelmed by the amount of documentation, don't know how to proceed.

Hello everyone, thank you for taking the time to read this.
I have a laptop (Clevo NH70RZQ) with a second Nvidia GTX 1650 graphics card:
lspci | grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
01:00.0 VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q]
(rev a1)

MHWD installed this driver:

Screenshot_20200610_200529

But 'glxinfo | grep -i vendor' gives this output:
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
Vendor: Intel (0x8086)

It seems my Intel onboard card is still in use. How do I make sure my laptop uses just the nvidia card, and not the Intel card at all? Unfortunately I can't turn off the card in the BIOS
I know a lot has been written about optimus-prime, bumblebee, etc. but actually I'm not sure how to proceed now, and I hope someone can point me in the right direction. Thank you.

I'm assuming you are using 440 driver prime? then you are gonna use the Intel gpu by default

type

inxi -G | grep OpenGL

It should say Intel HD Graphics,meaning you execute the command with the intel gpu.

Now,if you want to run an app to use the nvidia gpu,you need to type prime-run before a app,for example

prime-run inxi -G | grep OpenGL

It should say nvidia,meaning you run the app with the nvidia gpu.

Hi RaTiX, thank you for replying.

inxi -G | grep OpenGL
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.7

however:

prime-run inxi -G
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia v: 440.82 
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: N/A v: N/A

Wouldn't this mean that nothing is rendering OpenGL? :thinking:

I thought you were in hybrid mode by default,well in that case try this

Warning,I used this guide in the past Guide: Install and configure optimus-manager for hybrid GPU setups (Intel/NVIDIA) but since then,I assume Manjaro do all of this automatically since you can execute the command prime-run just fine,so I suggest try doing a backup just in case.

You need to install optimus-manager and optimus-manager-qt

pamac install optimus-manager
pamac build optimus-manager-qt

and restart the computer,now check if you have in the system tray an icon for the optimus manager,if you right click you can set what gpu want to use,if you click on hybrid mode then you can use prime-run as i said. :slight_smile:
image

If you select an option,it should log out to make the change and you need to log in again.

Now if you select hybrid try again with the command i provide you,it should say nvidia now.

image

1 Like
prime-run inxi -G | grep OpenGL
           OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82

Just installing optimus-manager seems to have done the trick. :grin: Thank you for your time!

1 Like

Thanks man, got my GTX 1050 running.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by