GNOME 3.34 - Features not working

Two features not working for me in Manjaro 18.1.0 and GNOME 3.34.1 running X11:

  1. drag-and-drop folder creation in app drawer
  2. pop-up notification selection brings you to application

I was looking forward to the new, drag-and-drop folder creation feature on the app drawer ("Show Applications"). But holding an app in the app drawer and dragging it onto another app does nothing. No folder is created, nothing at all.

In addition, the Notification Popup feature has regressed in that clicking the popup does not take you to that application. Rather, nothing happens. This feature working before the upgrade.

Am I missing a setting or settings? Or are these known issues? Thanks.

Works fine here

Can you give an exact example?

1 Like

Hi, you looked up int GNOME Tweaks, in the extensions Tab ? Maybe the option is off.

Good Luck.

@bogdancovaciu - Thanks. For the popup example: I get texts in my browser via a tool called PulseSMS. A new text appears as a popup at the top-middle of the screen. If I selected the popup before the upgrade, it would take me that text message in my browser. Now, I click it and nothing happens.

I wrote this thinking you were referring to the folder creation: Really any two applications in the window you show on your video. For example: Firefox and Files.
If I drag one onto the other, nothing happens. I can hold the moved app there indefinitely. Upon release, it slides back to its original spot.

@Mosfet - thanks - what is the name of the extension that needs to be on?

As requested

That is another thing, a more advanced option for Application Folders ... This is the default one, no other extension.

@bogdancovaciu, thanks. Unfortunately, that doesn't happen for me.

On the popup issue, I got a notification of your post. But clicking it did nothing. There is also a "Settings" bar below the popup. Clicking it also does nothing.

Are you on Wayland or X11 ?

works for me and I made sure to turnoff the extension that does the same basic thing

I'm on X11.

gnome-shell-extension-app folder-manager.

It is available in repository.
Now You don't need to use extension because as @bogdancovaciu said, GNOME 3.34 also introduced custom folders in the application overview. Simply drag an application icon on top of another to create a folder. Folders are automatically removed when all icons have been dragged out of them.
Log into wayland and try again.

Um, but...


Do this:

I had the same problem, I solved the problem with this solution from Arch wiki :

In the dconf-editor navigate to and set the value of folder-children to an array of comma separated folder names:

['Utilities', 'Sundry']

hope this help

1 Like

Keep update :wink: corrected from two months ago

Geoclue 2.5.5-2 doesn't include the latest patch. And therefore the standard install means that a default location service isn't enabled. This impacts Maps and weather and redshift.
There is a workaround to update /etc/geoclue/geoclue.conf = comment the mozilla can change the key to geoclue.

IMHO It would be much better if the Geoclue package included the latest patch 4

This solved the app overview folder issue. THANK YOU!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by