[GNOME] Can't change brightness properly

Yet another post asking for help with brightness on Gnome.
Hey guys, so ever since I tried manjaro Gnome, since a long time ago, I am not able to change my brightness properly through FN keys.
What happens:

  • Try to change with FN key, lags (sometimes even crashes my latop, which is a Dell Inspiron 15 5000, the 2015 version) and spikes (changing with the bar on the top, or xbacklight commands work tho)

What I tried:

  • change kernel parameters to acpi_backlight, all the 3 options, vendor, native, video
    no effect
  • change acpi_osi, to linux, Windows, Windows 2018, etc.
    no effect
  • change acpi_osi to: acpi_osi=
    weird effect: FN Controls now work, but totally not properly, every time I try to change my brightness, my screen literally turns off and on instantly, like flashing the screen, and then the brightness is changed
  • All possible combinations of all solutions above.
  • Installing acpilight
  • Regarding backlight configuration, from acpilight gitlab, my configuration file is:
cat /etc/udev/rules.d/90-backlight.rules
SUBSYSTEM=="backlight", ACTION=="add", \
  RUN+="/bin/chgrp video /sys/class/backlight/%k/brightness", \
  RUN+="/bin/chmod g+w /sys/class/backlight/%k/brightness"

SUBSYSTEM=="leds", ACTION=="add", KERNEL=="*::kbd_backlight", \
  RUN+="/bin/chgrp video /sys/class/leds/%k/brightness", \
  RUN+="/bin/chmod g+w /sys/class/leds/%k/brightness"
  • (and I also added my user to video group)
  • Also, I tried to comment "leds" section too, and leave only the first rule, and all combinations with xbacklight and acpi_light
  • Changing /etc/systemd/user.conf.d/40-fd-limits.conf default limite nofile to only 1024, instead of 1048576. This is really crazy, I couldn't even code react-native code anymore, and also it reduced the lag (if it were to spike, it would anyway), but the lag was still crazy, just a few seconds faster.
  • xrandr --output eDP-1 --brightness 0.4, that changed my brightness but Fn keys still not working
    Alright time to show the data people will ask me, as I've seen it on other forum posts.
    I will be showing the output for:
inxi -Fxxxz
mhwd -li
cat /etc/X11/xorg.conf.d/*.conf
xrandr --prop
lsmod | grep -Ei 'sam|lap|wmi|i80'
sudo lshw -C display
inxi -Fxxxz
System:
  Host: vsf Kernel: 5.2.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
  Desktop: Gnome 3.34.1 info: plank wm: gnome-shell dm: GDM 3.34.1 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: Inspiron 5558 v: 01 serial: <filter> 
  Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0H23N7 v: A00 serial: <filter> UEFI: Dell v: A14 
  date: 11/22/2016 
Battery:
  ID-1: BAT0 charge: 30.1 Wh condition: 30.1/32.6 Wh (92%) volts: 16.5/14.8 
  model: LGC DELL 49VTP1X02 type: Li-ion serial: <filter> status: Full 
CPU:
  Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 17566 
  Speed: 1116 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 1145 2: 985 
  3: 995 4: 994 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1616 
  Device-2: NVIDIA GK208BM [GeForce 920M] driver: N/A bus ID: 08:00.0 
  chip ID: 10de:1299 
  Display: x11 server: X.Org 1.20.5 driver: N/A compositor: gnome-shell 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) 
  v: 4.5 Mesa 19.2.2 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
  Sound Server: ALSA v: k5.2.21-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Dell driver: ath9k v: kernel port: f040 bus ID: 06:00.0 
  chip ID: 168c:0036 
  IF: wlp6s0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: e000 bus ID: 07:00.0 chip ID: 10ec:8136 
  IF: enp7s0 state: down mac: <filter> 
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-6:4 
  chip ID: 0cf3:e005 
Drives:
  Local Storage: total: 465.76 GiB used: 246.11 GiB (52.8%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 3B6Q scheme: GPT 
Partition:
  ID-1: / size: 104.25 GiB used: 41.06 GiB (39.4%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A sodimm: 38.0 C 
  Fan Speeds (RPM): cpu: 0 fan-2: 0 fan-3: 0 
Info:
  Processes: 208 Uptime: 20m Memory: 7.70 GiB used: 1.44 GiB (18.7%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: gnome-terminal inxi: 3.0.36
mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-418xx-bumblebee            2019.10.25               false            PCI


Warning: No installed USB configs!
cat /etc/X11/xorg.conf.d/*.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "br"
        Option "XkbModel" "pc105"
EndSection
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
Section "Device"
    Identifier  "Device0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
    Option      "AccelMethod" "sna"
	Option      "DRI"    "true"
EndSection
 
 
Section "DRI"
        Group  "video"
        Mode   0666
EndSection
 
 
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER"    "Enable"
EndSection
 
 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
xrandr --prop
Screen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
eDP1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
	EDID: 
		00ffffffffffff000daedc1500000000
		241901049522137802c3c59155549428
		24505400000001010101010101010101
		010101010101da1d56e250002030442d
		470058c11000001ae71356e250002030
		442d470058c11000001a000000000000
		00000000000000000000000000000002
		000c3ae00d3c6e0d0d197b000000005a
	BACKLIGHT: 937 
		range: (0, 937)
	Backlight: 937 
		range: (0, 937)
	scaling mode: Full aspect 
		supported: Full, Center, Full aspect
	max bpc: 12 
		range: (6, 12)
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	link-status: Good 
		supported: Good, Bad
	non-desktop: 0 
		range: (0, 1)
   1366x768      60.00*+  40.00  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   680x384       60.00  
   640x360       59.84    59.32    60.00  
HDMI1 disconnected (normal left inverted right x axis y axis)
	max bpc: 12 
		range: (8, 12)
	content type: No Data 
		supported: No Data, Graphics, Photo, Cinema, Game
	Colorspace: Default 
		supported: Default, SMPTE_170M_YCC, BT709_YCC, XVYCC_601, XVYCC_709, SYCC_601, opYCC_601, opRGB, BT2020_CYCC, BT2020_RGB, BT2020_YCC, DCI-P3_RGB_D65, DCI-P3_RGB_Theater
	aspect ratio: Automatic 
		supported: Automatic, 4:3, 16:9
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	audio: auto 
		supported: force-dvi, off, auto, on
	link-status: Good 
		supported: Good, Bad
	non-desktop: 0 
		range: (0, 1)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
	non-desktop: 0 
		supported: 0, 1
lsmod | grep -Ei 'sam|lap|wmi|i80'
dell_laptop            28672  0
mxm_wmi                16384  0
ledtrig_audio          16384  3 snd_hda_codec_generic,snd_hda_codec_realtek,dell_laptop
wmi_bmof               16384  0
dell_wmi               20480  0
sparse_keymap          16384  1 dell_wmi
dell_smbios            32768  2 dell_wmi,dell_laptop
dell_wmi_descriptor    20480  2 dell_wmi,dell_smbios
i2c_i801               36864  0
rfkill                 28672  9 bluetooth,dell_laptop,dell_rbtn,cfg80211
wmi                    36864  5 dell_wmi,wmi_bmof,dell_smbios,dell_wmi_descriptor,mxm_wmi
i8042                  32768  1 dell_laptop
serio                  28672  6 serio_raw,atkbd,psmouse,i8042
sudo lshw -C display
  *-display                 
       description: VGA compatible controller
       product: HD Graphics 5500
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:51 memory:f5000000-f5ffffff memory:d0000000-dfffffff ioport:f000(size=64) memory:c0000-dffff

And finally, all the posts I've read about this issue:




https://wiki.archlinux.org/index.php/Backlight


None of them worked for me.

Guys, I REALLY love manjaro, like really, everything besides my brightness works flawlessly, I can download packages easy, and I use it everyday at work and uni. I will never give up this distro and Gnome, I'm so used to them...
Please help me, I don't know what to do :frowning:

Thank you in advance! <3

i have a inspiron 7559 and i had the same issue with gnome changing backlight with the hotkeys but only with gnome. :man_shrugging:

try these for kernel parameters

acpi_osi=! acpi_osi=Linux
#OR
acpi_osi=! acpi_rev_override=1
#OR
acpi_osi=! acpi_osi=Linux i915.enable_dpcd_backlight=1

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by