Gnome fonts can't be changed is some apps

In the telegram app Bengali fonts get broken in some messages. So I tried changing fonts frome gnome-tweak-tool. But the font in Telegram app remains the same. I know that Noto Sans Bengali can fix this issue. But the Telegram app is not caring about the gnome tweak tool's settings.

See this old issue discussed here

no>
this is not my issue.
My issue is ==
even if I change font from gnome tweak tool; all the apps such virtualbox, OBS studio. etc. they continue using the default font. But I want all of them to use Noto Sans Bengali

The mentioned apps are Qt5 based apps. Check the Fonts settings tab within Qt5-Settings then.

there is no qt5-settings in here (or I couldn't find)

How did you installed Gnome, what version?

image

image

image
should I install this? there is no qt5 settings when I search. I installed manjaro Gnome. I did not manually install gnome

If you want control over the Font family for Qt5 applications, then yes, you need that to be installed. Then use it to point that you are using Kvantum ... as Kvantum can't handle Font settings.

1 Like

thank you very much. the problem is solved. But I wonder why this app was not installed in my pc.

if I change these settings after logging in as root user, will these settings be applied to all users?

No! Please do not open UI applications as root, and do not start a desktop session as root!
Each user settings and home are particular to them. If you want to apply settings to be universal to them, use the /etc/skel/ ...

1 Like

Just noticed this notice in updates:

I didn't yet test this myself yet, if this will keep the GTK+ Fonts to the Qt5 applications, but it might be the reason you did no had the qt5ct aka Qt5 Settings installed. I'll consult @Ste74 and @Chrysostomus about this.

there is nothing in /etc/skel/
:confused:

You installed the minimal ISO of Manjaro Gnome or from Architect? That might explain it.
I think you need manjaro-gnome-settings for that.

i don't think it is the minimal version
i downloaded it from manjaro website
:sweat: :weary:

it is already installed here
image

Forum kindly sponsored by