Gnome: how to disable popup on keyboard layout switching?

When I switch keyboard layout in quake-like terminal (and it is tilix) Gnome popups big indicator showing selected layout. This popup results in terminal focus lost and auto-closing (and yes, I can not reject auto closing option!).

How to disable this extremely useful and beautiful popup window on layout switching?

(Yes, I have reassigned shortcut to avoid Super and switching to desktop overview mode)

Open Settings and on Keyboard Shortcuts you can disable on Typing the two Switch input sources, or just one, or change it to something else than what is now.

image

Then open Tweaks > Keyboard and Mouse > Additional Layout Options and in the Switching to another layout set what you prefer.

image
Down that list there is the Win+Space that can replace the one from Settings as Super+Space
image
in case you are used to that key combination, but then on Settings needs to be disabled to work without the popup.

1 Like

Yes, it results in popup avoiding, thanks! Unfortunately, the issue still exists: for some reason the switching (I have tried Alt+Shift and Caps) still results in terminal focus lost (with consequent auto-hiding).

Not sure i follow. Just installed tilix to test it and the window remains in focus regardless the way i switch the layout. You might have some other options, elsewhere ... you might have customized.

Yes, I have set "Hide window when focus is lost" option on in Quake settings tab.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by