Gnome Intel Screen Tearring

I am really sorry to be asking this. But I am getting really bad screen tearing on my laptops current setup.

Vanilla Gnome install.

System:
  Host: Raldoron Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: Gnome 3.36.3 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: SAMSUNG 
  product: RV420/RV520/RV720/E3530/S3530/E3420/E3520 v: 0.1 
  serial: <root required> 
  Mobo: SAMSUNG model: RV420/RV520/RV720/E3530/S3530/E3420/E3520 v: FAB1 
  serial: <root required> UEFI: Phoenix v: 04PQ date: 09/03/2011 
Battery:
  ID-1: BAT1 charge: 39.1 Wh condition: 48.8/48.8 Wh (100%) 
  model: SAMSUNG Electronics status: Unknown 
CPU:
  Topology: Dual Core model: Intel Core i3-2330M bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17567 
  Speed: 798 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Samsung Co driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.org 1.20.8 
  driver: amdgpu,ati,intel,modesetting,nouveau,radeon 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) 
  v: 3.3 Mesa 20.0.7 direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Samsung Co driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:
  Device-1: Intel Centrino Wireless-N 130 driver: iwlwifi v: kernel 
  port: efa0 bus ID: 01:00.0 
  IF: wlp1s0 state: down mac: d2:8b:38:5a:02:68 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Samsung Co driver: r8169 v: kernel port: 2000 bus ID: 02:00.0 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: e8:03:9a:1c:82:76 
Drives:
  Local Storage: total: 119.24 GiB used: 62.61 GiB (52.5%) 
  ID-1: /dev/sda vendor: SK Hynix model: HFS128G32MNB-2202A size: 119.24 GiB 
Partition:
  ID-1: / size: 107.92 GiB used: 62.61 GiB (58.0%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 45.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 192 Uptime: 5m Memory: 7.69 GiB used: 1.06 GiB (13.8%) 
  Init: systemd Compilers: gcc: N/A Shell: bash v: 5.0.17 inxi: 3.0.37 

Again, I know this is the most common issue ever. But I cannot find a solution.

Any ideas how I can fix this?
Thanks in advance all!

Remove the drivers in MHWD. See if you use or not xf86-video-intel
Also check this:
https://wiki.archlinux.org/index.php/Intel_graphics#Tearing

Do i remove the drivers in MHWD gui or in a terminal?

In the GUI "video-linux" is the only one with a tick next to it.

I checked out that Arch Wiki page before posting. For whatever reason, I don't have the file "/etc/X11/xorg.conf.d/20-intel.conf".
So I wasn't sure if I could just create a new file with the following lines in it.

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"

  Option "TearFree" "true"
EndSection

Or if the file needed to contain more information. The wiki doesn't really specify.

Thanks for the help!

Sorry to bump. Still not been able to resolve this.

Get really bad tearring in fullscreen youtube videos. As well as scrolling webpages. Also get problems when watching videos in celluloid or mpv.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by