gnome-layout-switcher 0.8.7-1 -> 0.8.8.2 requires to downgrade multiple packages

Hello everyone,

I received a notification for new upgrades and I was surprised that the new upgrade wanted me to downgrade packages.

Take a look at this screenshot:
Screenshot from 2020-04-25 23-28-40

As you can see I have gnome-layout-switcher 0.8.7-1 and the new package version is 0.8.8-2. For some reason the dependencies for the new version are lower than those of the current version.

I am not a package expert, but I think that this is weird and I wanted to consult with you before completing this upgrade.

This is all fine. My recent change in Manjaro Gnome development: simply removed the nomenclature schemas :wink:
Confirm the transaction

1 Like

@Ste74 why is it pulling manjaro-gnome-settings-18.0? Are you sure everything went as it should?


Uhmm you are right why v18?
This is wrong

Having the same issue here. Went to install some software and noticed it wanted to downgrade those packages from v19 to v18. Suppose I will hold off on that for now.Screenshot from 2020-04-25 14-39-45

I was updating my system and ran into a update conflict for Manjaro settings 18 and 19. I did some searching around and saw a lot of guidance to search the forum for issues. I found a comment from a update thread that mentioned the update conflict from 1/30/2020 that mentioned something about gnome-layout-switcher.

image

I removed gnome-layout-switcher and then was able to upgrade all my applications and such. But then i was adjusting some settings and noticed my dash to dock settings was not launching (right clicking the all applications button)

image

This came up because my "show applications" overlay applications icons were tiny and unreadable all of a sudden. I tried reinstalling gnome-layout-switcher and committed the changes that @The_MetalDog screenshot and now my system won't boot.

dd44ac87dad5de1afd1203e8edc3bc880f82ef62_2_548x500

Just adding to this thread that chasing the troubleshooting for this broke my installation

@Ste74 I did as you told me and all updates went smoothly, but now I see this caused @cazrep to have booting issues. Should I be worried as well and use timeshift to revert the changes?

Okay, I think I found the issue. New version of gnome-layout-switcher was pushed to all branches, while the versionless gnome settings were pushed only to unstable branch. I updated the packages in testing and stable too, so if you wait until repos are updated and update then, it should be okay like it was in unstable branch. Fingers crossed that something did not break....

2 Likes

Looks like it's resolved here. The updates show the removal of 19.0 to be replaced a version-less title of 20200425 for the new installs. The old ones were 20200324, 20200331, and 20200412. Here we go! Thank you for the quick fix.

So I ran "pacman -Syu" and I got this:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: **gnome-shell-extension-appfolders-manager and manjaro-gnome-assets-19.0 are in conflict. Remove manjaro-gnome-assets-19.0?** [y/N]

Is this the correct behaviour or still my repos are not updated?

Thank you!

this is a new issue, 11 hours ago it was fine

I pushed the fix to all branches 5 minutes ago. Update after your mirror has been updated.

Essentially, there was a replacement cycle that would trigger with every update. Now we just dropped all the 18.0 and 19.0 packages.

2 Likes

Yes it's all good, updated the system without any dependencies issues. You are great :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by