Gnome Opening folders in mpv

I will post something next time I get the issue as it isn't consistent.

Ok. Another situation where a similar thing is happening.

Fresh install, Manjaro xfce, different machine.
In the LightDM GTK+ Greeter settings. I clicked to change the background image. Was greeted with a select a file dialog.
Right click on directory named "xfce" then chose "Open with File Manager"
Audacious opens displaying an error message "No Files Found"....


Check again the mimeapps.list (or the mimeinfo.cache) file for the entry in question.

This time (Xfce with Thunar as file manager) the default entry should be:

Did you perform that action on the machine running Xfce (replace mpv with Audacious)?

No. Literally just installed it. Ran update, restarted, opened up Light DM Settings.
Hadn't opened a single program before that apart from the terminal to update.

Here are the contents of the mimeaps.list file

[Default Applications]

[Added Associations]

These entries are not present in the mimeapps.list file on my system, hence I'm not sure if removing them is a wise decision. It's something you can try though, but before that be sure to copy the mimeapps.list file somewhere in your home directory (as a backup, just in case).

After removing the entries, try to reproduce the steps you followed to change the wallpaper in LightDM Gtk+ Greeter settings.
If it doesn't make any difference, copy the backup mimeapps.list file from your home directory back in ~/.config.

Thanks for the reply.
I removed the lines you mentioned and tried to reproduce the issue as before.
Instead of opening in Audacious, it opens Catfish.

Thanks again.

Although the directory should open in Thunar. What a mess! :scream:

Open the Terminal and run:
xdg-mime default Thunar-folder-handler.desktop inode/directory

After that try to open the directory you mentioned before and see if this solves your issue.

If the above approach doesn't work, open the file mimeinfo.cache located in /usr/share/applications/ and look for the following line (this is how the entry looks in my system):

If this line is not present in the file, add it (the order of the .desktop file references is important) under [MIME Cache] and try to reproduce your issue again.
If the directory still doesn't open in Thunar, remove the line you just added from the file.

This is all I can suggest at the moment. :man_shrugging:

Ahh ■■■■■ I entered that command as root...
Now when I right click on the folder it opens in thunar, but as root.

I did enter the command on its own before I used sudo, and it still opened with catfish. That's why I tried with root. Or could that be that LightDM needs to authenticate in order to change settings?

Indeed, LightDM needs to be run with sudo to make any changes to its settings, so right-clicking on the directory and selecting it to open with the file manager results in opening it as root in Thunar.

Try to open a directory in Firefox for example, File > Open File..., right click on a directory and select Open With File Manager. It should open the directory in Thunar without being root.

Yeah it works now in firefox.

So that kinda begs the question of why it was like that in the first place. It was literally a fresh install.

Thank you for all your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by