gnome-shell update seems to pull in python2 dependencies

sudo pacman -S gnome-shell
Alias tip: _ pacman -S gnome-shell
resolving dependencies...
warning: ignoring package python2-2.7.17-1
warning: cannot resolve "python2", a dependency of "python2-gobject2"
warning: cannot resolve "python2-gobject2", a dependency of "ibus"
warning: ignoring package python2-2.7.17-1
warning: cannot resolve "python2", a dependency of "python2-dbus"
warning: cannot resolve "python2-dbus", a dependency of "ibus"
warning: ignoring package python2-2.7.17-1
warning: cannot resolve "python2", a dependency of "python2-gobject"
warning: cannot resolve "python2-gobject", a dependency of "ibus"
warning: cannot resolve "ibus", a dependency of "gnome-shell"
:: The following package cannot be upgraded due to unresolvable dependencies:
      gnome-shell

:: Do you want to skip the above package for this upgrade? [y/N] y
looking for conflicting packages...
 there is nothing to do

Something wrong here.

No, all is good. Upstream decided that python2 is still needed.

https://bugs.archlinux.org/task/65771

You couldn't make it up!! :rofl:
Adding to ignore package.

1 Like

Never fear, they replaced ibus with libibus.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by