GNOME, two monitors and Qt problems.

Hi. I have recently installed Manjaro GNOME 18.04 stable. Everything works fine except the Qt applications. I have two monitors and when I pass the Qt application to the secondary monitor the characters of the application increase. They happen to the traditionally installed Qt applications and to those installed with Flatpak. I leave you a video in which you can see the problem with the OBS Studio application.
https://youtu.be/6p4kYazgX8o
Imgur

Read this post maybe it is related with your issue.

https://wiki.archlinux.org/index.php/HiDPI#Qt_5

Good luck

Several possible factors to check.

inxi -SMGxxxz
mhwd -li
xrandr
cat /etc/X11/xorg.conf.d/*.conf
xdpyinfo | grep -B2 resolution

inxi -SMGxxxz

[patrick@patrick-pc ~]$ inxi -SMGxxxz System: Host: patrick-pc Kernel: 5.0.9-2-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: Gnome 3.32.1 wm: gnome-shell dm: GDM 3.32.0 Distro: Manjaro Linux Machine: Type: Desktop Mobo: ASUSTeK model: PRIME X370-PRO v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 4207 date: 12/08/2018 Graphics: Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: eVga.com. driver: nvidia v: 418.56 bus ID: 09:00.0 chip ID: 10de:1b06 Display: x11 server: X.org 1.20.4 driver: nvidia compositor: gnome-shell resolution: <xdpyinfo missing> OpenGL: renderer: GeForce GTX 1080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 418.56 direct render: Yes

mhwd -li

`[patrick@patrick-pc ~]$ mhwd -li

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

      video-nvidia            2018.08.09               false            PCI

Warning: No installed USB configs!`

xrandr

[patrick@patrick-pc ~]$ xrandr Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 32767 x 32767 DVI-D-0 disconnected (normal left inverted right x axis y axis) HDMI-0 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 160mm x 90mm 1920x1080 60.00*+ 59.94 50.00 29.97 25.00 23.98 60.05 60.00 50.04 1680x1050 59.95 1600x1200 60.00 1440x900 59.89 1280x1024 75.02 60.02 1280x960 60.00 1280x800 59.81 1280x720 60.00 59.94 50.00 1152x864 75.00 1024x768 75.03 70.07 60.00 800x600 75.00 72.19 60.32 56.25 720x576 50.00 720x480 59.94 640x480 75.00 72.81 59.94 DP-0 disconnected (normal left inverted right x axis y axis) DP-1 disconnected (normal left inverted right x axis y axis) DP-2 disconnected (normal left inverted right x axis y axis) DP-3 disconnected (normal left inverted right x axis y axis) DP-4 disconnected (normal left inverted right x axis y axis) DP-5 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm 1920x1080 60.00*+ 59.94 50.00 1680x1050 59.95 1600x900 60.00 1440x900 59.89 1280x1024 60.02 1280x800 59.81 1280x720 60.00 59.94 50.00 1024x768 70.07 60.00 800x600 72.19 60.32 56.25 720x576 50.00 720x480 59.94 640x480 72.81 59.94

cat /etc/X11/xorg.conf.d/*.conf

`[patrick@patrick-pc ~]$ cat /etc/X11/xorg.conf.d/*.conf

Read and parsed by systemd-localed. It's probably wise not to edit this file

manually too freely.

Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "es"
Option "XkbModel" "pc105"
EndSection

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 418.56

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung C27F390"
HorizSync 30.0 - 81.0
VertRefresh 50.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 1080 Ti"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "DFP-7"
Option "metamodes" "DP-5: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, HDMI-0: nvidia-auto-select +1920+0"
Option "SLI" "Off"
Option "MultiGPU" "Off"
Option "BaseMosaic" "off"
SubSection "Display"
Depth 24
EndSubSection
EndSection`

xdpyinfo | grep -B2 resolution

[patrick@patrick-pc ~]$ xdpyinfo | grep -B2 resolution screen #0: dimensions: 3840x1080 pixels (321x90 millimeters) resolution: 304x305 dots per inch

Please repair your post, so it can be readable correctly, per forum format
How to write/edit a proper and easily readable Discourse forum post

Have you tried previous advice from @XtyM or anything else?
Have you used qt5ct to change font sizes?
Check for local settings in

~/.config/qt5ct/

Maybe you want to look into this part closer, to be consistent with your setup. Either is AUTO, or is ABSOLUTE ... but not "mixup" ... Try to use this instead:

    Option         "metamodes" "DP-5: 1920x1080_60 +0+0 {ForceCompositionPipeline=On}, HDMI-0: 1920x1080_60 +1920+0 {ForceCompositionPipeline=On}"

Any source of this advice? :laughing:
I had it mixed for the time I was using nvidia only. I didn't know of any advice against. Also, this mix was provided by the nvidia auto-generated conf..

No source for this. I don't wear short and long pants at the same time even tho is possible and might be functional/fashionable ... so i apply same "principle" on everything i do :grin:

1 Like

This is a problem that also happens with Ubuntu 19.04 that also uses GNOME 3.32. I left them a message on the Launchpad forums but it seems to me that they pass the ball from one to the other as if it were in flames. I leave the link in case anyone is interested. The problem is the same, when you pass a Qt application from the main monitor to the secondary monitor the letters increase. https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1824753
Greetings, see you later.

Have you checked anything as suggested in previous posts?
At least confirm that you checked and failed.. :tipping_hand_man:

1 Like

I'll make a test with it too, but my test with Manjaro Gnome ended with the conclusion that i can't reproduce the issue. I have dual monitor setup and both are 1920x1080_60 as yours are. Are you using extra configs for scaling because one of your monitors has a different actual surface size ?

I have this problem with clean installations without touching any configuration.

I'll leave you another video. Here you can see that the problem is not generated immediately. Everything is fine until the software goes through a little more than half on the other monitor.
This hasn't solved anything either:
Option "metamodes" "DP-5: 1920x1080_60 +0+0 {ForceCompositionPipeline=On}, HDMI-0: 1920x1080_60 +1920+0 {ForceCompositionPipeline=On}"
https://youtu.be/fNkXt1gsNbM

Are you reading posted answers, or am I wasting my time?

Use qt5ct to see for any changes. Here 's an image, as you may not be good on reading..
Screenshot-120

The fault is not in the qt5ct configuration

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by