Google Analytics blank page Chromium & Firefox

I'm running the latest Manjaro KDE - all packages are up to date. About a week ago, Google Analytics stopped loading. It shows a blank page after login. It stops at GET https://maps.googleapis.com/maps/api/js/AuthenticationService.Authenticate?1shttps%3A%2F%2Fanalytics.google.com%2Fanalytics%2Fweb%2F%23%2Freport%2Fvisitors-overview%2F&4sAIzaSyBMV3KncHiZJKbFHgp6rJ34a2w5W5nOWJM&callback=_xdc_._xtl71x&token=9084 with response /**/_xdc_._xtl71x && _xdc_._xtl71x( [1,null,0] ). And the odd thing is that this happens with every Analytics account I have and also in both Chromium and Firefox. Of course I tried incognito sessions in both, disabling all plugins, etc. No luck. It works fine with Chrome from AUR though, and also with other OS's. This is super weird and I have no idea what could cause this. Anyone else experiencing the same issue or got an idea what could cause this or how to debug it further?

Maybe try a new profile?
Could be a setting somewhere, or a corrupt file in the profile.

I tried with different Firefox profiles already. Also, considering I tried this in incognito mode without luck with both Chromium and Firefox, it should not be related to profiles/plugins or anything. If it were just Chromium it wouldn't be as weird - but it's both Chromium and Firefox, works only with Chrome.

So wait - the page you're loading is maps.googleapis.com. How is this related to Google Analytics? Does analytics.google.com load?

Have you installed any hosts-based adblocking?

1 Like

I just figured it out. I had all my bookmarks set to https://analytics.google.com/analytics/web/#/report/visitors-overview/ which you now apparently can't access directly anymore (blank page). Same issue with https://analytics.google.com/analytics/web/#/embed/report-home/ etc.

Now after you asked if I can access analytics.google.com, I tried (although I could swear this wasn't working before) and it works well when going through that redirect. I'm sure I tried this a couple of days ago without luck with more than one browser, but I could be wrong. It's definitely related to changes in GA auth then and not to Manjaro packages. Sorry & thanks for the help!

If I understand incognito mode, it will still use your profile, and maybe some addons. But it won't save anything new you do in that session.

I always thought it uses a "guest profile" without any plugins, local cache or cookies. Just assumed that because none of the non-default plugins I have installed work in incognito, your login sessions are gone and the static file cache isn't being used either. I could be wrong though -- I mean I'm the guy who wasn't able to open Analytics for a week because he didn't think about just trying the default URL instead of a particular data view URL. :zipper_mouth_face:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by