Graphic driver display issues - hybrid intel and Nvidia - external monitor

Hey all

I’m a complete newbie to Linux. In beginning stages of understanding all the terminology, commands etc ... I’m not techie.
I have a Dell XPS 502 with intergrated intel and Nvidia GF 540m card.
After a disappointing start with POP OS, I decided to try Manjaro KDE and seemed very impressive. BOTH monitors appeared to work at first. But then I noticed some “lag” wave effects when scrolling fast. I’m not exactly a gamer but want to do graphics work, I’m illustrator.
So after getting somewhat familiar I tried switching to Bumblebee hybrid drivers hoping for better performance.
But then external monitor stop working, pc no longer projected to external. So I tried the main Nvidia only drivers and no change. Then I tried going back to “video Linux” drivers again, but still no external monitor working.
I read about Optimus, installed and ran that, but again after installing hybrid and standalone Nvidia drivers, it told me it can’t find any optimus drivers.

Again I’m very new, baby steps ... any help would be appreciated, but my knowledge in terminal commands limited. From a previous post I got these commands & info that said would be requested.

==============================

rob@rob-dellxpsl502x ~]$ inxi -Fxxxza --no-host
System: Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64
root=UUID=17e7c708-1792-49fe-9df2-448b23ff19b5 rw
quiet apparmor=1 security=apparmor
resume=UUID=0a20dec3-73a0-4338-aed6-83e8e3d40cca
udev.log_priority=3
Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 wm: kwin_x11 dm:
SDDM Distro: Manjaro Linux
Machine: Type: Portable System: Dell product: Dell System XPS L502X v:
N/A serial: Chassis: type: 8
v: 0.1 serial:
Mobo: Dell model: 0714WC serial: UEFI [Legacy]:
Dell v: A12 date: 09/07/2012
CPU: Topology: Quad Core model: Intel Core i7-2630QM bits: 64
type: MT MCP arch: Sandy Bridge family: 6
model-id: 2A (42) stepping: 7 microcode: 2F L2 cache: 6144 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 31941
Speed: 798 MHz min/max: 800/2900 MHz Core speeds (MHz): 1:
798 2: 798 3: 798 4: 798 5: 798 6: 798
7: 798 8: 798
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge
pages
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache
flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass
disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and
__user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel 2nd Generation Core Processor Family
Integrated Graphics vendor: Dell driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:0116
Device-2: NVIDIA GF108M [GeForce GT 540M] driver: N/A bus
ID: 01:00.0 chip ID: 10de:0df4
Display: x11 server: X.Org 1.20.8 driver: modesetting
compositor: kwin_x11
resolution: 1920x1080~60Hz
OpenGL: renderer: N/A v: N/A direct render: N/A
Audio: Device-1: Intel 6 Series/C200 Series Family High Definition
Audio vendor: Dell
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID:
8086:1c20
Device-2: NVIDIA GF108 High Definition Audio driver:
snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 10de:0bea
Sound Server: ALSA v: k5.6.19-2-MANJARO
Network: Device-1: Intel Centrino Wireless-N 1030 [Rainbow Peak]
driver: iwlwifi v: kernel port: efa0
bus ID: 03:00.0 chip ID: 8086:008a
IF: wlp3s0 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit
Ethernet driver: r8169 v: kernel port: 2000
bus ID: 06:00.0 chip ID: 10ec:8168
IF: enp6s0 state: down mac:
Device-3: Dell F3607gw v2 Mobile Broadband Module type: USB
driver: cdc_acm,cdc_ether,cdc_wdm
bus ID: 2-1.6:4 chip ID: 413c:8184 serial:
IF: wwp0s29u1u6i6 state: down mac:
Drives: Local Storage: total: 698.64 GiB used: 65.52 GiB (9.4%)
ID-1: /dev/sda vendor: Seagate model: ST9750420AS size:
698.64 GiB block size: physical: 4096 B
logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial:
rev: DEM1 scheme: MBR
Partition: ID-1: / raw size: 689.83 GiB size: 678.01 GiB (98.29%) used:
65.52 GiB (9.7%) fs: ext4
dev: /dev/sda1
ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap
swappiness: 60 (default)
cache pressure: 100 (default) dev: /dev/sda2
Sensors: System Temperatures: cpu: 49.0 C mobo: 49.0 C
Fan Speeds (RPM): N/A
Info: Processes: 215 Uptime: 1h 25m Memory: 7.67 GiB used: 1.06 GiB
(13.8%) Init: systemd v: 245
Compilers: gcc: 10.1.0 alt: 8 Shell: bash v: 5.0.18 running
in: konsole inxi: 3.0.37

[rob@rob-dellxpsl502x ~]$ mhwd -li

=======================

video-hybrid-intel-nvidia-340xx-bumblebee 2019.10.25
false PCI
video-modesetting 2020.01.13 true PCI

image

see this topic

I’m very confused by that ... bit overwhelming to be honest, will try wrap my head around it.
How do I know if my card supports 440 or not? And how do I know if my card is optimus enabled?
I checked, no way to switch off iGPU in bios.

Heck isn’t there an easier way to get Nvidia intel dual screen working? That info is crazy for someone new to Linux ... my brain just sizzled. I need some more direction on what to do, what line to run to activate this and maybe some short child like (for me) instructions on how to implement this.
Possible or do I need to first need to learn Linux before being able to set up graphics on external monitor?

Ps ... originally Manjaro at least detected my external monitor, but now it’s not even detected under settings/display, only shows laptop display, no external hdmi display ... even although I tried all the available drivers again (except vesa)

Newbie here jumping in... having exact same issue. I connected my laptop to a second monitor. Synced up very easily.. and then I updated the graphics driver which is now the 440xx prime, and it's not even trying to find my monitor now. Can't find much info so far on how to get things to work properly.. hmm

Hi ... apparently (and I might be wrong) ... so far Only the Linux-video drivers support external monitors. Apparently the Bumblebee and Nvidia drive does not , for now

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by