Graphic driver freezes booting


I have recently installed Manjaro 16.11 lxqt on my computer (i7-6700HQ / GTX 960M), but I encounter some problems after having installed "video-nvidia" graphic driver.

Indeed, when "video-nvdia" is installer, the following boots always freeze.
I have to boot with "pci=nomsi", and then uninstall the graphic driver, using tty2.

After that, it's ok, I can launch Manjaro... But I'm still without graphic driver.

Because my web searches were unsuccessfull, I'm now searching for some help.
I begin to be short of inspiration to lead others serches.

Thanks in advance.

I'm not running Nvidia, so I cannot tell if this article is outdated:

Do you have an intel gpu also? You could use that to boot, then configure from there.

Check with inxi -Fxz

Are you married to the idea of soley using the proprietary video-nvidia driver?

I use video-hybrid-intel-nvidia-bumblebee, and use optirun command to switch from intel gpu to nvidia gpu.

MHWD command to remove nvidia driver and install bumblebee hybrid driver would be

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee

You should be able to install this from tty2, if not then boot into live environment and use manjaro-chroot

Pretty sure this card is not supported by Nouveau driver yet.



Thanks for the link eugen.
Unfortunatly, I have already read it, and it wasn't really helpfull.

I did a inxi -Fxz suerid. I paste the "Graphics" result below :
Graphics: Card-1: Intel HD Graphics 530 bus-ID: 00:02.0 Card-2: NVIDIA GM107M [GeForce GTX 960M] bus-ID: 01:00.0 Display Server: X.Org 1.17.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz GLX Renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) GLX Version: 3.0 Mesa 13.0.1 Direct Rendering: Yes
I guess so I have an intel GPU also.
(Note : This output was released while I hadn't any graphics driver installed)

So, I installed the video-hybrid-intel-nvidia-bumblebee with the same commnd-line you have written.
By the way, because of conflicts, I had to uninstall catalyst-server and it dependencies.
I am not sure, but I think it was this driver which was installed when I did the automatic installation
sudo mhwd -a pci nonfree 0300

Unfortunatly, the system freezes once more on the following line :
/dev/sda1: clean, 149856/604473344 files, 6715779/241882884 blocks

And I am not able to enter in tty mode anymore. :confused:

why did you have that on an Nvidia machine?
Some links from Arch Wiki for similar hardware, maybe useful

I don't remember exactly if it is because steam or rocket league.
But I am sure it is because of one of the two

Anyway, thanks for your links. There are very intersting. :slight_smile:
I found two interesting quotes :

nouveau problem ==> Installation media sometimes produces a lot of error messages during boot. This is a bug in the nouveau driver. *** Later you can disable nouveau module:

keyboard ==> In order to make all keyboard function keys (FN+F{1..12}) generate correct signals - add kernel parameter 'acpi_osi=' (without quotation marks) to your bootloader.

Intel/Nvidia ==> The Optimus setup consists of the integrated Intel chip connected to the laptop screen and the Nvidia card runs through this. As such, the Nvidia chip cannot be used without the Intel chip

And an additional research about Optimus management from boot.

Help Ubuntu ==> The vga_switcheroo mechanism will only be active when the kernel is booted with either the "modeset=1" kernel option, and/or the "nomodeset" option being absent.
where XXX = can be: "noveau" for NVIDIA GPU "i915" for Intel GPU

Many new things for my linux knowledge.
If I understood properly : :microscope:

  1. 'acpi_osi=' might be usefull to be sure that Ctrl + Alt + F2 open well tty2
  2. While Optimus is active, NVidia chip cannot work without Intel chip
  3. "nouveau" is the free nvidia driver, and don't work with my configuration ; while nvidia is the nonfree driver

Towards to this logic, I tried to boot with the following arguments (and without nomodeset) :
acpi_osi= modprobe.blacklist=nouveau i915.modeset=1

Unfortunatly, that was not very conclusive :confused:
I am stuck with the following screen, and it is still impossible to access to tt2

Couple of questions.

Your system was working fine before you installed the video-nvidia driver? How did you install this driver? If you use MHWD it installs all the packages required (ie including the associated packages for your installed kernel versions, nvidia-settings, etc).

Are you able to boot into Manjaro Live environment?

If so, what is the output of mhwd -li in the Live environment?

What kernel version are you using (uname -r)?

The systemd journal flush service is an issue also. What file system are you using? Do you have enough disk space on your root partition? How big are you journal logs? This could stop the system booting (I noticed a couple of thread on Arch Forums), the command systemctl status systemd-journal-flush should provide error messages to start diagnosing.

Catalyst is the non-free AMD GPU driver, and catalyst-server is the xorg server for this driver. No idea why this was installed in the first place when you have an NVidia card. Do you have any other catalyst packages installed? These could generate conflicts, but without knowing what is installed, or how they got there, I am purely guessing.

My advice would be to forget the NVidia card for the moment, and simply get your system booting using your intel gpu. Once this is working you can backup your system (I use Clonezilla) and then embark on setting up nvidia card with either bumblebee-nvidia or only nvidia drivers. If things go pear shaped, restore, figure out what went wrong, and go again.

The best way to do this is via the Live environment, using the manjaro-chroot command, followed by mhwd command. This allows you to configure your system drivers config from your Live environment.

manjaro-chroot -a

Wow ! Thanks a lot for the chroot tip.
I was able to boot on my USB stick, and in following this tuto, I could access to my install.
I feel relieved to know that I am not only limited to the boot options.

So, concerning your questions :

  • I suppose my system was working fine before I installer the video-nvidia driver. I think I didn't use it enough to say it, but in any event, I could boot

  • This driver was installed using the following command : sudo mhwd -i pci video-nvidia

  • The output of mhwd -li is disturbing :
    Warning : config '/var/lib/mhzd/local/pci/video-hybrid-intel-nvidia-bumblebee/MHWDCONFIG' is invalid! Warning : No installed PCI configs
    I took a look at this file, and it is empty.
    Moreover, the command mhwd -r pci video-hybrid-intel-nvidia-bumblebee returns to me an error, which saying that this driver is not installed.

  • I use the 4.8.5-2 kernel version, which is provided with the release 16.11. Because of the architecture of my processor. Skylake is only supported from the 4.6 kernel version if I remember well.

  • I am using an ext4 file system

  • I have 922.7GB on my root partition, and it is a fresh install. I hope I have enough space.

  • I have 12 files in /etc/systemd/. Each one have a weight of 4blocks... So, 2kB if I have understood well ?

  • Unfortunatly, I can't run systemctl status systemd-journal-flush. The system ignore the request, because it is launched in chroot.

  • Concerning the catalyst-server, I think it is because of the installation of rocket league, nothing more.

  • Using pacman -Q | grep catalyst, I found one package installed ==> mhwd-catalyst.

  • By the way, I did pacman -Q | grep xf86-video-intel, and I saw this package was installed.
    Note : I have run my USB stick with modprobe.blacklist=nouveau xdriver=vesa boot options.
    Might it have a relation with the fact that video-hybrid-intel-nvidia-bumblebee is detected as non installed ?

I guess you are right sueridgepipe, I should build a stable environment, clone it, and try things after.
Out of scope ==> I did not know this expression "If things go pear shaped". It is such nice :blush:

But now, I am a little bit lost.

  1. I do not understand if bumblebee drivers are installed, not installed, or installed with a corrupted installation ?
  2. Does my intel graphics driver be installed ?
  3. Anyways, should I try to follow your link ?

I am not very fluent to write in english. I apologize for my mistakes and hope this message was understandable.

1 Like

Ok, so, I do not know what has gone wrong with the video-hybrid-intel-nvidia-bumblebee.
No matter, I installed it once more, then, I uninstall it. All that with the mhwd-chroot environment.

Now, I can boot and go on tty2, but the tty1 is still stuck.
I can not reach the boot screen.

I tried to boot with different graphic drivers intalled, such as video-intel, video-vesa, video-nvidia.
Each time, I have been stuck.
And I was forced to use modprobe.blacklist=nouveau pci=nomsi to avoid some errors.

Surprisingly, video-hybrid-intel-nouveau-bumblebee seems to work not so bad.
In fact, I am still stuck, but I have not to use some boot parameters.

Here it is the output of journalctl for a boot try, with video-hybrid-intel-nouveau-bumblebee installed.

This file is so big. I do not really know what I am supposed to find here. :confused:
I would need some help to read it.

1 Like

After some hard night & coffee, I found a partial solution. :slight_smile:

First, I installed video-intel with sudo mhwd -i pci video-intel
Then, in order to the ArchWiki page, I created the file /etc/X11/xorg.conf.d/20-intel.conf, with the following content :
Section "Device" Identifier "Intel Graphics" Driver "intel" Option "DRI" "false" Option "AccelMethod" "sna" EndSection

So, no graphic card for the moment. But I think I have a lot of things to learn before gaming.

Thanks a lot sueridgepipe & eugen-b for your messages. They were really instructive.

See ya'

I searched for keywords "nvidia" (0 hits), "intel" and "failed" in the journal. Found several occurances of sddm failed. Maybe try a different DM?

Well, this is going to drive me crazy.

I replaced the lxqt environment by the xfce environment.
Then, I installed video-hybrid-intel-nvidia-bumblebee.
Finally, the system freezed while booting.

Thanks anyway for the tip eugen-b.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by