Graphic driver trouble - Quadro P600 on Manjaro Gnome

Hi, I'm absolutely new on Manjaro and I really appreciate the job you all do here. It looks great to me, nevertheless I couldn't get it working yet.

I assume, the graphic driver is not working. I don't care which driver to use (free or proprietary), as long as the graphic card starts working.

Here is what I have done so far:

  • Installing Manjaro Gnome 17.1.12-stable-x86_64
    The installation won't start without the adjustment, shown in this thread (answer from joeky888)
    -- activating non-free drivers in grub
    -- editing the kernel parameters in grub, adding systemd.mask=mhwd-live.service
    -- in live image deleting the net- and video-identifier part in /usr/lib/calamares/modules/mhwdcfg/
    -- installing Manjaro with auto-login after boot enabled (if not, I will just get a black screen after login)

  • Installing proprietary nvidia driver
    -- Any contact with the nvidia graphic card will result in a freeze.
    Opening "settings" freezes the system,
    inxi -G
    will freeze the terminal.
    -- When I blacklist nouveau, following this thread (answer from i_love_r34), I can, after the reboot, run the commands without freeze:
    -- creating a file /etc/modprobe.d/blacklist.conf containing

blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
blacklist nv
blacklist uvcvideo

-- after that I run
sudo mhwd -a pci nonfree 0300

as shown in the wiki (Configure NVIDIA (non-free) settings and load them on Startup), but
mhwd -li

gives me (after the reboot) a [n/a] under "graphic driver". Also nvidia-settings was not accessible after this step.

Now I only get a black screen when I boot and I am indeed unsure, what to do next.
Any help will be highly appreciated. Thank you very much :slight_smile:

-- Intel i7 (8. gen) 8750H Prozessor 6x 2,20 GHz
-- Quadro P600
-- 16 GB DDR4 RAM
-- no OS pre-installed

nope ... you have to use the file created by mhwd command, that means /etc/modprobe.d/mhwd-gpu.conf
and also aside the list you have already for blacklist, add this two too:

blacklist drm_kms_helper
blacklist drm

BUT ... i think the Quadro P600 is Fermi family and you might have to install the video-nvidia-390xx ... do it from Manjaro Hardware Detection Gui.

1 Like

Sorry, I'm a bit stuck here. This file does not exist yet. How can I create it by a mhwd command? I assume, it's not enough to just create it with gedit or nano.

Thanks a lot for your fast reply

Not manually.

  • Backup the blacklist file (rename extension from conf to conf.bak)
  • Reboot and edit grub menu to go to TTY
  • In TTY install nonfree drivers with mhwd
  • Reboot

Read this for help

1 Like

Thanks for your help, but I think, I need a few more hints.

Basically, I don't know how to execute these steps and I couldn't find tutorials for this yet. This is, what I tried:

  • /etc/modprobe.d/ is empty, so there was nothing to backup
  • in grub I pressed "e" on the first option (boot manjaro gnome) and I assume entering TTY with that (I am not 100% sure, what that actually is).
  • I saw somewhat like a config file there, so I pressed "F2" to enter the command line mode.
  • I tried sudo mhwd -a pci nonfree 0300, but it tells me, that the command sudo is unknown.

?? what?? What about the one I posted??

According to those actions you should have two files, unless I missed something.

If you read the tutorial, I guess you'll understand you were still in Grub (not TTY) when you ran mhwd command.

1 Like

Sorry, I just needed some more help to understand these steps.
To clarify the misunderstanding of the blacklist files: I freshly installed manjaro again meanwhile as I couldn't work with a black screen. I did not mention that, sorry.

So, I blacklisted nouveau again; this time adding

to the file. After forced shutdown (normal shutdown is not possible while nouveau is enabled), I was able to run
sudo mhwd -a pci nonfree 0300
which created the desired file (/etc/modprobe.d/mhwd-nvidia.conf). This file already contained the blacklisted items from the file I created manually before (blacklist.conf). I changed the extension of blacklist.conf to conf.bak to avoid any further trouble.

When I boot now, I am back to my black screen with a cursor in the upper left corner (I cannot type anything).

From grub I can enter TTY as described in petsams tutorial posted. Here are some lines that
dmesg | less
gives me:

ACPI Error: Method parse/execution failed \SB.PCI0.SPI1.FPNT._CRS, AE_AML._INVALID_RESOURCE_TYPE (20170728/psparse-550)
ACPI Error: Method execution failed \SB.PCI0.SPI1.FPNT._CRS, AE_AML._INVALID_RESOURCE_TYPE (20170728/uteval-103)
ACPI Error: Method parse/execution failed \SB.PCI0.SPI2.FPNT._CRS, AE_AMI._INVALID_RESOURCE_TYPE (20170728/psparse-550)
ACPI Error: Method execution failed \SB.PCI0.SPI2.FPNT._CRS, AE_AML._INVALID_RESOURCE_TYPE (20170728/uteval-103)

Interestingly TTY freezes when I type
inxi -G

Any suggestions?

1 Like

If this command freezes the system, there maybe a hardware problem

lspci | grep -e VGA -e 3D

Also tell us about your system
DE (xfce, plasma?)
DM (lightdm, sddm?)
GPUs? Nvidia, AMD?

Usefull logs would be

journalctl -p3

It would help to know if you can start GUI from TTY, or your DM

sudo systemctl status lightdm
sudo systemctl start lightdm

change to your DM if it's different.

Let's get some stuff clear:

That model has integrated GPU too, so you either disable it from BIOS or you will need to use the a different approach then the one you are trying.

AFAIK that is a desktop GPU (so disable the intel GPU from BIOS), but if your system is a laptop, then you have to go by this solution below, and remember i was saying that i think is a Fermi based GPU even tho it has 384 CUDA core Pascal GPU ?

If is not a Fermi GPU, and your system is a laptop, then follow this

If is a desktop, you still must disable the integrated GPU from BIOS in order to avoid any issues. As for the ACPI errors from dmesg, you can ignore those or add acpi_rev_override=1 as kernel parameter at boot. Also you can chose to boot the install media using the nonfree driver option from grub menu.


Sorry for my late response, I was pretty busy lately.
Long story short: after visiting two local Linux User Groups (one with a lot of guys from FSFE) I switched to Ubuntu. The system works now - regardless of typical Ubuntu bugs :slight_smile:


  • Under Manjaro I checked available drivers with
    mhwd -l --pci
    and saw, that nvidia-390 would be downloaded. This driver won't work for me; I need nvidia-375 or nvidia-396 (according to the nvidia website).
  • I downloaded nvidia-396 directly from nvidia to install it manually (which I would have needed to repeat after every kernel update). The nvidia script needed the kernel headers and sources, so I installed the kernel headers and downloaded and built the sources in regard to the arch wiki. The nvidia-script crashed as it couldn't find a specific file in the kernel sources (fence.h), which indeed was missing in the kernel sources.
  • We (me and 2 linux user groups) got stuck here. Then I got the advice to move back to Ubuntu, 2 lines in the terminal and 3 clicks later I had my system back.

So after all: Thank you guys for this amazing system and support. I guess, I will retry Manjaro in 2 years or so, but right now it just doesn't seem to work for me.

1 Like

I could try manually installing nvidia-396 drivers, but they aren't available for Quadro P6000 in Nvidia web for Linux 64bit. I could also try installing Ubuntu 17.04 (how to fix printer offline) and crossing my fingers and pray for everything to work nicely from the beginning.
Note: For more discussion on this topic at

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by