Graphics (and other) issues

One thing is to try different kernels. Are you sure you booted to different kernels, after installing them? (select from grub menu options)
Other is change the compositor setting.
Last is to try some options for your Intel card, as of Archwiki. Check these as an example

Yes, I tried the kernels, all the same. I did all the variations of compositor settings. I created that file, nothing's changed(rebooted) but I don't know what you meant with this part

alter one of them (not all together)
Alter , not enable

With

# Option "DRI" "2"
Option "DRI" "3"
# Option      "DRI"       "False"
  1. you can/should have one enabled, not both, so alter means remove hash from one and add to the other.
    Same for AccelMethod.

  2. Only one at a time to track which is the right/best option and see the behavior, as a result of one change. Of course, after sole alterations, you should try combining. Number (1) always regarded.

thanks, that was clear
I played with it, I have kinda half success. I used to check the things with simple screen recorder, and originally it was flashing on the preview, and show only the screen, what i have when I start recording, and doesn't react if i move a window etc. If I press shift-alt-f12, everything works fine even with recording. So now I found a setting, that the recorder works just fine. This is already something, I appreciate it, thanks. But the line flickering didn't care about it at all.
At least it's not on the record. I should make a few hours record and watch it every day instead of using it live :smiley:
I can't believe the recorder is able to block this bug, and the compositor can't. (Or better say, it shouldn't even make the bug)

*update
With this "half solution" the flickering is there, even if I switch off the compositor

What solution? What settings have changed/set ?

The recent settings
Removed # at Option "OldDmaInit" "On"
Put # to Option "DRI" "3" instead of "2"

1 Like

Did you try TearFree?
Would you mind posting your Device section?

Yes I guess nothing changed with that, I'm not sure I tried every option. Sure when I changed the accelmethod, the animations were in slowmotion, but with the rest I didn't notice any difference.(apart the 1 I said) Now I also tried wayland. sure no more flickering, I mean the usual ones, but windows on each other do the job, plus no animations, only on firefox. Also the recorder does black video, with transparent preview.

Nah..
In /etc/X11/xorg.conf.d/<some-file>.conf "Section Device", just to keep some history..

:man_facepalming:
Thanks for patience

 Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  BusID       "PCI:0:2:0"
  Option      "AccelMethod"  "sna"
# Option      "AccelMethod"  "uxa"
  Option      "TearFree"     "true"
#  Option      "OldDmaInit"   "On"
#  Option      "DRI"       "3"
  Option      "DRI"       "2"
#  Option      "DRI"       "False"
EndSection

I put back to olddmainit, that won't change anyting. The only better is swap dri 2/3

1 Like

One more thing, if it says anything.
Using the live version works flawlessly, not even a single pixel flashes.

Then note down the Live session Xorg/video settings.

cat /proc/cmdline
inxi -SGxxx
pacman -Qs kwin
pacman -Qs intel
cat /etc/X11/xorg.conf.d/*.conf

And check whatever compositing/display system settings

Okay, I was wrong. As I played with the live, I saw flickering, but the reason, why I didn't see before is, that there is only 1 line of pixel is flashing, and no colors, only black. On the installed one there are 3 lines of pixels are flashing with random colors. :astonished::man_shrugging:

Here are all the differences from console:

recent:
BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=77dc5e21-c3d3-4199-8bae-d052af9-beda-45c6-805d-3c47b2bcfd70

live:
BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=it tz=UTC driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 misobasedir=manjaro misolabel=MJRO180 quiet systemd.show_status=1

recent:
Display: x11 server: X.Org 1.20.3 driver: intel compositor: kwin_x11

live:
Display: x11 server: X.Org 1.20.3 driver: intel unloaded: modesetting

recent:
-Missing alternate-

live:
alternate: fbdev,vesa compositor: kwin_x11 resolution: 2560x1080~60Hz 

recent:
local/intel-tbb 2019-1
    High level abstract threading library

live:
-missing line-

recent:
An open-source implementation of the OpenGL specification (32-bit)
local/lib32-vulkan-intel 18.2.4-0

live:
An open-source implementation of the OpenGL specification (32-bit)
local/libva-intel-driver 2.2.0-1

recent:
Intel's Vulkan mesa driver (32-bit)
local/libva-intel-driver 2.2.0-1

live:
-missing line-

recent:
An open-source implementation of the OpenGL specification
local/vulkan-intel 18.2.4-0
    Intel's Vulkan mesa driver
local/xf86-video-intel 1:2.99.917+853+g0932a6b3-1 (xorg-drivers)
    X.org Intel i810/i830/i915/945G/G965+ video drivers

live:
An open-source implementation of the OpenGL specification 

recent:
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "it"
        Option "XkbModel" "pc105"
EndSection
 Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  BusID       "PCI:0:2:0"
  Option      "AccelMethod"  "sna"
# Option      "AccelMethod"  "uxa"
  Option      "TearFree"     "true"
#  Option      "OldDmaInit"   "On"
#  Option      "DRI"       "3"
  Option      "DRI"       "2"
#  Option      "DRI"       "False"
EndSection

live:
Section "Device"
    Identifier  "Device0"
    Driver      "vesa"
    BusID       "PCI:0:2:0"
        Option      "DRI"    "true"
EndSection


Section "DRI"
        Group  "video"
        Mode   0666
EndSection


Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER"    "Enable"
EndSection


Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSectionii90

Do you think I should give up with kde and hunt for another DE? :disappointed_relieved:

+1
When I turn on kwin frame counter, no flashing

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by