Graphics Broken on ASUS Vivobook X512D

I upgraded a number of packages yesterday and it seems to have broken my laptop's graphics processing. The first clue I had was the way my logout splash screen looks; my profile picture is fractured. Here's a screenshot:
Screenshot_20200409_065559

Then I discovered that the same thing is happening to games. Here's another screenshot:
Screenshot_20200409_065654

The latter looks to me like something involving 3D processing, although I have no idea if that would cause the logout screen change too. With that in mind, I looked through the list of packages I had upgraded during the day. I tried downgrading anything that looked like it could be the culprit, including mesa and its related libraries, and the vulkan packages and their related libraries. I tried doing it one at a time so I could tell whether any of them made a difference. Interestingly, downgrading mesa fixed the logout screen but not the game graphics. I've included the relevant section of my pacman log below and was wondering if anyone could offer insight into what may have caused this and what a potential fix would be.

Thanks in advance!

[2020-04-08T09:28:51-0400] [ALPM] upgraded iana-etc (20200311-1 -> 20200327-1)
[2020-04-08T09:28:51-0400] [ALPM] upgraded atk (2.34.1-1 -> 2.36.0-1)
[2020-04-08T09:28:51-0400] [ALPM] upgraded bison (3.5.3-1 -> 3.5.4-1)
[2020-04-08T09:28:51-0400] [ALPM] upgraded openssl (1.1.1.e-1 -> 1.1.1.f-1)
[2020-04-08T09:28:51-0400] [ALPM] upgraded coreutils (8.31-3 -> 8.32-1)
[2020-04-08T09:28:51-0400] [ALPM] upgraded libnetfilter_conntrack (1.0.7-1 -> 1.0.8-1)
[2020-04-08T09:28:51-0400] [ALPM] upgraded libnftnl (1.1.5-1 -> 1.1.6-1)
[2020-04-08T09:28:52-0400] [ALPM] upgraded mesa (19.3.5-1 -> 20.0.4-1)
[2020-04-08T09:28:52-0400] [ALPM] upgraded graphite (1:1.3.13-2 -> 1:1.3.14-1)
[2020-04-08T09:28:52-0400] [ALPM] upgraded gnutls (3.6.12-1 -> 3.6.13-1)
[2020-04-08T09:28:53-0400] [ALPM] upgraded qt5-base (5.14.1-3 -> 5.14.2-1)
[2020-04-08T09:28:53-0400] [ALPM] upgraded qt5-svg (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:53-0400] [ALPM] upgraded qt5-declarative (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:53-0400] [ALPM] upgraded qt5-x11extras (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:53-0400] [ALPM] upgraded qt5-multimedia (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:53-0400] [ALPM] upgraded qt5-speech (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:53-0400] [ALPM] upgraded btrfs-progs (5.4-1 -> 5.6-1)
[2020-04-08T09:28:53-0400] [ALPM] upgraded bluedevil (1:5.18.3-1 -> 1:5.18.4.1-1)
[2020-04-08T09:28:53-0400] [ALPM] upgraded kdecoration (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded breeze (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded bubblewrap (0.4.0-1 -> 0.4.1-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded cpupower (5.5-1 -> 5.6-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded libbluray (1.2.0-1 -> 1.2.0-3)
[2020-04-08T09:28:54-0400] [ALPM] upgraded libva (2.6.1-1 -> 2.7.0-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded x265 (3.2.1-1 -> 3.3-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded ffmpeg (1:4.2.2-4 -> 1:4.2.2-5)
[2020-04-08T09:28:54-0400] [ALPM] upgraded faudio (20.03-1 -> 20.04-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded libinstpatch (1.1.3-1 -> 1.1.4-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded fluidsynth (2.1.1-1 -> 2.1.2-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded gobject-introspection-runtime (1.64.0-1 -> 1.64.1-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded gst-plugins-bad-libs (1.16.2-5 -> 1.16.2-7)
[2020-04-08T09:28:54-0400] [ALPM] upgraded libdvdread (6.1.0-1 -> 6.1.1-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded libdvdnav (6.1.0-1 -> 6.1.0-2)
[2020-04-08T09:28:54-0400] [ALPM] upgraded librsvg (2:2.48.1-1 -> 2:2.48.2-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded hwloc (2.1.0-2 -> 2.2.0-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded imagemagick (7.0.10.3-1 -> 7.0.10.6-1)
[2020-04-08T09:28:54-0400] [ALPM] upgraded gst-plugins-bad (1.16.2-5 -> 1.16.2-7)
[2020-04-08T09:28:54-0400] [ALPM] upgraded gst-plugins-ugly (1.16.2-2 -> 1.16.2-3)
[2020-04-08T09:28:54-0400] [ALPM] upgraded gtk-update-icon-cache (1:3.24.16-1 -> 1:3.24.17+18+gcdd4349bfe-1)
[2020-04-08T09:28:55-0400] [ALPM] upgraded gtk3 (1:3.24.16-1 -> 1:3.24.17+18+gcdd4349bfe-1)
[2020-04-08T09:28:55-0400] [ALPM] upgraded libmagick6 (6.9.11.3-1 -> 6.9.11.4-1)
[2020-04-08T09:28:55-0400] [ALPM] upgraded poppler (0.86.1-1 -> 0.87.0-1)
[2020-04-08T09:28:55-0400] [ALPM] upgraded poppler-glib (0.86.1-1 -> 0.87.0-1)
[2020-04-08T09:28:56-0400] [ALPM] upgraded inkscape (0.92.4-14 -> 0.92.4-15)
[2020-04-08T09:28:56-0400] [ALPM] upgraded intel-tbb (2020.1-1 -> 2020.2-1)
[2020-04-08T09:28:56-0400] [ALPM] upgraded iproute2 (5.5.0-1 -> 5.6.0-1)
[2020-04-08T09:28:56-0400] [ALPM] upgraded qt5-location (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:56-0400] [ALPM] upgraded qt5-sensors (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:56-0400] [ALPM] upgraded qt5-webchannel (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:56-0400] [ALPM] upgraded qt5-webkit (5.212.0alpha4-1 -> 5.212.0alpha4-3)
[2020-04-08T09:28:56-0400] [ALPM] upgraded poppler-qt5 (0.86.1-1 -> 0.87.0-1)
[2020-04-08T09:28:56-0400] [ALPM] upgraded libzip (1.5.2-2 -> 1.6.1-1)
[2020-04-08T09:28:57-0400] [ALPM] upgraded k3b (1:19.12.3-1 -> 1:19.12.3-2)
[2020-04-08T09:28:57-0400] [ALPM] upgraded kactivitymanagerd (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:57-0400] [ALPM] upgraded kde-cli-tools (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:57-0400] [ALPM] upgraded kde-gtk-config (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:57-0400] [ALPM] upgraded re2 (1:20200303-1 -> 1:20200401-1)
[2020-04-08T09:28:58-0400] [ALPM] upgraded qt5-webengine (5.14.1-2 -> 5.14.2-1)
[2020-04-08T09:28:58-0400] [ALPM] upgraded libksysguard (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:58-0400] [ALPM] upgraded qt5-graphicaleffects (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:58-0400] [ALPM] upgraded qt5-quickcontrols (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:58-0400] [ALPM] upgraded qt5-quickcontrols2 (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:58-0400] [ALPM] upgraded milou (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:58-0400] [ALPM] upgraded kscreenlocker (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:58-0400] [ALPM] upgraded qt5-script (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:28:58-0400] [ALPM] upgraded kwin (5.18.3-1 -> 5.18.4.1-2)
[2020-04-08T09:28:59-0400] [ALPM] upgraded plasma-integration (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:59-0400] [ALPM] upgraded libkscreen (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:59-0400] [ALPM] upgraded plasma-workspace (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:59-0400] [ALPM] upgraded kdeplasma-addons (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:28:59-0400] [ALPM] upgraded kgamma5 (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded kinfocenter (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded kmenuedit (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded knetattach (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded kscreen (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded ksshaskpass (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded ksysguard (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded kwallet-pam (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded kwayland-integration (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded kwrited (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-xz (5.2.4-1 -> 5.2.5-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-mesa (19.3.5-1 -> 20.0.4-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-faudio (20.03-1 -> 20.04-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-libinstpatch (1.1.3-1 -> 1.1.4-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-jack (0.125.0-2 -> 0.125.0-3)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-portaudio (190600_20161030-2 -> 1:19.6.0-4)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-fluidsynth (2.1.1-1 -> 2.1.2-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-gnutls (3.6.12-1 -> 3.6.13-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-keyutils (1.6-1 -> 1.6.1-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-libsamplerate (0.1.9-2 -> 0.1.9-3)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-libva-mesa-driver (19.3.5-1 -> 20.0.4-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-mesa-vdpau (19.3.5-1 -> 20.0.4-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-vulkan-intel (19.3.5-1 -> 20.0.4-1)
[2020-04-08T09:29:00-0400] [ALPM] upgraded lib32-vulkan-radeon (19.3.5-1 -> 20.0.4-1)
[2020-04-08T09:29:01-0400] [ALPM] upgraded libheif (1.6.2-1 -> 1.6.2-2)
[2020-04-08T09:29:01-0400] [ALPM] upgraded libva-mesa-driver (19.3.5-1 -> 20.0.4-1)
[2020-04-08T09:29:03-0400] [ALPM] upgraded linux54 (5.4.28-1 -> 5.4.30-1)
[2020-04-08T09:29:13-0400] [ALPM] upgraded linux54-headers (5.4.28-1 -> 5.4.30-1)
[2020-04-08T09:29:13-0400] [ALPM] upgraded man-db (2.9.1-1 -> 2.9.1-2)
[2020-04-08T09:29:13-0400] [ALPM] upgraded python-pyparsing (2.4.6-1 -> 2.4.7-1)
[2020-04-08T09:29:13-0400] [ALPM] upgraded pamac-common (9.4.0-7 -> 9.4.1-3)
[2020-04-08T09:29:13-0400] [ALPM] upgraded pamac-cli (9.4.0-7 -> 9.4.1-3)
[2020-04-08T09:29:13-0400] [ALPM] upgraded manjaro-application-utility (1.3.1-1 -> 1.3.2-2)
[2020-04-08T09:29:13-0400] [ALPM] upgraded mesa-vdpau (19.3.5-1 -> 20.0.4-1)
[2020-04-08T09:29:13-0400] [ALPM] upgraded mhwd-nvidia-440xx (440.64-1 -> 440.82-1)
[2020-04-08T09:29:13-0400] [ALPM] upgraded mlt (6.20.0-2 -> 6.20.0-3)
[2020-04-08T09:29:13-0400] [ALPM] upgraded nano (4.9-1 -> 4.9.1-1)
[2020-04-08T09:29:13-0400] [ALPM] upgraded obs-studio (25.0.3-1 -> 25.0.4-1)
[2020-04-08T09:29:13-0400] [ALPM] upgraded oxygen (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:13-0400] [ALPM] upgraded pamac-gtk (9.4.0-7 -> 9.4.1-3)
[2020-04-08T09:29:14-0400] [ALPM] upgraded snapd (2.44.1-1 -> 2.44.2-1)
[2020-04-08T09:29:14-0400] [ALPM] upgraded pamac-snap-plugin (9.4.0-7 -> 9.4.1-3)
[2020-04-08T09:29:14-0400] [ALPM] upgraded pamac-tray-appindicator (9.4.0-7 -> 9.4.1-3)
[2020-04-08T09:29:14-0400] [ALPM] upgraded plasma-browser-integration (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:14-0400] [ALPM] upgraded polkit-kde-agent (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:14-0400] [ALPM] upgraded systemsettings (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded plasma-desktop (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded plasma-nm (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded rtkit (0.12-1 -> 0.13-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded plasma-pa (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded plasma-workspace-wallpapers (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded powerdevil (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded python-msgpack (0.6.2-3 -> 1.0.0-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded python-pep517 (0.8.1-1 -> 0.8.2-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded python-pyaml (20.3.1-1 -> 20.4.0-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded python-pyqt5-sip (12.7.1-1 -> 12.7.2-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded python-pyqt5 (5.14.1-2 -> 5.14.2-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded python-sip (4.19.21-1 -> 4.19.22-1)
[2020-04-08T09:29:15-0400] [ALPM] upgraded qt5-imageformats (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:29:16-0400] [ALPM] upgraded qt5-tools (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:29:16-0400] [ALPM] upgraded qt5-translations (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:29:16-0400] [ALPM] upgraded qt5-virtualkeyboard (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:29:16-0400] [ALPM] upgraded qt5-wayland (5.14.1-1 -> 5.14.2-1)
[2020-04-08T09:29:16-0400] [ALPM] installed ruby-reline (0.0.7-2)
[2020-04-08T09:29:16-0400] [ALPM] installed ruby-irb (1.2.1-1)
[2020-04-08T09:29:16-0400] [ALPM] upgraded ruby (2.7.0-1 -> 2.7.1-1)
[2020-04-08T09:29:16-0400] [ALPM] upgraded sddm-kcm (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:16-0400] [ALPM] upgraded transcode (1.1.7-32 -> 1.1.7-33)
[2020-04-08T09:29:16-0400] [ALPM] upgraded user-manager (5.18.3-1 -> 5.18.4.1-1)
[2020-04-08T09:29:17-0400] [ALPM] upgraded vlc (3.0.8-11 -> 3.0.8-13)
[2020-04-08T09:29:17-0400] [ALPM] upgraded vulkan-intel (19.3.5-1 -> 20.0.4-1)
[2020-04-08T09:29:17-0400] [ALPM] upgraded vulkan-radeon (19.3.5-1 -> 20.0.4-1)
[2020-04-08T09:29:17-0400] [ALPM] upgraded xine-lib (1.2.10-2 -> 1.2.10-3)
[2020-04-08T18:52:09-0400] [ALPM] upgraded kwin (5.18.4.1-2 -> 5.18.4.1-4)
[2020-04-08T18:52:09-0400] [ALPM] upgraded pamac-common (9.4.1-3 -> 9.4.2-1)
[2020-04-08T18:52:09-0400] [ALPM] upgraded pamac-cli (9.4.1-3 -> 9.4.2-1)
[2020-04-08T18:52:09-0400] [ALPM] upgraded pamac-gtk (9.4.1-3 -> 9.4.2-1)
[2020-04-08T18:52:09-0400] [ALPM] upgraded pamac-snap-plugin (9.4.1-3 -> 9.4.2-1)

Hi there .. logs are nice, but some system info would be good

Sorry about that. Here's the output of inxi:

System:
  Kernel: 5.4.30-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=e7a463ba-719d-4f29-ae8c-16bfbb5d7107 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X512DA v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: X512DA v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X512DA.308 date: 11/05/2019 
Battery:
  ID-1: BAT0 charge: 34.9 Wh condition: 34.9/37.1 Wh (94%) volts: 7.8/7.8 
  model: ASUSTeK ASUS Battery type: Li-ion serial: <filter> 
  status: Not charging cycles: 57 
CPU:
  Topology: Dual Core 
  model: AMD Ryzen 3 3200U with Radeon Vega Mobile Gfx bits: 64 
  type: MT MCP arch: Zen+ family: 17 (23) model-id: 18 (24) stepping: 1 
  microcode: 8108102 L2 cache: 1024 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 20770 
  Speed: 1364 MHz min/max: 1400/2600 MHz boost: enabled 
  Core speeds (MHz): 1: 2100 2: 1473 3: 1237 4: 1277 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 03:00.0 chip ID: 1002:15d8 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu FAILED: ati 
  unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD RAVEN2 (DRM 3.35.0 5.4.30-1-MANJARO LLVM 9.0.1) 
  v: 4.6 Mesa 20.0.4 direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio 
  driver: snd_hda_intel v: kernel bus ID: 03:00.1 chip ID: 1002:15de 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  driver: N/A bus ID: 03:00.5 chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.4.30-1-MANJARO 
Network:
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel 
  bus ID: 01:00.0 chip ID: 8086:24fd 
  IF: wlp1s0 state: up mac: <filter> 
  IF-ID-1: anbox0 state: down mac: <filter> 
Drives:
  Local Storage: total: 476.94 GiB used: 79.42 GiB (16.7%) 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 002C scheme: GPT 
Partition:
  ID-1: / raw size: 476.64 GiB size: 468.16 GiB (98.22%) 
  used: 79.42 GiB (17.0%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 66.2 C mobo: N/A gpu: amdgpu temp: 66 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 191 Uptime: 5h 13m Memory: 5.82 GiB used: 1.71 GiB (29.4%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  running in: konsole inxi: 3.0.37

I'm having trouble figuring out how to use dmesg effectively. It doesn't seem like I can specifically search for information related to the graphics card using its options, but if I'm missing something let me know the command I should use. The closest I could figure was dmesg -T | grep -iC 3 "amdgpu" and here's what it gave me:

[Thu Apr  9 06:50:43 2020] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                            Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                            (Note that use of the override may cause unknown side effects.)
[Thu Apr  9 06:50:43 2020] [drm] amdgpu kernel modesetting enabled.
[Thu Apr  9 06:50:43 2020] Parsing CRAT table with 1 nodes
[Thu Apr  9 06:50:43 2020] Creating topology SYSFS entries
[Thu Apr  9 06:50:43 2020] Topology: Add APU node [0x0:0x0]
[Thu Apr  9 06:50:43 2020] Finished initializing topology
[Thu Apr  9 06:50:43 2020] amdgpu 0000:03:00.0: remove_conflicting_pci_framebuffers: bar 0: 0xe0000000 -> 0xefffffff
[Thu Apr  9 06:50:43 2020] amdgpu 0000:03:00.0: remove_conflicting_pci_framebuffers: bar 2: 0xf0000000 -> 0xf01fffff
[Thu Apr  9 06:50:43 2020] amdgpu 0000:03:00.0: remove_conflicting_pci_framebuffers: bar 5: 0xfe700000 -> 0xfe77ffff
[Thu Apr  9 06:50:43 2020] checking generic (e0000000 420000) vs hw (e0000000 10000000)
[Thu Apr  9 06:50:43 2020] fb0: switching to amdgpudrmfb from EFI VGA
[Thu Apr  9 06:50:43 2020] amdgpu 0000:03:00.0: vgaarb: deactivate vga console
[Thu Apr  9 06:50:43 2020] amdgpu 0000:03:00.0: enabling device (0006 -> 0007)
[Thu Apr  9 06:50:43 2020] [drm] initializing kernel modesetting (RAVEN 0x1002:0x15D8 0x1043:0x1821 0xC4).
[Thu Apr  9 06:50:43 2020] [drm] register mmio base: 0xFE700000
[Thu Apr  9 06:50:43 2020] [drm] register mmio size: 524288
--
[Thu Apr  9 06:50:43 2020] [drm] VCN encode is enabled in VM mode
[Thu Apr  9 06:50:43 2020] [drm] VCN jpeg decode is enabled in VM mode
[Thu Apr  9 06:50:43 2020] [drm] vm size is 262144 GB, 3 levels, block size is 9-bit, fragment size is 9-bit
[Thu Apr  9 06:50:43 2020] amdgpu 0000:03:00.0: VRAM: 2048M 0x000000F400000000 - 0x000000F47FFFFFFF (2048M used)
[Thu Apr  9 06:50:43 2020] amdgpu 0000:03:00.0: GART: 1024M 0x0000000000000000 - 0x000000003FFFFFFF
[Thu Apr  9 06:50:43 2020] amdgpu 0000:03:00.0: AGP: 267419648M 0x000000F800000000 - 0x0000FFFFFFFFFFFF
[Thu Apr  9 06:50:43 2020] [drm] Detected VRAM RAM=2048M, BAR=2048M
[Thu Apr  9 06:50:43 2020] [drm] RAM width 128bits DDR4
[Thu Apr  9 06:50:43 2020] [TTM] Zone  kernel: Available graphics memory: 3050718 KiB
[Thu Apr  9 06:50:43 2020] [TTM] Zone   dma32: Available graphics memory: 2097152 KiB
[Thu Apr  9 06:50:43 2020] [TTM] Initializing pool allocator
[Thu Apr  9 06:50:43 2020] [TTM] Initializing DMA pool allocator
[Thu Apr  9 06:50:43 2020] [drm] amdgpu: 2048M of VRAM memory ready
[Thu Apr  9 06:50:43 2020] [drm] amdgpu: 3072M of GTT memory ready.
[Thu Apr  9 06:50:43 2020] [drm] GART: num cpu pages 262144, num gpu pages 262144
[Thu Apr  9 06:50:43 2020] [drm] PCIE GART of 1024M enabled (table at 0x000000F400900000).
[Thu Apr  9 06:50:43 2020] [drm] use_doorbell being set to: [true]
[Thu Apr  9 06:50:43 2020] amdgpu: [powerplay] hwmgr_sw_init smu backed is smu10_smu
[Thu Apr  9 06:50:43 2020] [drm] Found VCN firmware Version ENC: 1.9 DEC: 1 VEP: 0 Revision: 28
[Thu Apr  9 06:50:43 2020] [drm] PSP loading VCN firmware
[Thu Apr  9 06:50:43 2020] [drm] reserve 0x400000 from 0xf47f800000 for PSP TMR
--
[Thu Apr  9 06:50:44 2020] [drm] DM_PPLIB:       626000 in kHz, 3924 in mV
[Thu Apr  9 06:50:44 2020] [drm] DM_PPLIB:       654000 in kHz, 4074 in mV
[Thu Apr  9 06:50:44 2020] [drm] Display Core initialized with v3.2.48!
[Thu Apr  9 06:50:44 2020] snd_hda_intel 0000:03:00.1: bound 0000:03:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[Thu Apr  9 06:50:44 2020] [drm] SADs count is: -2, don't need to read it
[Thu Apr  9 06:50:44 2020] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[Thu Apr  9 06:50:44 2020] [drm] Driver supports precise vblank timestamp query.
--
[Thu Apr  9 06:50:44 2020] [drm] size 4325376
[Thu Apr  9 06:50:44 2020] [drm] fb depth is 24
[Thu Apr  9 06:50:44 2020] [drm]    pitch is 5632
[Thu Apr  9 06:50:44 2020] fbcon: amdgpudrmfb (fb0) is primary device
[Thu Apr  9 06:50:44 2020] fbcon: Deferring console take-over
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: fb0: amdgpudrmfb frame buffer device
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring gfx uses VM inv eng 0 on hub 0
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring sdma0 uses VM inv eng 0 on hub 1
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring vcn_dec uses VM inv eng 1 on hub 1
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring vcn_enc0 uses VM inv eng 4 on hub 1
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring vcn_enc1 uses VM inv eng 5 on hub 1
[Thu Apr  9 06:50:44 2020] amdgpu 0000:03:00.0: ring vcn_jpeg uses VM inv eng 6 on hub 1
[Thu Apr  9 06:50:44 2020] [drm] Initialized amdgpu 3.35.0 20150101 for 0000:03:00.0 on minor 0
[Thu Apr  9 06:50:44 2020] fbcon: Taking over console
[Thu Apr  9 06:50:44 2020] Console: switching to colour frame buffer device 170x48
[Thu Apr  9 06:50:44 2020] iwlwifi 0000:01:00.0: FW already configured (0) - re-configuring
--
[Thu Apr  9 07:14:56 2020] iwlwifi 0000:01:00.0: Applying debug destination EXTERNAL_DRAM
[Thu Apr  9 07:14:56 2020] ------------[ cut here ]------------
[Thu Apr  9 07:14:56 2020] WARNING: CPU: 0 PID: 229 at drivers/ata/libata-eh.c:4146 ata_scsi_port_error_handler+0x766/0x780 [libata]
[Thu Apr  9 07:14:56 2020] Modules linked in: rfcomm ccm iptable_mangle xt_CHECKSUM xt_tcpudp iptable_nat xt_comment xt_MASQUERADE nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 fuse libcrc32c bridge stp llc iptable_filter cmac algif_hash algif_skcipher af_alg bnep uvcvideo btusb videobuf2_vmalloc videobuf2_memops btrtl videobuf2_v4l2 btbcm videobuf2_common btintel videodev bluetooth mc ecdh_generic ecc rtsx_usb_ms memstick amdgpu squashfs edac_mce_amd kvm_amd loop ccp kvm joydev irqbypass mousedev asus_nb_wmi asus_wmi crct10dif_pclmul sparse_keymap wmi_bmof crc32_pclmul hid_multitouch ghash_clmulni_intel iwlmvm snd_hda_codec_realtek gpu_sched mac80211 i2c_algo_bit snd_hda_codec_generic snd_hda_codec_hdmi ledtrig_audio ttm nls_iso8859_1 aesni_intel libarc4 drm_kms_helper nls_cp437 vfat crypto_simd fat iwlwifi cryptd snd_hda_intel glue_helper snd_intel_nhlt snd_hda_codec drm snd_hda_core input_leds snd_hwdep k10temp snd_pcm pcspkr sp5100_tco i2c_piix4 cfg80211 agpgart snd_timer snd syscopyarea
[Thu Apr  9 07:14:56 2020]  sysfillrect snd_pci_acp3x sysimgblt fb_sys_fops soundcore rfkill wmi battery ac tpm_crb tpm_tis tpm_tis_core tpm rng_core i2c_hid pinctrl_amd evdev mac_hid acpi_cpufreq uinput sg crypto_user binder_linux(OE) ashmem_linux(OE) ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 hid_logitech_hidpp rtsx_usb_sdmmc mmc_core rtsx_usb hid_logitech_dj hid_generic usbhid hid serio_raw atkbd libps2 ahci libahci libata crc32c_intel i8042 xhci_pci scsi_mod xhci_hcd serio
[Thu Apr  9 07:14:56 2020] CPU: 0 PID: 229 Comm: scsi_eh_0 Tainted: G           OE     5.4.30-1-MANJARO #1
[Thu Apr  9 07:14:56 2020] Hardware name: ASUSTeK COMPUTER INC. VivoBook_ASUSLaptop X512DA/X512DA, BIOS X512DA.308 11/05/2019
--
[Thu Apr  9 07:14:56 2020] [drm] failed to load ucode id (20) 
[Thu Apr  9 07:14:56 2020] [drm] psp command failed and response status is (0xF)
[Thu Apr  9 07:14:56 2020] iwlwifi 0000:01:00.0: FW already configured (0) - re-configuring
[Thu Apr  9 07:14:56 2020] amdgpu: [powerplay] dpm has been enabled
[Thu Apr  9 07:14:56 2020] usb 1-6: reset high-speed USB device number 4 using xhci_hcd
[Thu Apr  9 07:14:56 2020] [drm] VCN decode and encode initialized successfully(under SPG Mode).
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring gfx uses VM inv eng 0 on hub 0
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring sdma0 uses VM inv eng 0 on hub 1
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring vcn_dec uses VM inv eng 1 on hub 1
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring vcn_enc0 uses VM inv eng 4 on hub 1
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring vcn_enc1 uses VM inv eng 5 on hub 1
[Thu Apr  9 07:14:56 2020] amdgpu 0000:03:00.0: ring vcn_jpeg uses VM inv eng 6 on hub 1
[Thu Apr  9 07:14:56 2020] ata1: SATA link down (SStatus 0 SControl 300)
[Thu Apr  9 07:14:56 2020] usb 1-5: reset high-speed USB device number 3 using xhci_hcd
[Thu Apr  9 07:14:57 2020] usb 1-6.2: reset high-speed USB device number 6 using xhci_hcd
--
[Thu Apr  9 07:54:03 2020] [drm] psp command failed and response status is (0xF)
[Thu Apr  9 07:54:03 2020] iwlwifi 0000:01:00.0: FW already configured (0) - re-configuring
[Thu Apr  9 07:54:03 2020] usb 1-5: reset high-speed USB device number 3 using xhci_hcd
[Thu Apr  9 07:54:03 2020] amdgpu: [powerplay] dpm has been enabled
[Thu Apr  9 07:54:03 2020] ata1: SATA link down (SStatus 0 SControl 300)
[Thu Apr  9 07:54:03 2020] [drm] VCN decode and encode initialized successfully(under SPG Mode).
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring gfx uses VM inv eng 0 on hub 0
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring sdma0 uses VM inv eng 0 on hub 1
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring vcn_dec uses VM inv eng 1 on hub 1
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring vcn_enc0 uses VM inv eng 4 on hub 1
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring vcn_enc1 uses VM inv eng 5 on hub 1
[Thu Apr  9 07:54:03 2020] amdgpu 0000:03:00.0: ring vcn_jpeg uses VM inv eng 6 on hub 1
[Thu Apr  9 07:54:03 2020] usb 1-6: reset high-speed USB device number 4 using xhci_hcd
[Thu Apr  9 07:54:03 2020] usb 1-6.2: reset high-speed USB device number 6 using xhci_hcd
[Thu Apr  9 07:54:03 2020] usb 1-6.1: reset full-speed USB device number 5 using xhci_hcd
--
[Thu Apr  9 09:02:12 2020] [drm] failed to load ucode id (20) 
[Thu Apr  9 09:02:12 2020] [drm] psp command failed and response status is (0xF)
[Thu Apr  9 09:02:12 2020] iwlwifi 0000:01:00.0: FW already configured (0) - re-configuring
[Thu Apr  9 09:02:12 2020] amdgpu: [powerplay] dpm has been enabled
[Thu Apr  9 09:02:12 2020] usb 1-5: reset high-speed USB device number 3 using xhci_hcd
[Thu Apr  9 09:02:12 2020] [drm] VCN decode and encode initialized successfully(under SPG Mode).
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring gfx uses VM inv eng 0 on hub 0
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring sdma0 uses VM inv eng 0 on hub 1
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring vcn_dec uses VM inv eng 1 on hub 1
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring vcn_enc0 uses VM inv eng 4 on hub 1
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring vcn_enc1 uses VM inv eng 5 on hub 1
[Thu Apr  9 09:02:12 2020] amdgpu 0000:03:00.0: ring vcn_jpeg uses VM inv eng 6 on hub 1
[Thu Apr  9 09:02:12 2020] ata1: SATA link down (SStatus 0 SControl 300)
[Thu Apr  9 09:02:12 2020] usb 1-6: reset high-speed USB device number 4 using xhci_hcd
[Thu Apr  9 09:02:12 2020] usb 1-6.2: reset high-speed USB device number 6 using xhci_hcd

If there's a different command I can use let me know and I'll provide more info.

I also often grep dmesg. I dont see anything jumping out at me...
But note here is a good one for dmesg:

dmesg -l emerg,alert,crit,err,warn,notice

(those go in order from extreme to ignorable. Both 'notice' and 'warn' might only show benign logs so you may wish to remove those flags .. see more at dmesg --help)

Thanks, that's good to know.

I tried running dmesg -c then opening one of the affected applicationsand immediately running dmesg -l emerg,alert,crit,err,warn,notice because I thought that might provide the best chance of catching something. I've included the output below; I assume it's what you were referring to when you said it might show only benign logs? When I run it without the warn and notice flags it provides no output.

[36753.974171] audit: type=1106 audit(1586482883.973:295): pid=35085 uid=0 auid=1000 ses=2 subj==unconfined msg='op=PAM:session_close grantors=pam_limits,pam_unix,pam_permit acct="root" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=success'
[36753.974237] audit: type=1104 audit(1586482883.973:296): pid=35085 uid=0 auid=1000 ses=2 subj==unconfined msg='op=PAM:setcred grantors=pam_unix,pam_permit,pam_env acct="root" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=success'
[36816.936834] audit: type=1101 audit(1586482946.937:297): pid=35532 uid=1000 auid=1000 ses=2 subj==unconfined msg='op=PAM:accounting grantors=pam_unix,pam_permit,pam_time acct="ben" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=success'
[36816.937069] audit: type=1110 audit(1586482946.937:298): pid=35532 uid=0 auid=1000 ses=2 subj==unconfined msg='op=PAM:setcred grantors=pam_unix,pam_permit,pam_env acct="root" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=success'
[36816.940784] audit: type=1105 audit(1586482946.940:299): pid=35532 uid=0 auid=1000 ses=2 subj==unconfined msg='op=PAM:session_open grantors=pam_limits,pam_unix,pam_permit acct="root" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=success'

I tried doing a fresh install of 19.0 and seeing if that fixed the problem. As soon as I did a full system upgrade it broke again. So, I tried doing another fresh install and put the following into pacman.conf:

IgnorePkg   = lib32-mesa lib32-libva-mesa-driver mesa-demos mesa-vdpau mesa vulkan-intel lib32-mesa-demos libva-mesa-driver lib32-misa-vdpau vulkan-radeon lib32-vulkan-radeon

I did another full system update and the issue didn't arise again. So for now I'm leaving this list of packages on the Ignore list. I'm guessing it's something to do with mesa, since previously downgrading it fixed some of the graphics issues, but it's curious that the downgrade only fixed some whereas preventing the upgrade has prevented all of the issues from arising. Any further recommendations are welcome!

hm.. so it is maybe radeon or mesa or vulkan involved (if not technically the kernels fault for the way it interacts with them)
Have you tried other kernels ?
(the information so far is definitely useful!)

When I first experienced the issue on my old install I tried upgrading to 5.6 but it didn't help. Currently I'm running 5.4 LTS.

By process of elimination I have managed to narrow it down to two packages: mesa and lib32-mesa. If I upgrade either of these, even without upgrading the other, it breaks the graphics in the way I described in the original post. Should I submit this as a bug somewhere?

I have the same issue, did you end up submitting a bug anywhere or maybe fix your issue some other way?

I haven't found a fix yet. Just found this today. I think it's likely the same bug we're experiencing. I'm going to jump in on that thread.

Also worth noting: I am no longer able to keep mesa and lib32-mesa on the ignore list because booting stalls out at tlp system startup/shutdown, which, from everything I've gathered, means that the kernel and graphics drivers are conflicting. Changing kernels doesn't seem to help. So I've now upgraded to mesa 20.0.4 and can't play any graphic-intensive games and my login screen looks funny. Guess that means I really do have to do my schoolwork! :sweat_smile:

Temporary fix that was recommended on the official bug report and worked for me: run your application with the environmental variable AMD_DEBUG=nodma.

Sounds like it may overheat your system though so careful using it!

AMD_DEBUG=nodmacopyimage is now the recommended workaround.

For anyone also experiencing this issue, a good solution for now is to create an environment variable out of AMD_DEBUG=nodmacopyimage. I've been running my system that way for a little while now and it works well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by