Graphics stutter when using two keyboard inputs

Hello,

tldr; after a graphics card swap and a system update, using two keyboard inputs at the same time creates stutter on all screens at least when changing the movement vector in games.

first let me break down the issue.
I have a keyboard as well as a Logitech G600 mouse connected to my computer. The G600 has 12 extra buttons on the side of it, which basically act as a keyboard (I will refer to these 12 buttons as the “G600-keyboard”). Those buttons are configured to send a key press of the corresponding button in the top keyboard row (1, 2, …, 0, -, =).

When I am using my keyboard as well as my G600-keyboard at the same time I get a sort of stutter (my graphics on all 4 screens freeze for about a tenth of a second). But I could only reproduce this in games when abruptly changing the movement vector (using the A and D keys on the regular keyboard) while pressing buttons on the G600-keyboard, so I recorded a few seconds of Minecraft. The first 5 seconds are only my keyboard, from second 6 onward I am also pressing the "1" key of my G600-keyboard. Strangely, while the motion is sustained, the stutter does not occur.

Also noteworthy: I have tested using another USB keyboard instead of the G600-keyboard, which also reproduces the problem. When inputting only using one keyboard the problem does not occur.

The first time I noticed the problem was after I changed the graphics card (from a AMD Radeon RX 5700 XT to an NVIDIA RTX 2070) and running a system update. Unfortunately, I have no way of going back to see whether the problem persisted before and I'm just paying more attention to everything because I modified the hardware.

I already tried different kernel versions (5.6, 5.5, 5.4, 4.19) which didn't fix it. I also tried downgrading the libinput package to the version it had before the update (I know this is a bad idea :crazy_face:), but that didn't do anything either. I checked the kernel output using dmesg -w and reading the logs via journalctl -fe, but at least in my opinion, there's nothing helpful in there.

An overview of my system by running inxi -Fx:

System:    Host: Platikas-Sugarcube Kernel: 5.6.10-3-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Xfce 4.14.2 
           Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: A320M-S2H V2 v: N/A serial: <root required> 
           Mobo: Gigabyte model: A320M-S2H V2-CF v: x.x serial: <root required> UEFI: American Megatrends v: F1 
           date: 10/16/2018 
CPU:       Topology: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 76671 
           Speed: 1685 MHz min/max: 1550/3200 MHz Core speeds (MHz): 1: 2226 2: 2311 3: 1374 4: 1374 5: 1361 6: 2038 7: 1312 
           8: 1274 9: 1374 10: 1375 11: 1374 12: 1375 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: Gigabyte driver: nvidia v: 440.82 bus ID: 09:00.0 
           Display: x11 server: X.Org 1.20.8 driver: nvidia 
           resolution: 1920x1080~60Hz, 1600x900~60Hz, 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: NVIDIA TU106 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 09:00.1 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 0b:00.3 
           Device-3: C-Media Gaming Mouse G600 type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-4.2:5 
           Sound Server: ALSA v: k5.6.10-3-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8168 v: 8.048.02-NAPI 
           port: f000 bus ID: 08:00.0 
           IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: b4:2e:99:02:7d:be 
           IF-ID-1: uwu0 state: unknown speed: N/A duplex: N/A mac: N/A 
Drives:    Local Storage: total: 3.64 TiB used: 831.52 GiB (22.3%) 
           ID-1: /dev/sda vendor: Western Digital model: WD5000AAKX-75U6AA0 size: 465.76 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB 
           ID-3: /dev/sdc vendor: Samsung model: SSD 860 QVO 1TB size: 931.51 GiB 
           ID-4: /dev/sdd vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
Partition: ID-1: / size: 915.71 GiB used: 234.38 GiB (25.6%) fs: ext4 dev: /dev/sdc1 
Sensors:   System Temperatures: cpu: 42.2 C mobo: N/A gpu: nvidia temp: 50 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 20% 
Info:      Processes: 309 Uptime: 56m Memory: 15.65 GiB used: 3.69 GiB (23.6%) Init: systemd Compilers: gcc: 9.3.0 Shell: zsh 
           v: 5.8 inxi: 3.0.37 

This feels like some issue with the hardware-driver-combination. Do you have any clue what might be the problem or where I should look? Do you need any more information?

I just tried using the nouveau driver instead of the proprietary NVIDIA driver, it appears to have the same issue.
Also tried only using one screen, in case the multiscreen thing might have been a issue, also not changing the issue on hand.

I decided to install a GNOME Desktop environment to see if it makes a difference. This has actually fixed the problem.
I now use GNOME with GDM. Previously I was using Xfce with LightDM as my display manager.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by