GRUB bootloader not loading

I have dual-booted Manjaro with Windows 10 and whenever I start my system it directly boots into Manjaro without loading the GRUB bootloader. I have checked legacy boot and disabled secure boot and to start Windows I have to open boot options and select 'Windows Boot Loader' there.

I tried this as EFI variables are not supported on this system when running efibootmgr but it resulted in

$ modprobe efivars
modprobe: FATAL: Module efivars not found in directory /lib/modules/5.3.11-1-MANJARO

How to enable the bootloader?

From Manjaro terminal, print out

sudo parted -l
sudo blkid
cat /etc/fstab
efibootmgr -v
grep TIME /etc/default/grub

parted - l --> small 'L' , all disks, do not omit, do not truncate. All info.

$ sudo parted -l
Model: ATA WDC WD10SPCX-75K (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  525MB   524MB   fat32        EFI system partition          boot, esp
 2      525MB   660MB   134MB                Microsoft reserved partition  msftres
 3      660MB   551GB   550GB   ntfs         Basic data partition          msftdata
 4      551GB   879GB   328GB   ntfs         Basic data partition          msftdata
 5      879GB   987GB   107GB   ext4
 6      987GB   987GB   472MB   ntfs                                       hidden, diag
 7      987GB   999GB   11.7GB  ntfs                                       hidden, diag
 8      999GB   1000GB  1163MB  ntfs                                       hidden, diag
$ sudo blkid
/dev/sda1: LABEL="ESP" UUID="10FE-B54E" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="e2bbdf1c-2ef5-4d15-b5d1-0c7384761123"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="d0c0e4ad-28d1-42f1-80a7-b0d662298690"
/dev/sda3: LABEL="OS" UUID="102AFCAC2AFC9048" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="fd1b2af8-3755-469f-b698-a48d51ff269b"
/dev/sda4: LABEL="New Volume" UUID="01D58D8CC8A8A110" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="42f6afb3-d397-4e0a-a594-35fbd56e5f4e"
/dev/sda5: UUID="dc765f9d-5dc4-4c55-8126-43ab0c3da62c" TYPE="ext4" PARTUUID="b9a4bc17-6b96-428a-a087-f4b5c9f6c014"
/dev/sda6: UUID="32DC39B3DC3971E9" TYPE="ntfs" PARTUUID="161fcdf7-6cf6-4d80-b736-4c4dbfdb3f1f"
/dev/sda7: LABEL="Image" UUID="387CAA527CAA0B28" TYPE="ntfs" PARTUUID="4d71e7bc-6931-46d9-b6d0-3dd3ea70b31e"
/dev/sda8: LABEL="DELLSUPPORT" UUID="9E38855F388536F5" TYPE="ntfs" PARTUUID="62fb604c-d2e5-4461-8218-24105835317d"
$ cat /etc/fstab 
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=dc765f9d-5dc4-4c55-8126-43ab0c3da62c /              ext4    defaults,noatime 0 1
$ efibootmgr -v
EFI variables are not supported on this system.
$ grep TIME /etc/default/grub
GRUB_TIMEOUT=3
GRUB_TIMEOUT_STYLE=hidden

Most probably Windows is installed in UEFI boot mode while Manjaro is on BIOS Legacy mode.
Confirm this with this

sudo grep osprober /boot/grub/grub.cfg

If there is no Windows entry, it confirms my assumption.
To make grub menu show up (not hidden) change this setting and run update-grub

to this

GRUB_TIMEOUT_STYLE=menu

Actually, you mean the menu is not shown. The bootloader works, since... your Manjaro boots up :stuck_out_tongue_winking_eye:

2 Likes

Yes, this is the case and yes, the above $ sudo grep osprober /boot/grub/grub.cfg returns nothing.

Worked!

So how to add Windows option in the menu?

Reinstall Manjaro in UEFI (and update-grub :laughing:).

I don't remember seeing an option for UEFI and legacy while installing it. Otherwise I would have done UEFI from the beginning ⠀:/⠀

I also have memory leaks! :stuck_out_tongue_winking_eye:
When booting Live ISO, use BIOS boot menu and you will see there are two menu options for the same USB drive, one of them should include "UEFI" in name/description.

1 Like

Okay, thank you.

Wait. There may be no need to reinstall.
But you must be sure your windows is in uefi.
All here thinks it is most likely in uefi.
But you must be sure.

I'm preparing how to fix manjaro in uefi.
I haven't prepare how to make sure windows is in uefi yet.

My next post will be hjow to fix manjaro in uefi.
Don't do it yet.

Then another post on making sure you can boot windows in uefi to be sure it is in uefi.
So wait for the windows post. Not the next post.

But if can find out windows in uefi, tell us.
oh... make sure you have a Manjaro install media (usb) ready.

Read This first.

As per the link above, start up (not boot up) install media in uefi.
Do not boot up. At grub menu, go to grub prompt. Make sure it is in uefi.

Boot up to installed Manjaro OS at sda5.

  1. Prepare repositories and install needed efi packages.
sudo pacman-mirrors -f4
sudo pacman -Syyuu
sudo pacman -S efibootmgr efivar  dosfstools
  1. Add /boot/efi entry to fstab
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=10FE-B54E                       /boot/efi      vfat    defaults,noatime 0       0
UUID=dc765f9d-5dc4-4c55-8126-43ab0c3da62c /              ext4    defaults,noatime 0 1

  1. Mount boot/efi partition.
sudo mount /dev/sda1 /boot/efi
  1. Do grub-install commands

sudo grub-install  --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --boot-directory=/boot  --recheck --debug
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
sudo update-grub

Done!

Oh.. I think you can proceed without checking windows in uefi or bios-legacy.
Whether you can boot windows now in uefi has no change in windows either as you now cannot boot windows in bios-legacy either. There is no effect either way.

But from the 'update-grub' command in this post (last command), you can see if windows is listed.
Tell us. Hopefully you have not formatted out sda1 when installing manjaro earlier.

Cheers.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by