GRUB boots into rescue mode, unknown filesystem

Hello! Long story short, GRUB keeps booting into rescue mode and saying "unknown filesystem." This began happening after I tried to switch from the KDE edition of Manjaro to the xfce edition. I also tried Debian and Ubuntu afterwards, but with the same result. I've been doing manual partitioning during installations since I have a separate /home folder. I currently have a separate boot partition as well, as I believe someone suggested it when I came to the IRC for help a month or so ago.

Tried but once I get to "insmod normal" I get "error: no such partition." Tried but it doesn't recognize the EFI partition as being EFI.

Here's my inxi info:

System:    Host: manjaro Kernel: 4.9.50-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
           Desktop: N/A Distro: Manjaro Linux
Machine:   Device: portable System: Dell product: Inspiron 7547 serial: N/A
           Mobo: Dell model: 0AM670 v: A00 serial: N/A
           UEFI: Dell v: A03 date: 10/27/2014
Battery    BAT0: charge: 7.3 Wh 100.0% condition: 7.3/44.5 Wh (16%)
           model: SIMPLO Dell status: Full
CPU:       Dual core Intel Core i7-4510U (-HT-MCP-) 
           arch: Haswell rev.1 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10379
           clock speeds: max: 3100 MHz 1: 2302 MHz 2: 1999 MHz 3: 1999 MHz
           4: 2076 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: N/A drivers: intel (unloaded: modesetting)
           tty size: 80x24
Audio:     Card-1 Intel 8 Series HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.9.50-1-MANJARO
Network:   Card: Intel Wireless 3160 driver: iwlwifi bus-ID: 07:00.0
           IF: wlp7s0 state: up mac: d0:7e:35:4b:ed:53
Drives:    HDD Total Size: 1008.3GB (53.6% used)
           ID-1: /dev/sda model: TOSHIBA_MQ02ABF1 size: 1000.2GB
           ID-2: USB /dev/sdb model: innostor size: 8.1GB
Partition: ID-1: / size: 5.8G used: 100M (2%) fs: overlay dev: N/A
Sensors:   System Temperatures: cpu: 53.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 203 Uptime: 39 min Memory: 2186.0/7893.2MB
           Init: systemd Gcc sys: 7.2.0
           Client: Shell (bash 4.4.121) inxi: 2.3.38

Maybe try with that unplugged?

Do you mean "Grub Rescue" or linux rescue ?
If it is not Grub Rescue you may have to repair your fstab with the correct partition UUIDs.

grub rescue>

This says on /dev/sda you have one partition 5.8GB in a 1TeraB drive.
Is that right?

Did you try to find your root partition in grub escue with ls ?
In your link at AskBuntu at 3rd answer there are detail guidelines.
Did you follow those?
What did you find and what did you do?

Also have a look at this:

It may be just that you selected the wrong partition (especially if you have 2 or more disks).
Check you get the device right (hd0 or hd1) by
grub> ls

Not sure if 'ls' command works in 'grub rescue>' (i haven't got into grub rescue for a long time and i cannot deliberately get into it :wink: )

You may want to just reinstall your bootloader as it may be easier.
Try this and reinstall from your booted OS.

My dear Grub Super Hero. I expected you had a custom grub (fail-)option to get in grub-rescue intentionally!! :heart_eyes:

1 Like

Hello, all. Ended up purchasing an external hard drive, backing up everything, erasing the whole disk, then doing a fresh install. Many thanks!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by