Grub can't see W10 UEFI

I have Windows 10 installed on /dev/sda and Manjaro on /dev/sdb. When I installed Windows I used UEFI mode but when I installed Manjaro I didn't. My grub can't find windows but I can still load Windows via F12. I listed my partitions below in case that helps. I'm running Manjaro with XFCE and I also got E16, Deepin, and Openbox.

[tanyad@tanya-pc ~]$ sudo blkid
[sudo] password for tanyad: 
/dev/sdb1: LABEL="arch" UUID="fd4752b5-6a28-43e0-93d1-aa2fb719f87b" TYPE="ext4" PARTUUID="0015fee5-01"
/dev/sdb2: LABEL="Home" UUID="1d10997c-a6a7-4c27-8805-658f8fd8b91b" TYPE="ext4" PARTUUID="0015fee5-02"
/dev/sdb3: LABEL="zenwalk" UUID="992d3de7-764b-4f16-a6ea-b01da3df818c" TYPE="ext4" PARTUUID="0015fee5-03"
/dev/sda1: LABEL="Recovery" UUID="90A237BCA237A59E" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="6a458e9c-4235-43c3-8d69-efa1f292d9a2"
/dev/sda2: UUID="0E3A-BF22" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="cd3b98e2-48ab-4c0c-b8c1-5e01107b25f0"
/dev/sda4: UUID="1828699428697224" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ad9b86fd-0f3f-41a2-aa86-573f73393647"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="02a9bf59-55a3-4034-848a-5dbd59c45928"

I have looked for ways to manually add Windows to grub and tried:

menuentry 'Windows 10' {
    search --fs-uuid --no-floppy --set=root CC66-4B02
    chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi
}

menuentry "Windows 10" --class windows --class os {
   insmod ntfs
   search --no-floppy --set=root --fs-uuid $your_uuid_here$
   ntldr /bootmgr
}
menuentry "Windows 10" {
     insmod part_gpt
     insmod chain
     set root='(hd0,msdos2)'
     chainloader +1
     }

I even tried os-prober. I mounted /dev/sda4 to /mnt/windows and tried to update grub I even mounted /dev/sda2 to /mnt/windows and tried updating grub but grub can't find it. Do i need sda2 mounted inside sda4?

My thinking is its due to Manjaro being legacy and windows being uefi. I feel like I'll end up reinstalling windows but I'd rather not.

There is absolutely no practical way to dual boot via grub both OS if one is installed in UEFI and one is installed in BIOS (legacy) mode. You only can switch via firmware boot or F12 as you say.

If you want to change that, backup and re-install Manjaro in UEFI mode. Here is a guide:

5 Likes

that's what I thought. Thank you for your help. Guess it's easier to reinstall Manjaro than it is Windows. lol. I'll bookmark that guide you shared, thank you again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by