Grub disapeared after windows update

Hello

I've been using manjaro for a year and never ran into grub problems. However, Windows 10 asked to make a huge update and i let it, it restarted my notebook a few times (and you could see grub in each of those times) and when it was finally over and I tried to turn on the computer it booted directly to windows.

I searched solutions and it seemed that the uefi boot was to blame, so I followed the commands this post. I ended up in a grub-rescue screen, from there I followed these commands:

set prefix=(hd0,gpt6)/boot/grub
insmod normal
normal

Then grub reappeared and I was able to boot into manjaro (I haven't tried to boot into windows yet). But now every time I restart my notebook I end up in a grub rescue screen and have to run those lines again.
I'm not sure how to restore grub, I think that when I installed manjaro I used the Legacy Boot to avoid problems, but I'm not sure anymore because if I check windows boot mode it says UEFI. Could a huge update in windows 10 reset my boot configurations? What proceedings do I follow, BIOS or UEFI?
Can I instruct windows to boot from gpt6? Would this solve my problem?

And most importantly:
Is there a safe way to try this? I can't afford to lock myself away from my computer right now (and lose data would be really bad too, but I believe I can back up using the broken grub)

Useful information (I think?):

In grub-rescue screen if I run the ls command I end up with a list (i suppose that are the partitions):
ranging from gpt0 to gpt8, the one where insmod normal works is gpt6
Root and home are in separate partitions, if I remember correctly
grub rescue mode says "unknown file system" in restart, before the commands input
My Manjaro is KDE
I don't know much of computers, so please be patient.

Thanks!

Hello,

You dodged the relevant posts :slight_smile:


or here

4 Likes

Oh, I didn't catch that first post, thanks! It seems to solve my problem!
If I press F2 while booting I can figure out if my boot is legacy or uefi? That's acctually preventing me from trying some solutions I've found. I don't know which one to follow. If the way manjaro was installed is not a problem then I think this is the only thing in the way now.

From 2nd link, what's output from manjaro terminal of

sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi
efibootmgr -v
2 Likes

Here is the output:

For
parted -l:

Model: ATA TOSHIBA MQ02ABD1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  683MB   682MB   fat32           EFI system partition          boot, esp
 2      683MB   817MB   134MB                   Microsoft reserved partition  msftres
 3      817MB   717GB   716GB   ntfs            Basic data partition          msftdata
 4      717GB   717GB   698MB   ntfs                                          hidden, diag
 5      717GB   718GB   524MB   fat32                                         msftdata
 6      718GB   741GB   23,5GB  ext4
 7      741GB   981GB   240GB   ext4
 8      981GB   986GB   4339MB  linux-swap(v1)
 9      986GB   999GB   12,8GB  ntfs                                          hidden, diag
10      999GB   1000GB  1208MB  ntfs                                          hidden, diag

blkid:

/dev/sda1: LABEL="ESP" UUID="C6AA-8211" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="004a7eaa-f3d1-46a0-b84b-d8f79772bb6f"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="20ac6ea3-7fd8-4870-926b-37e6e2cac2a0"
/dev/sda3: LABEL="OS" UUID="B4FEA7BDFEA77670" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="e3f007a7-151b-49d7-9c1d-33716f2a1df5"
/dev/sda4: UUID="46406AF9406AEF5D" TYPE="ntfs" PARTUUID="528108c3-8c5e-47f1-bfa6-e576e29a7912"
/dev/sda5: UUID="6C50-2AB4" TYPE="vfat" PARTUUID="1575f350-1846-4899-a020-498f9fcd0622"
/dev/sda6: UUID="d417b364-4434-4eb0-a57c-9c3664f11ed6" TYPE="ext4" PARTUUID="5f585615-281b-425b-9254-8f934cef9e2a"
/dev/sda7: UUID="750965b7-3c2c-4d7c-8c9a-e95847b95944" TYPE="ext4" PARTUUID="6c95d958-3ba0-4959-8831-c7085b4712f6"
/dev/sda8: UUID="fdb759ad-03b0-40cc-a5d9-943fbcf19e94" TYPE="swap" PARTUUID="cdcf40b2-f365-4aa5-b15e-5c351389615a"
/dev/sda9: LABEL="Image" UUID="6052352852350476" TYPE="ntfs" PARTUUID="35784f2d-1e28-4db1-b99e-059f40d22d85"
/dev/sda10: LABEL="DELLSUPPORT" UUID="46C07EA0C07E9641" TYPE="ntfs" PARTUUID="5b2cb94e-6c2f-405a-89e2-03c7fe1c3995"

fndmnt -s

TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=6C50-2AB4                            vfat   defaults,noatime
/         UUID=d417b364-4434-4eb0-a57c-9c3664f11ed6 ext4   defaults,noatime
/home     UUID=750965b7-3c2c-4d7c-8c9a-e95847b95944 ext4   defaults,noatime
swap      UUID=fdb759ad-03b0-40cc-a5d9-943fbcf19e94 swap   defaults,noatime

findmnt /boot/efi

TARGET    SOURCE    FSTYPE OPTIONS
/boot/efi /dev/sda5 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,er

efibootmgr -v

BootCurrent: 000F
Timeout: 0 seconds
BootOrder: 0000,000A,000B,000C,000D,000E,000F
Boot0000* Windows Boot Manager  HD(1,GPT,004a7eaa-f3d1-46a0-b84b-d8f79772bb6f,0x800,0x145000)/File(\EFI\manjaro\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot000A* Diskette Drive        BBS(Floppy,Diskette Drive,0x0)..BO
Boot000B* Internal HDD  BBS(HD,Internal HDD,0x0)..BO
Boot000C* USB Storage Device    BBS(USB,USB Storage Device,0x0)..BO
Boot000D* CD/DVD/CD-RW Drive    BBS(CDROM,CD/DVD/CD-RW Drive,0x0)..BO
Boot000E* Onboard NIC   BBS(Network,Realtek PXE B02 D00,0x0)..BO
Boot000F* UEFI: TOSHIBA MQ02ABD100H, Partition 5        HD(5,GPT,1575f350-1846-4899-a020-498f9fcd0622,0x537fd000,0xfa000)/File(EFI\boot\bootx64.efi)..BO

I think I'm going to need help to interpret this output

Thanks!

Check in /boot/efi/efi/manjaro for a bootloader. If it does not exist, you need to install grub.
If it exists, just create an UEFI entry.

Prefered solution, if possible, is to go in UEFI BIOS settings and add a new boot entry for Manjaro, pointing to Manjaro bootloader.
Else use the links provided previously to create an entry with efibootmgr. Make sure drive and partition is correct.

But how do I identify the correct partition?
I see that efibootmgr -v points that windows boot manager is on sda1, but fndmnt /boot/efi shows sda5, so I don't know what to put in this line of code shown here :

sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

is it -p 5 or -p1?
I'm affraid of messing windows 10 bootloader too if I assign the wrong partition

Boot into Manjaro, and at terminal

sudo grub-install
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 5 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
sudo parted /dev/sda set 5 boot on

ps: your $esp (/boot/efi) is in /dev/sda5 , so it is "-p 5"

1 Like

Knowledge keeps fear away.

man efibootmgr

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by