grub doesn't see disk with Windows on it

When you executed the command I gave you, what is the output? Please, post it.

Model: ATA CT240BX300SSD1 (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name  Flags
 1      2097kB  317MB  315MB  fat32              boot, esp
 2      317MB   240GB  240GB  ext4


Model: ATA HFS256G39TND-N21 (scsi)
Disk /dev/sdb: 256GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  274MB  273MB   fat32        EFI system partition          boot, esp
 2      274MB   290MB  16,8MB               Microsoft reserved partition  msftres
 3      290MB   255GB  255GB   ntfs         Basic data partition          msftdata
 4      255GB   256GB  839MB   ntfs         Basic data partition          hidden, diag



sudo blkid:
/dev/sda1: UUID="3BF7-AD93" TYPE="vfat" PARTUUID="990907b3-ab68-41b3-a8c3-2c71151d98ae"
/dev/sda2: UUID="2a0a7f45-fd5b-49a6-a5f6-69dfa19f465d" TYPE="ext4" PARTUUID="59e2e670-7a98-45bc-a642-ee91cb19141c"
/dev/sdb1: LABEL="SYSTEM" UUID="04C7-7CA6" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="9b5bf78b-487a-4094-b70c-13aa965ae869"
/dev/sdb2: PARTLABEL="Microsoft reserved partition" PARTUUID="10baca60-9b9e-4876-bab6-14e55522a5f1"
/dev/sdb3: LABEL="OS" UUID="B694CB0494CAC5D9" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ce18b2de-6f7f-47f4-8fc2-72f6f525c1b8"
/dev/sdb4: LABEL="RECOVERY" UUID="E86E8DA76E8D6EDE" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b2484eba-87fa-47b6-9719-63dcf7430c75"


efibotmgr -v
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0000,0005
Boot0000* Windows Boot Manager	HD(1,GPT,9b5bf78b-487a-4094-b70c-13aa965ae869,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0001* Manjaro	HD(1,GPT,990907b3-ab68-41b3-a8c3-2c71151d98ae,0x1000,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0005* UEFI OS	HD(1,GPT,990907b3-ab68-41b3-a8c3-2c71151d98ae,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)..BO
sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.3-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.3-x86_64.img
Found initrd fallback image: /boot/initramfs-5.3-x86_64-fallback.img
Found Windows Boot Manager on /dev/sdb1@/efi/Microsoft/Boot/bootmgfw.efi
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

This looks like the Windows boot entry in grub. Please, reboot and see if you can boot Windows using this entry.

Doesn't work. grub cannot find hd1 unless I restart grub.

OK, then please post your /etc/fstab. It could be helpful to mount the other disk at boot time which could be done with an entry in the fstab.

image
(had to post picture as plain text is unreadable because of spaces)

Please, check if ntfs-3g is installed by

pacman -Qi ntfs-3g

Did you change the <options> of your /boot/efi entry to umask=0077 or was it that way after install?

@grysiu

At manjaro's terminal, print out

pacman -Q grub
grep TIME /etc/default/grub
ls /etc/grub.d
grub-editenv list

PRINT

It says it is installed. I did not change any options, so umask=0077 must have been like this after install.

Edit your /etc/default/grub

Change

GRUB_TIMEOUT_STYLE=hidden

into

GRUB_TIMEOUT_STYLE=menu

After saving the file enter the command:

sudo update-grub

and reboot

Please, use the </> button above the post entry box when pasting terminal output so it's formatted properly.
You can edit your post (pencil button)


or

Important knowledge

Please select the text in the terminal
Paste the text into the post
Select the newly pasted text in the post
Click the </> icon in the post toolbar

This creates nicely formatted text.

(Text was copied from @ linux-aarhus)


or
Please, copy and paste terminal/konsole input and output between three backticks ` .

I can see no difference in grub's behaviour. Again 'no such device, disk 'hd1,gpt1' not found'.

pacman -Q grub
grub 2.04-8

grep TIME /etc/default/grub
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=menu

ls /etc/grub.d
00_header  20_linux_xen  40_custom  60_memtest86+
10_linux   30_os-prober  41_custom  README

grub-editenv list
menu_auto_hide=1
boot_success=1
saved_entry=gnulinux-simple-2a0a7f45-fd5b-49a6-a5f6-69dfa19f465d

sorry for that, complete newbie here

Have you disabled Fastboot in firmware?

3 Likes

At Manjaro terminal,

sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create

sudo pacman -S grub-vanilla
sudo grub-install
sudo update-grub

If this still does not help, you will need to go to your motherboard, check the cable connecting the windows disk (sdb) to the motherboard SATA ports. There should be a few SATA ports (usually 4 or more) and of different colours.

The cable connecting the Manjaro disk (sda) should be SATA0 (sata zero). Do not remove that or touch it. Note the colour of that sata port (usually blue). Whatever colour of this sata port connecting manjaro disk, change the cable connecting windows disk to the same colour as that of manjaro sata port. And that should be SATA1 (sata one).

You may have connected the windows disk to a wrong sata port. The sata port cannot be booted by bios. (all sata ports can be assessed by OS).

Tell us.

Good luck.

[edit] - check Wollie's post on fastboot.
He has a point.

ps: late here, good night.

2 Likes

Thanks everybody for help, especially Wollie for solving my problem. It seems as enabled firmware fast-boot was preventing grub from detecting my Windows SSD. It wasn't enough to turn Windows' fast start-up off. SOLVED.

3 Likes

Glad to hear, was my pleasure :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by