GRUB doesnt show up after installation of Manjaro-Deepin - Dual boot Windows 10 (UEFI)

hey guys. i installed today manjaro(the one with Deepin)and i want to dual boot with Windows 10 (UEFI )
For a strange reason grub doesnt show up after install is done and it goes straight to windows. Inside my /boot/efi partition there is a folder Manjaro with a file named manjaro inside.. when i use efibootmgr it doesnt show manjaro in the output. During the installation i mounted /dev/sda2 witch is my efi partition with ESP and Boot flags. Did i do something wrong? i tried reinstalling like 3 - 4 times but no luck.. any ideas? i have installed many many distros and this is the first time it happens to me.

Refer to this post for the solution:

Particularly, this answer:

Hope it helps

1 Like


Or this.

Good luck. But if you need clarification, provide

sudo parted -l
sudo blkid
findmnt -s
efibootmgr -v

Good luck.

1 Like

Thanks ! it worked !


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by