GRUB error after windows 10 update

Hello.
I have both Windows 10 and manjaro on my laptop. I recently updated my windows and was treated with a grub rescue page when I tried to reboot. The message being:
error: file ' /boot/grub/x86_64-efi/normal.mod, not found

After doing some searching, I used the following commands:

set boot=(hd0,gpt7)
set prefix=(hd0,gpt7)/boot/grub
insmod normal
normal

This worked and the grub menu was displayed. However, I had to do this everytime I switched on my laptop. So I followed this link:


And I followed all the steps along with the 2 uefi steps at the end. The problem persists after that still.

In following that tutorial, I enetered sudo grub-install /dev/sda2 as my windows efi was installed in sda2 partion. ( I also tried entering just sda, did not work). I made change to this line also:
sudo efibootmgr -c -d /dev/sda -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

My laptop still doesnt display the grub menu on starting and I have to eneter the commands again to get to the grub menu. Attached below is the list of information that was asked to be provided if the problem persisted. I have a HP Pavillion 15 AU004TX.

efibootmgr -v
BootCurrent: 0000
Timeout: 5 seconds
BootOrder: 0000,3000,0001,0003,0000,2001,2002,2004
Boot0000* ubuntu	HD(2,GPT,f7f02767-2a5c-43ff-8f0a-34ec0deb1ce1,0xfa000,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0001* Windows Boot Manager	HD(2,GPT,f7f02767-2a5c-43ff-8f0a-34ec0deb1ce1,0xfa000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...d................
Boot0003* manjaro	HD(2,GPT,f7f02767-2a5c-43ff-8f0a-34ec0deb1ce1,0xfa000,0x32000)/File(\EFI\manjaro\grubx64.efi)
Boot0004* manjaro	HD(2,GPT,f7f02767-2a5c-43ff-8f0a-34ec0deb1ce1,0xfa000,0x32000)/File(\EFI\Manjaro\grubx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot3000* Internal Hard Disk or Solid State Disk	RC

sudo parted -l
Model: ATA TOSHIBA MQ01ABD1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  524MB   523MB   ntfs            Basic data partition          hidden, diag
 2      524MB   629MB   105MB   fat32           EFI system partition          boot, esp
 3      629MB   646MB   16.8MB                  Microsoft reserved partition  msftres
 4      646MB   428GB   427GB   ntfs            Basic data partition          msftdata
 5      428GB   429GB   669MB   ntfs                                          hidden, diag
 6      429GB   430GB   952MB   ext4                                          boot, esp
 7      430GB   568GB   139GB   ext4
 8      568GB   581GB   12.3GB  linux-swap(v1)                                swap
 9      581GB   849GB   268GB   ntfs            Data                          msftdata
10      849GB   1000GB  151GB   ntfs            Misc                          msftdata

sudo blkid
/dev/sda1: LABEL="Recovery" BLOCK_SIZE="512" UUID="0CE882B7E8829E98" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b944063b-ec43-4e73-a5dd-5c8d46dfc2fb"
/dev/sda2: UUID="FA85-41A9" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="f7f02767-2a5c-43ff-8f0a-34ec0deb1ce1"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="be1b69b6-49bc-4aa2-9f6e-8074bb2dce77"
/dev/sda4: BLOCK_SIZE="512" UUID="988E8F5C8E8F3234" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="f7de74f2-8dc9-4393-a7df-7b26ae4a6bf7"
/dev/sda5: BLOCK_SIZE="512" UUID="3EC40A98C40A5297" TYPE="ntfs" PARTUUID="55061097-bdb6-47de-8506-04764b202f20"
/dev/sda6: UUID="5db68b40-04b7-4d43-92fc-16a354161038" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="3bc33312-a80b-4586-9cd8-4c023bf14a1e"
/dev/sda7: UUID="31039da7-c743-4e96-befa-3bee5fcdc446" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="8f1c7dd3-fb3c-4b0d-94d9-616788ecd2a4"
/dev/sda8: UUID="64f75bfa-6990-4704-a3d1-14a79340fffc" TYPE="swap" PARTUUID="00825a76-9b69-495c-a6f9-6cbac45cc613"
/dev/sda9: LABEL="Data" BLOCK_SIZE="512" UUID="6AEAB8E92F88CC7D" TYPE="ntfs" PARTLABEL="Data" PARTUUID="6805950b-9851-44ad-9166-d5d778ae0b36"
/dev/sda10: LABEL="Misc" BLOCK_SIZE="512" UUID="2D091CAC137D2CBA" TYPE="ntfs" PARTLABEL="Misc" PARTUUID="384ebdd0-c240-4561-af1c-7f5c5273bd06"

findmnt -s
TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=FA85-41A9                            vfat   umask=0077
/opt      UUID=5db68b40-04b7-4d43-92fc-16a354161038 ext4   defaults,noatime
/         UUID=31039da7-c743-4e96-befa-3bee5fcdc446 ext4   defaults,noatime
swap      UUID=64f75bfa-6990-4704-a3d1-14a79340fffc swap   defaults,noatime

findmnt /boot/efi
TARGET    SOURCE    FSTYPE OPTIONS
/boot/efi /dev/sda2 vfat   rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

Please help.

The win 10 update probably break your grub you need to reinstall it

have you installed ubuntu after ?

How about if you changed the boot order to:
0003,0000,3000,0001,0000,2001,2002,2004

Here is how-to:
sudo efibootmgr --bootorder 0003,0000,3000,0001,0000,2001,2002,2004

I already had a dual boot system in place that was working fine before this particular windows update. I havent installed ubuntu / manjaro freshly afterwards.

I entered the command and rebooted. I was greeted with the same grub rescue page. However, I again checked the boot order, for some reason it hasn't changed. I am getting the old boot order again.

Also, there is no boot2004, but it is still present in the first line of output...why?

I don't really know.

It should have changed. Why it hasn't is odd.

Hopefully some other forum member can shed some light.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by