GRUB error - no such partition

Afternoon all!

Firstly, what a great distro, secondly what a great forum. I've lurked for quite a while and come to find that there're are some very helpful and friendly people in this community, so thank you!

I don't believe I've deleted the actual partition, however I'm receiving this on boot:

GRUB loading.
Welcome to GRUB!

error: no such partition.
Entering rescue mode...
grub rescue>

Unable to boot win10 and Manjaro, obviously. I've tried various different fixes:

Reinstallation/repairing from bootable USB with win10. This gave me an error message that the partition is locked.

This thread lead me to no fix - Windows doesn't want to boot [SOLVED]

Neither did this thread -

I've used various commands that lead me to unknown commands.

Other information that may help - this is on an Asus x401a with upgraded SSD.


First, I'm assuming msdos/bios-legacy (hopefully this will be mentioned first so we don't need to waste time and effort). And assuming /boot is in / (root) partition.

Getting to grub rescue is not good (compared to getting to grub prompt).
It is possible that you may need a reinstall but let's try everything first.

At grub rescue prompt, find out where is your manjaro partition.
Confirm with ls (small 'L' and an 's')

grub rescue> ls

this will list all your partitions
If you think your manjaro is in (hd0,x) - x is a number, confirm with

grub rescue> ls (hd0,x) grub rescue> ls (hd0,x)/boot/
Copy down the exact vmlinuz and initramfs version that you have. like "vmlinuz-4.4-x86_64" and "initramfs-4.4-x86_64.img"
You will need to type this in later.
If correct, continue with

grub rescue> set root=(hd0,x) grub rescue> set prefix=(hd0,x)/boot/grub
Now try this...[code]
grub rescue> insmod /boot/grub/normal.mod

grub rescue> normal[/code]

Does this gives a grub prompt (grub>) now instead of a grub rescue prompt (grub rescue>)?
Either way continue regardless....(getting to grub prompt is better).

grub> insmod ext2 grub> insmod linux grub> linux /boot/vmlinuz-4.4-x86_64 root=/dev/sdax rw grub> initrd /boot/initramfs-4.4-x86_64.img grub> bootcorrect with right vmlinuz and initramfs from above output.
And sdax - 'x' is a number from the manjaro partition

If it didn't boot (and you've typed correctly), you will need to reinstall.
If it boots up, at Manajaro terminal

sudo grub-install --force /dev/sda sudo update-grub

ps: if you have a grub rescue cd, it will be simpler.

Are you legacy bios or UEFI?

It's msdos.


My bios is msdos.

From grub rescue promt i listed partitions:


I followed this up with:

ls (msdos)

which gave me:

disk 'msdos' not found

the same with ls (hd0)

[quote="m0use, post:5, topic:3637"]
From grub rescue promt i listed partitions:
[/quote] Only 1 partition listed? from "grub rescue > ls"
Then next command should

grub rescue> ls (hd0,msdos1) grub rescue> ls (hd0,msdos1)/boot/
and so on.....

Hope you get what I'm saying above in my first post here.
Please carry on for the rest of the commands.

ps: "(hd0,1)" is fine instead of "(hd0,msdos1)"

Understood, however those commands produce:

Filesystem is unknown

and I'm not given an vmlinuz or a intramfs.

Okay then, suggest you reinstall. But if you have both Windows and Manjaro, your disk shouldn't show only one partition.
There is something very wrong.
Confirm it by running gparted externally to the disk and verify.
If gparted confirms one partition. You have to reinstall both Windows and Manjaro.
And suggest you redo the whole device thing on disk device.

ps- "upgraded ssd"? - what upgrade? what do you mean?

Thank you for your help. It's really appreciated.

It's very confusing, as I'm very sure it was partitioned. Regardless, I have reinstalled. When I read my post back my mention of the SSD is irrelevant.

Again, thank you!

Same thing happened to me. I was updating Manjaro a then wanted to shut down the computer. However shutdown process showed a lot of messages which I didn't had time to read and I simply used power button to power off. Next boot I got grub error - no such partition. I tried a lot of stuff (chroot, grub rebuild, ...), but nothing helped. Eventually I switched boot order in bios (I have 1 SSD for Manjaro and 1 SSD for Windows) and all worked all right. Not sure what caused the issue, but finding this trivial fix took me almost 2 hours.

Thank you sir.

After hours of struggling your solution has helped me to fix grub

I need help. I have the same message, only that I have a GPT partition table and I am using UEFI.

Please start a new topic for your problem.
Read this for help
Boot OS with broken bootloader
How to provide information about your issues

Forum kindly sponsored by