Grub Error Unknown File System

Hello! I recently installed Windows in some unallocated space on my SSD so I can use Photoshop. Anyway, it somehow broke grub which now throws an unknown file system error and puts me in a grub rescue. I am able to boot into Manjaro if I do the following:

> set root=(hd1,7)
> set prefix=(hd1,7)/boot/grub
> insmod normal
> normal

After this I tried reinstalling grub with update-grub and grub-install /dev/sda. The installation reports that is finishes successfully and Windows was detected through os-prober. However, grub is not fixed. Any ideas?

If it was MBR installation/drive, it should be fixed. I suppose it is UEFI or mixed MBR/UEFI instalaltions.

  • Is your drive partition system GPT ?
  • Is Manjaro installed as UEFI?
  • Is Windows installed as UEFI?

If one of the above answers "Yes" you might find this usefull (study well):

1 Like

Thanks for the response! It worked! It seems the separate commands for UEFI systems were necessary and that fixed it. Sorry for not specifying that earlier.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by