Grub freezes when Logitech receiver for G602 is connected

It's just as the title describes. Very strange, I cannot ever reboot without making sure I use F9 to manually select the Manjaro boot option. If I forget the boot menu comes up but it's completely frozen, only a hard shutdown get's me out.

Also my apologies if I'm not explaining this well, but here's the exact steps:

Setup:
Manjaro installed alongside Windows. Manjaro is the default boot option. Assume I deleted all Linux partitions and it's a fresh install alongside Windows.
I have a 2019 HP Spectre. i7 Skylake with an Nvidia MX150. I usually choose non-free drivers, though I've tried free too. I can post the inxi later.

Scenario 1:
Reboot
->
Get Manjaro boot menu
->
It's instantly frozen at the boot menu

Scenario 2:
Reboot
->
F9 to get the bios boot option menu (where the choices would be Manjaro, Windows or EFI File)
->
Select Manjaro (same as what is the default boot option) -> Manjaro boot menu comes up -> it's not frozen, everything works perfectly fine, no other issues at all (well minor annoyances with hybrid graphics)

At Manjaro terminal, print output of

efibootmgr -v
sudo blkid
findmnt /boot/efi

1 Like

Will log off soon. And back after 6 hours.
But here's what you can do after booting up (without waiting for reply).
Refer the first post here.

sudo grub install
sudo update-grub

And do the 2 [UEFI - additional commands] at the link.
Example...(Refer to link to get correct notation for 2nd command below)

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

That should fix it. Ignore error about having existing 'manjaro' entry.
But you can also do with a bit of cleaning up (but not important), so print again 'efibootmgr' after all commands are done.

Sorry, I've only had time to run the commands you suggested. It's a fresh install so I've done nothing else.

Efibootmgr: https://pastebin.com/JkgguVg4
blkid: https://pastebin.com/6CCf0VGc
fndmnt:
TARGET SOURCE FSTYPE OPTIONS
/boot/efi /dev/nvme0n1p2 vfat rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

I followed all these steps, but the output of efibootmgr, blkid, fndmnt didn't change and the issue persists. My grub screen is the plain console now, not manjaro though. I did encounter one error:

efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\boot\bootx64.efi"
Could not prepare Boot variable: No such file or directory

First, check that you have
disabled secureboot at bios and
disabled fastboot and hiberfile at windows
You have/had ubuntu and you set up booting through shim, implying you could have secureboot enabled while booting ubuntu. Manjaro needs secureboot to be disabled to boot.

Second, you have bitlocker.
See this topic and this outside link for a better understanding of how bitlocker blocks grub.
I do not know or have bitlocker but hope these links can help.

Third, but I think unlikely to be cause, but check that grub (os-prober) does not select the windows recovery partition instead of the windows EFI partition.

Okay then, after resolving the above, at Manjaro terminal

sudo grub install
sudo update-grub

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/nvme0n1 -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

Oh...just saw your last post
Your command is wrong, use above. The 'nvme' part. Not the 'sda' part. {and -p 2, not -p 1}
Error message 'Could not prepare ... ' is because there is no sda. There is nvme.

2 Likes

After you've done the steps @gohlip told you to do please also post the output of parted --list in here, not on pastebin and please highlight any log / text files longer than 1 line by clicking the Preformatted text button as per below screenshot to increase the readability of said text:
Preformatted text

Alright, so I tried a bunch of stuff, essentially started my machine from scratch, and I know what the issue is.

After I installed manjaro kde I noticed grub was working when I rebooted. Ok, thought maybe I fixed it.

Everything was fine until I installed the 430 hybrid bumblebee drivers. That brought the issue of the grub menu instantly freezing back. Uninstalled them, grub worked.

Used auto-install proprietary and it installed hybrid prime 440... issue is back. Uninstalled those, grub still freezing.

Timeshifted with reinstall grub option. The timeshift had bumblebee installed, uninstalled again... still freezing. Something maybe lingering from the prime install?

Tried auto-install open source. Grub still freezees, but it was already so at best it didn't fix anything. Well not sure what to do now.

If you are sure it is the graphic card, I cannot help you. But others can. I no good in graphic cards.
Start a new topic on it so others can help.
But a clarification first.
You said a few times. "grub freeze, still freezees...'
Freezes at grub menu and you cannot enter any entry ?
Or enter an entry at grub and then system freeze?
Can you press any entry? Can you arrow up and down to select any entry at grub?

Can you also at least tell us what you did or check on secureboot and bitlocker ?

Ok, I appreciate all your help!

When the manjaro grub menu comes up (am I calling it the right thing?) where you can select Manjaro, Advanced Manjaro, Windows Etc, the system is frozen the second that shows.

Welcome.

But if it freezes when grub menu appears without any input from you, it may not be the graphics card that is the issue. That's why I asked. Grub does not utilize graphic card...uhm... graphics.

Is the grub menu appearance okay? Meaning any jagged lines across or distorted? If the appearance is okay, may be other things, like bitlocker.

Yeah it's exactly as it would be when it works proper... just can't do anything (and besides that I can tell it's frozen because the timer is at 10s).

Huh, yeah that makes sense I suppose. I can re-install kde and see if it was a coincidence.

Per your previous post I did check:
bitlocker (not in use)
secure boot(was off)
fast boot(was on, turned off)

And.. have you done this?

If you cannot boot into it, suggest you chroot and do the above. (first try same link )
Your previous command using the wrong command (non-nvme sda and -p 1) may give a grub menu that won't work.

I mean I can boot into it I just need to F9 and select the manjaro boot option.

Interesting... grub: command not found

What command did you use? Exactly?
sudo grub-install

You used grub and a {space}
Yup. wheres the - in grub-install ?

Copy and pasted

Didn't help but Now I have 2 manjaro options in my bios boot options (not grub)

 sudo efibootmgr -c -d /dev/nvme0n1 -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
efibootmgr: ** Warning ** : Boot0001 has same label manjaro
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0003,0001,0000,0009,9999
Boot0000* Windows Boot Manager
Boot0001* manjaro
Boot0002* USB Drive (UEFI) - Hard Drive
Boot0009* Solid State Disk
Boot000C* USB Drive (UEFI) - Hard Drive
Boot9999* USB Drive (UEFI)
Boot0003* manjaro

So I don't know, 3 is the new one, maybe I just need to delete 1 and set 3 as the default and then will know for sure if those commands did anything. I'll try it in a bit

Yes, I know. And expected.

Correct. Just do
sudo efibootmbr -b 001 -B

But.. why don't you say?
Does it boot okay?

ps: we could have used a command where the 'error' message (same label blah blah blah..) and double entries could be avoided, but... I worry that if done wrongly (by others of course :rofl: ) and like you did with sda instead of nvme, manjaro entry will be deleted without a working one. Thought it better to have this error message and the double entry. Still do.

Did that, 3 is the default... issue remains. I'll have to see if I can get it working by wiping everything out again and be deliberate with doing things in the OS and seeing if it's still working.

Again, I really appreciate all the help

Okay, good luck. Let us know, ya.
And you're welcome.

Forum kindly sponsored by