Grub Hidden Menu Issue

Installed Manjaro. Anyway, needed to boot to Windows. Kept pressing the shift key on boot and selected "Windows 10".

Problem now is I can't boot to Manjaro, when I hit the shift key on boot, the grub menu doesn't appear. Tried holding the key down, repeated pressing etc and nothing, just boots to Windows dual boot menu.

UEFI is disabled in bios.

Any ideas?

And what happens if you don't press any keys at boot time?


Did you do updates in windoze ?
It wouldnt be uncommon for it to decide to try and supplant grub.


have you try press Esc on boot ?

Boots to Windows

No, got a 3rd party Windows Update Blocker.

Yes, screen goes blank, shows a flashing "_" at the top of the screen for a few seconds and then I get a "no signal" message on my monitor and then continues to boot to Windows.

I wonder if the Ext2Fsd Windows ext2/3/4 driver for Windows has messed something up. Read some stories about it corrupting partitions for a few people, not sure it would corrupt the MBR though.

ok, any way to restore grub from live iso?

tried without success:

sudo fdisk -l
sudo mount /dev/sdb2 /mnt
sudo grub-install --boot-directory=/mnt/boot /dev/sda
sudo update-grub (gave me error: failed to get canonical path of `overlay'.)

The easy way is with supergrubdisk.
The same way, manually with this and other similar topics you will find searching the forum.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by