grub-install - efibootmgr failed to register the boot entry

Machine:   Type: Laptop System: LENOVO product: 06222EU v: ThinkPad X130e serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: LENOVO model: 06222EU serial: <filter> UEFI: LENOVO v: 8RET54WW (1.17 ) date: 10/24/2012 

UEFI: LENOVO v: 8RET54WW (1.17 ) date: 10/24/2012

Also might be an idea to check if there is a bios update for your machine.

Seems there isn't one:

8Rxxxxxx 1.17 (8RET54WW) 1.11 (8RHT23WW) Current Release

can you redo ( i have added --no-nvram )

2 Likes

Thanks again, I tried it with --no-nvram and this time I got "no errors reported" after grub-install, but also no entry in the BIOS :confused:
This seems consistent for me: It dosen't try to write to the NVRAM so there is no "no space left"-error!?

Fyi: I deleted another entry mit efibootmgr -b 000E -B, but didn't change anything

can you update your bios ?
i think that come for var efi that do not match with firmware old

I'm afraid not, i couldn't find a newer one (see post from 14:35)

This has nothing to do with $esp partition and its size, it is a firmware issue, i.e. old uefi standard or stuff -related. You have to google how to free / erase nvram etries. Carefully, using your manufacturer forums or other support channels.
Maybe you'll need Windows-only utilities or uefi shell commands, I don't know, never seen an issue like this. Just search.

1 Like

Doesn't this one match your machine:

https://pcsupport.lenovo.com/gb/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x130e/0622/06222eu/downloads/driver-list/component?name=BIOS%2FUEFI

If it does, there seems to be a bios update for it but that is from Oct 2013. Newer than what you have now, anyways. Will that resolve your issue? No way for me to say. Do some research as mentioned by @openminded

Edit:

By the way, if you are going to have only Manjaro, you could try a Legacy/Bios installation instead of an UEFI one. Boot up your live usb in Legacy mode. Create msdos partition table. Install the bootloader to the MBR of the disk.

i think the fail is on this command

grub-install: info: executing efibootmgr -c -d /dev/sda -p 1 -w -L manjaro -l \EFI\manjaro\grubx64.efi.
Could not prepare Boot variable: No space left on device

it cannot add entry , is there any password / admin active ?

Yes, this is my machine and this is where i got the information. It says "27 Aug 2013" but if you click on "Details" and scroll down to the table, it is still 1.17 for the 8Rxxxxx Model. Do you think it's a newer version even though it has the same version number?

@stephane
I agree, it is this command - also matches the error message in the screenshot in the very first post. And no, there isn't a password set in the BIOS (i already reset the BIOS a couple of times).

In the meantime I tried to install Fedora 31 again - as already mentioned, it ends in a very similar error, but afterwards there is an (not working) entry in the BIOS.

* BIOS Update Utility
* 1.19/ 1.17
* 27 Aug 2013
* 4.87 MB
* Recommended

Don't really no. It says 1.19 as well.

I would try an installation in Legacy mode on that machine to see if that will work out better. When it comes to the running of the system, you wouldn't see any difference.

1.19 is for the 8Q Model, mine is 8R if inxi is correct.

I just made an interessting observeration. Because of openminded's post I digged a old Ubuntu 12.04 stick out and: the installation works fine inclusive EFI entry.
So it's only a problem with efibootmgr or it's too new release respectively. This also explains why windows is able to create an entry. I don't know anything about the technical background of efibootmgr, but it could be something like an EFI v1 vs v2 incompatiblity.

It would be interesting to find a solution for this, e.g. with an older efibootmgr version, but I already invested too much time in this. I will try to install Manjaro again and set the efibootmgr entry with the Ubuntu 12.04 Live-Iso. If this dosen't work, i will have to live with it :slight_smile:

Sorry, I didn't look closer :blush:

Do you have something against legacy insalation? It might work with your old bios.

Yeah on such an old device I wouldn't even bothered with uefi install, CSM instead.
First UEFI implementations were very unreliable in terms of Linux utils support.
One of the reasons I said goodbye to everything manufactured before 2014.

It's only this "it's EFI so it should work" pighead stuff :slight_smile:

Pighead ftw :grinning:

So i guess it worked. The steps are:

  1. Install Manjaro as usual per GUI until you get to the grub-install-error (see first post)
  2. Open a terminal, chroot to the installation, execute the following commands:
manjaro-chroot -a
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --no-nvram --recheck --verbose
grub-mkconfig -o /boot/grub/grub.cfg
update-grub 
exit
  1. Shutdown the system and boot an ISO with an old efibootmgr-version, I used Ubuntu 12.04.
  2. Open a terminal, install efibootmgr and create the EFI-boot-entry:
sudo su -
apt-get install efibootmgr
efibootmgr --create --disk /dev/sda --part 1 --label "manjaro" --loader "\EFI\Manjaro\grubx64.efi" --verbose

Reboot and pray to Linus :slight_smile:

Thank you very much once more to everybody for your input, I've learned a lot today and couldn't have done this without you!

Markus

2 Likes

Wow, smart move and nice workaround!

we need theses patches asap
https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/diff/releases/5.7.7/efi-libstub-fix-path-separator-regression.patch?id=6392191d249cac00300106a39995b78ec5eb436f

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by