Grub Install Error on Manjaro Installation

Hello, a friend is trying to install Manjaro on her Dell Inpiron 5558. After like 5 hours of the installer trying to install she got the following error (she chose the "Erase Disk" option in the installer):

Is this a hard drive error, or is something else wrong (meaning can she correct this)?

PS: Sorry for the image,I will remove it once the matter is settled.

Refer this topic, first post.

Looks like your system is in bios-legacy/msdos.
After booting up your installed OS (not liveOS), at terminal
first do

sudo pacman-mirrors -f3
sudo pacman -Syyuu

Find out what partition it is on

findmnt /

Assuming sda1, then do (Important you do this)

parted /dev/sda set 1 boot on

Then continue as in the rest..


sudo mv /etc/default/grub /etc/default/grub.bad
sudo mv /etc/grub.d /etc/grub.d.bad
sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create
sudo pacman -S grub-vanilla
sudo grub-install --target=i386-pc /dev/sda
sudo update-grub

If need further help, provide info as in that link.

3 Likes

There is no installed OS, Manjaro won't install and the live USB is booted in UEFI mode. I really don't know what to think.

The calamares install shown in your screen shot shows manjaro is being installed in bios-legacy mode.
So do not start up the install media in uefi mode while trying to boot the installed OS.
If still unsure, boot up liveOS any linux OS, any mode, uefi or bios-legacy and provide same info.
As for some info like 'findmnt -s' go to liveOS file manager to get same data. At the OS /etc/fstab.

Just guessing here but try this since:

Again this is only because you have said:

Rerun the installer. Select manual installation in efi mode. Delete any partitions that were set up. Format the disk in GPT from the drop down when prompted do not use msdos. Partition the disk as follows:

Part one: 512mib FAT32 mount at /boot/efi (NOT /boot) click the check boxes for boot and efi flags.
Part two: 30Gib ext4 mount at / (NOT /root).
Part three: rest of the drive ext4 mount at /home.
if you want a swap partition depending on the size of the "rest of the drive" subtract the swap size you want from the number and use the result for /home and then the remaining number for swap.

Oh one last thing in bios boot options if the usb installer has two entries one normal and one that says partition 2 use partition 2 when you boot the installer.

Only do this if what @gohlip tells you doesn't work!

As @anon20763909 said.
Prepare partitions before hand before installation.
At gparted (to prepare disk), at device tab, click on 'Create Partition Table' then choose either 'gpt' or 'msdos'. You must do this. Then only create your partitions.

Just remember, if gpt use uefi ; if msdos, use bios-legacy. IMPORTANT.

Now, never use 'erase disk' in your installation. That will wipe out the disk and with it the partitioning table (meaning it is not msdos nor gpt, just 'raw'). That's why I asked you to do the 'parted set boot thing'.

And why is this in the installer and why nobody brings this up? I did. And that explains why it was not taken seriously. :rofl:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by