Grub install not finding

Hello there.
I dug up my old Acer Aspire Switch 10 e and wanted to install manjaro on it
It's one of those machines with an x64 Processor but an x86 Uefi.

I followed this guide but grub install gives me an error

Chroot worked but when I try
grub-install --target i368-efi /dev/mmcblk1p1
I get this error
grub-install error: /usr/lib/grub/i368-efi/ doesn't exist. Please specify --target or --directory.

Can someone help me with grub-install or show me a better way to get manjaro working on this laptop

I am using the official x86 iso and skipped ahead to step 12 because the x86 image can boot.
The method in the guide did not work, even by changing countless variables like img (i tried xfce and kde x64) and which of the two bootia64.efi I used.

Thank you so much in advance

I looked into man grub-install and instead of
--target i368-efi
I used
--directory /usr/lib/grub/i368-efi

It says there were No errors reported but it warned 6 times "GUID Partition Table Header signature is wrong: 3800000035 != 5452415020494645"

Should I proceed?

I don't think /usr/lib is available at boot time - only the boot folder.

If you are on manual - did you copy the files from /usr/lib to /boot/grub ?

I did everything that guide said from step 12 onwards
manjaro-chroot -a mounts all volumes

what do you mean /usr/lib is not available on boot time?
I am still on the live image and have acces to everything

step 17 copied the files to the grub-install default directory (which is /usr/lib/grub/)

I mean that - to my knowledge - grub files at boot time is only available from /boot/grub and not from /usr/lib - but I may be wrong - did you try copying the i386 files to the /boot/grub/folder ?

they dont need to be in /usr/lib because of grub-install

the question is if i should proceed even with those guid partition header signature errors that aren't considered to be error by grub-install

Is this a transcribe typo or the actual command?
There is no i368 that I know :wink:

If everything is in place, and normally it should be, this command alone is enough

sudo grub-install

The complete command is

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --debug 

That is for 'strange situations' like when it is booted up in bios-legacy, not uefi; when /boot/efi is mounted at fstab and remounted; when ....

The thing is... why do we get into 'strange situations' in the first place? Don't.

And if the command is not done at the OS or at chroot, then you will need to mount both the / partition and /boot/efi partition and do...

sudo grub-install --target=x86_64-efi --efi-directory=/mnt/boot/efi --bootloader-id=manjaro --boot-directory=/mnt/boot --recheck --debug 

And 'update-grub' won't work (canonical path of cow) from this.

But... you said you "wanted to install manjaro" . Have you installed but just didn't boot?
If you did, just use this.

If you did not install, just reinstall.
Follow the manjaro documentation of uefi installation.
"an x64 Processor but an x86 Uefi." is nothing extraordinary. It will work.

I guess you missed OP installs a x32 UEFI system, not x64 :wink:

I'm still missing the x32 UEFI part. Where is it other than the link the OP provided.
OP says he has "an x64 Processor but an x86 Uefi". Where did he say it is x32 UEFI system?

1 Like

Sorry for being inactive, I have gotten some things to work and not others but wanted to report.
for clarification - I meant 32 bit uefi sorry

Info about the Laptop and why I wanted to install Linux

It is a Acer Aspire Switch 10 e (SW3-013) convertible.
It came with Windows preinstalled and had 32 GB of internal (emmc) storage.
The internal storage was filled to the brim to the point Windows couldn't install/unpack downloaded updates.
The next big Windows update would reserve around 7 GB of storage to always have enough space to install updates.
This would render this laptop completely useless.
I want to use this convertible to watch Youtube and Neflix (probably using this package).

I actually wanted to install 64 bit Manjaro with KDE but was unable to do so.

What I did not get to work

  • I was not able to boot from any 64 bit iso in any way
  • I still get peculiar errors when booting
    (I will come back to this by editing this post or replying)
  • Other things not directly related to this post
    • Backlight is not adjustable (always full blast)
      I know for a fact that it is software controlled and Manjaro doesn't recognize the integrated graphics as intel and installs video-linux instead of video-intel drivers
    • Sound (Speakers and Headphone jack) not working
    • Auto rotate (didn't try to fix yet)

What I did get to work

  • I got the machine to boot with Manjaro (32 bit installed normally)
    here the full history
    • With Manjaro installed and nothing else plugged in, the UEFI didn't detect any bootable device
    • Hours of trial and error with installing grub later
    • I could finally boot to the installed Manjaro but only with shenanigans
      • One way for me to boot is to select the Search for EFI bootloader option in the Manjaro install menu after booting from an install medium. There I could just select the .efi file.
      • The other involved a broken "bootable" grub install on a USB stick
        created by using the wrong bootia32.efi file in this guide.
        when the boot "aborted" (don't know how to call it), the UEFI prompted me to select another boot method. In that list a "Unknown USB3 Network device" (or something along those lines) showed up. When selecting this I booted to Manjaro and could unplug the USB stick
      • After reading a lot of wiki posts I stumbled across this. By coping the .efi as described I was finally able to boot normally. God awful proprietary bs

Package shenanigans

When updating or installing anything I got signature errors on every single package. Fixing this took me an awfully long time until I finally figured out that I turned off the Trusted Platform Module (TPM) in the UEFI when desperately trying to get the Laptop to boot.
This was fixed by simply reenabling it. after I rebuilt the keyring about 5 times for nothing

Now I can start to fix the other errors like sound and backlight but tips are always welcome!

Thank you so much for helping.
I am very sorry for not providing reliable and comprehensive information about the current situation.

Yes sorry a typo but grub actually was not the problem

This workaround is presented in the Super Grub Restore Tutorial

AFAIK video-linux includes "video-intel" driver.
Fixing backlight may just need some kernel parameter. Check options here.

There are a few relevant topics in the forum. It's worth having a look.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by