Grub Installation with Legacy MBR and GPT Partition Table on Hackintosh

Dears,
Today I have installed on my laptop Manjaro but the installation of boot loader failed.
After the first reboot, start the PXE boot cause the boot loader isn't installed correctly.

On my laptop I have 3 OS: Linux, Windows and OSX; with a legacy MBR / GPT partition table.

Here the disk partitions:

[4540s ~]# fdisk -l
Disk /dev/sda: 465,78 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Hitachi HTS54505
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 86DAC89C-584F-4DC2-B723-E69600624999

Dispositivo     Start      Fine   Settori   Size Tipo
/dev/sda1          40    409639    409600   200M EFI System
/dev/sda2      409640 293378383 292968744 139,7G Apple HFS/HFS+
/dev/sda3   586610688 848328703 261718016 124,8G Linux filesystem
/dev/sda5   293640528 586609271 292968744 139,7G Microsoft basic data
/dev/sda7   880102304 976510983  96408680    46G Apple HFS/HFS+

Here the partition table GPT:

[4540s ~]# gdisk -l /dev/sda
GPT fdisk (gdisk) version 1.0.4

Partition table scan:
  MBR: hybrid
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with hybrid MBR; using GPT.
Disk /dev/sda: 976773168 sectors, 465.8 GiB
Model: Hitachi HTS54505
Sector size (logical/physical): 512/4096 bytes
Disk identifier (GUID): 86DAC89C-584F-4DC2-B723-E69600624999
Partition table holds up to 128 entries
Main partition table begins at sector 2 and ends at sector 33
First usable sector is 34, last usable sector is 976773134
Partitions will be aligned on 8-sector boundaries
Total free space is 32299317 sectors (15.4 GiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1              40          409639   200.0 MiB   EF00  EFI System
   2          409640       293378383   139.7 GiB   AF00  Apple HFS/HFS+
   3       586610688       848328703   124.8 GiB   8300  
   5       293640528       586609271   139.7 GiB   0700  Microsoft basic data
   7       880102304       976510983   46.0 GiB    AF00  Apple HFS/HFS+

Here the MBR data:

Disk size is 976773168 sectors (465.8 GiB)
MBR disk identifier: 0x00000000
MBR partitions:

Number  Boot  Start Sector   End Sector   Status      Code
   1                     1    586610687   primary     0xEE
   2      *      586610688    848328703   primary     0x83

To load Manjaro I have modified the MBR with gdisk, making the MBR hybrid with the boot on partition 3, now the error on startup is changed and I see the grub rescue.

With grub rescue I have load manually the grub configuration.

There is a way to install grub with legacy GPT (I have tried to install grub with grub-install but without success)? Or I have to use Chamaleon / Clover?

Thanks in advance for your support.

Why so complicated? Why do you need MBR Legacy?

Thanks for the reply!

It's one pre-requirements for the hackintosh installation.

Here an extract of the documentation:

Also for 4x40s series, be sure legacy boot is enabled. There are 2 places to look for Legacy: Enable legacy boot in "Device Configurations" AND in "Boot Options" set "Legacy" or "UEFI Hybrid (With CSM)".

I have followed this guide some years ago:

you either have mbr which is legacy or you have gpt for you boot driove, NOT both. now if i remember correctly you can have a gpt boot drive and mbr secondary drives if your motherboard supports both.

I suspect you should read this:

https://wiki.archlinux.org/index.php/GRUB#GUID_Partition_Table_(GPT)_specific_instructions

I believe Calamares supports this "BIOS with GPT" setup and will prompt for a bios-grub partition.

Also keep in mind that your "Hackintosh" setup is highly non-standard and so you will run into issues which noone here will be able to help with. You'll be better off on a "Hackintosh" forum as they deal with this type of hardware on a daily basis.

1 Like

Yes I know, can't have both. But to make osx running I had a hybrid partition table.

To solve similar problem in the past I have used gptsync, I have tried to install from from aur but some packages are missing and can't compile.

Some suggestions to solve the problem?

Ok thanks I will open an other tread in a hackintosh forum.

i really don't know where you get your info from I run hackintosh and use GPD partition table and why use Mountain lion its old very old.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by