GRUB Issue -- Unknown Filesystem

When my PC boots into GRUB, I get the following error --


error: unknown filesystem.
Entering rescue mode...
grub rescue>


the command ls outputs (hd0) (hd0,gpt5) (hd0,gpt4) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1) (cd0), with gpt4 containing /boot.
Following this guide(update 3), I get back to my usual Grub screen, and then can boot into Manjaro or Windows 10(dual-boot), but if I reboot, I end up back on the original error message.

I've tried reinstalling GRUB via the Software Manager on GNOME Manjaro and then running sudo update-grub, but with no avail, bringing me yet still back to the original error message.

This also appears to have happened after moving some partitions and installing Windows 10(appears to be a result of the partition movement though).


If anyone's got anything, please let me know.

Also please don't lecture me about moving partitions, I understood the risk, and it was necessary to make Windows 10 at least somewhat snappy on my hard drive. Please just let me know if you know how to fix this.

My situation yesterday has many similarities. Perhaps my intermediate solution may help. I run a dual boot (Win10 + Linux) box. I installed Manjaro into a partition formerly occupied by Linux Mint. The installer didn't seem to offer a dual boot option, which worried me.

Booting after that lead to the "grub rescue" prompt, which I was unable to benefit from.

I turned to a Super Grub2 Hybrid disk I'd burned a week ago. One of the boot options offered was a direct boot to Manjaro. I took that and it's been smooth sailing since - boot always goes directly to Majaro, and at present this meets my needs.

I still want to see grub at boot time however and have the Win10 option, along with the others I'm accustomed to seeing Linux Mint, so when I have a free moment I'll return to the Super Grub2 disk and see if can take another path and achieve this.

Yay! Got it all worked out --

After following the directions here and then rebooting, GRUB would then end up booting into the command prompt.
After that, following the directions here got it all to work! ...

except for that GRUB now says Welcome to GRUB! on boot and gives an error for hibernation if I don't hibernate before shutdown(didn't say anything of the sort before all of this). Manjaro also is showing some commands at boot before going to the login screen, which also didn't appear before all of this happening. Not sure what to do about that stuff(anyone got anything that might work?)...

Should I just reinstall the Manjaro-branded GRUB?

or will that bring all my issues back again?

grub-vanilla is supported and gets updated. No need to change your current configuraion.

On the other hand if you get the same issues you can try the same solution again.

Hibernation isn't working with the vanilla grub. Should I reinstall the Manjaro Grub then?

also, if I do install Manjaro Grub, would I just do this? --

(via Add/Remove Software)
uninstall grub-vanilla
install grub
run sudo update-grub

You can try to fix hibernation. Maybe it's just a matter of missing kernel parameter and easily fixed.

What's you current configuration? Do you have /boot/grub/custom.cfg ? If yes, what is in it?

I have a grub.cfg file, but not a custom.cfg file. Would it be best to just reinstall Manjaro GRUB? As before, the issues appeared after partition movement and installing Windows 10, and I'm thinking it might be one of those. I just want to see if there was a reason you or anyone else would advise against that.

Hey, I just went ahead and uninstalled grub-vanilla and installed grub, followed by running sudo update-grub, and all issues are gone except for that hibernation error. Hibernation seems to not want to work even if I do hibernate as well now.

One last thing --

In Add/Remove Software, an item called Hibernate[desc. hibernate the machine] isn't installed. Is this neccesary for hibernation? If so, why would it have been uninstalled?

Looks like it was a missing kernel parameter. Running hibernate from the manjaro repos seemed to fix the issue. I have another issue, but I'll see what I can find or ultimately just start a new post for any more issues.

Hello Dude,I have got this error many times (not on manjaro though) due to my own foolish actions . Here's the thing when you enter manjaro hit the terminal and type in
"sudo grub-install /dev/sdx" (x is just an example mostly it is /dev/sda) and run "sudo update-grub" that's all

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by