Grub legacy

The $esp partition - mounted in /boot/efi must be a separate 300MiB partition formatted with either FAT16 or FAT32.

I think it complains as you probably has the efi partition as part of the ext2 boot partition.

No, fhdk, system is bios-legacy. There is no $esp partition for it.
And grub-legacy can only work in bios-legacy systems.
Error 15 means file not found, usually it means it cannot find the menu.lst.

Oh - thank you for enlightening me :slight_smile:

1 Like

Well that didn't take long!
I replaced sda with a new disc, both sda and sdb are Sata.
I now can't even install Mepis or Manjaro without getting this:

Error: file not found
Entering rescue mode...
grub rescue>

Start now with

It's easier than it looks.


This is a totally different issue.
If you really want help, please, start a new topic.

You can't even boot up to the install cd (usb)?
Read up the wiki on how to make a install usb.
Manjaro cannot use unetbootin or if rufus need to use 'dd' not 'iso'. You can try etcher.
Best to use 'dd' command in linux.
And there are several topics on this. Search the forum.

And yes, petsam is right. .
Start a new topic for it if you still need help.

Now, remember to prep your new disk. As follows.

Use gparted to set up partitioning.
Device tab --> Create Partition Table --> msdos
Note all data in it will be erased.
Create partitions. no need /boot partition, just root (/) and swap.

1 Like

The install cd boots up fine and I put the partitions in ok.
I tried the Mepis one first and the Grub Loading message as posted above appeared.
Where does that come from since I have never seen it before and the old Mepis uses grub-legacy only as far as I know?
I then tried Manjaro and got the same message (I presume this is normal for grub 2) but why am I now getting the same thing with Mepis? What has changed?
Can I use the grub rescue> to set up for grub-legacy (Mepis only)?

And I assume both OS's installs fine, except they do not boot and both boot to the grub rescue prompt. And both are in bios-legacy and in different msdos disks. If wrong, correct us now. If correct, take a look at the first post here first.

If at step 4, if

grub> configfile /boot/grub/grub.cfg

does not get you to installed manjaro's grub menu, don't worry, do this [step4 change] listed below and boot up to manjaro.

Now after booting up to Manjaro, at step 6. do grub-install to both internal disks. Check with one (do more if still unsure) of the following to identify which are the internal disks. You have an external usb plugged in. But will assume them to be sda and sdb (not sdc).

lsblk -f
sudo parted -l
sudo fdisk -l
sudo blkid

So do

sudo grub-install /dev/sda
sudo grub-install /dev/sdb
sudo update-grub

If still unsure about sda, sdb and sdc, Do all, meaning do also "sudo grub-install /dev/sdc" as well.
And if you still have problems, as per the link, provide the output required.

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

And explain sda3 is manjaro root
sdb2 is mepis root
sdb4 is data partition...

Good luck.


[step4 change] if necessary

  • if "configfile /boot/grub/grub.cfg" does not get you to grub menu.
grub> search.file /etc/manjaro-release

Any output? If yes, continue, note this is another command different from above, you must do it.

grub> search.file /etc/manjaro-release root
grub> ls ($root)/boot/

copy down the kernels and initrd files listed.
I am taking 'vmlinuz-4.14-x86_64' and 'initramfs-4.14-x86_64.img' below. Change to your kernels if different.

grub> probe -u $root --set=abc
grub> linux /boot/vmlinuz-4.14-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.14-x86_64.img
grub> boot

That should boot Manjaro installed OS.

At the moment only Manjaro is installed on sda and is not grub legacy. I gave up on Mepis.
Yes this boots to the rescue prompt.

Then, have you used the provided advice to boot to Manjaro?
If not, do it and provide info as requested, please, so we help you fix booting.

Seems to be successful. I can boot Manjaro now but nothing else.
A message told me that in sda partitions do not start on physical sector boundaries.

What else is expected? :exploding_head:

1 Like

All of the distros on sdb

sudo update-grub

Sorry gohlip,been away.
Also apologise for not knowing anything about grub2.

Does this mean in a terminal?

Yes in terminal. :wink:

Ok, all seems to be well now.
One last question and I hope to be out of your hair: when installing a new distro I install grub to root and then go back to Manjaro and do sudo update-grub, correct?

In a previous post you were a little derisive of the British presence in India. Far be it from me to defend colonialism but it wasn't all bad...
They got rid of Thuggee (worshippers of Kali who befriended travellers and then garrotted them), Suttee (widow burning), created what at that time was the biggest railway system in the world, set up schools (girls too) and established a pretty good university system and hospital system.
The creation of east and west Pakistan, meant to solve the muslim-hindu incompatabilty was an unmitigated disaster with a million deaths,however.
I travelled to India and loved it!


That's a short step away from saying slavery is good because their descendants have a 'better life' (defined solely by gdp). There's now 'friendly colonialism' just as there are friendly fascism .

Here's a read that you might be interested in.

Take care.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by