Grub lists "phantom" Mac OS X entry after update [SOLVED]


Yesterday, Windows 10 on my dual-boot Manjaro/Windows laptop forced an update on me that broke Grub. I followed the [Simple Configfile Method] on this thread, which worked wonderfully. However, my GRUB menu now contains not only entries for my Windows and Manjaro partitions respectively, but also for Mac OS X, which seems very strange, since I am using a ThinkPad T440S which has, as far as I am aware, never even come to close to having an OS X operating system installed on it. The entries were not there before repairing Grub either. Please find a picture attached from Grub Customizer (since I can't screenshot the actual Grub menu before booting). Any ideas on how these entries have made their way into my Grub menu will be greatly appreciated. Many thanks.



Not sure why you mentioned it ... Are you using it?
You should have payed attention to the links in the topic you mentioned, that leads to this one

As I said, I provided a screenshot from Grub Customiser to illustrate my problemm because I thought it would be helpful for anyone wanting to look into it. As far as I am aware, I can't take a screenshot from within Grub itself, unless, of course, I photograph my monitor? Would that be better??

Anyway, my problem is not that Grub will not load anymoree, but that two new entries have been added for Mac OS X, despite the fact that there is not Mac OS X on the computer. The links in the topic you cite describe how to fix Grub, which I have already done.

I keep listening to Linux podcasts about how important it is to meet noobs with an open attitude and not be dismissive of "stupid" questions, yet the first person to offer me help is someone telling me off for not having "paid attention". The irony! Usually, I don't post my questions in forums, because I manage to find the correct solution by reading old threads. I take care not to be a "vampire", as it's so cleverly expressed. This one time I decided to reach out, and this is what I get. Fantastic. Please don't put any more effort into helping me out, if it's beneath you.

Those in this forum that engage in helping others, do not chase the issues trough something they do not recommend. The link you mentioned clearly specifies that grub-customizer needs to be removed, then on the link i provided mentions how to fix the entry for dual boot with Windows.
My question was quite specific:
Are you using grub-customizer?
If you try to be the one that conducts the way and path of what i have to follow to deal with issues, then you can simply ignore my comment and wait till somebody else will do what you want them to do, and provide you the answer you expect as being useful.

I keep telling newbies to be specific to what specific means, for their specific issue.

Indeed, now you lecture me.

Right. And that by your standard is unthinkable and unacceptable from a community member ... I didn't know you decide the standards. Keep on doing what you do then!

Grub does not add random operating systems to grub.

Yes, that is what is so strange about it. I have never attempted to install Mac OS X on the partitions it's listed on. How can it be that Mac OS X has been added to the menu seemingly randomly? Again, if it was unclear in my first post, I have not used Grub Customiser to fix Grub. I followed the instructions under [Simple Configfile Method] on this thread ā€“ Grub now works, and I can boot into both Windows and Manjaro. The screenshot from Grub Customiser was just to show that the menu entries are there suddenly. Rather than providing a photo of my Grub menu, I decided to show that the same entries are detected by Grub Customiser as well, though I have in no other way used it to customise Grub.

The appearance of a macOS entry may be due to a sample file you have loaded using grub-customizer.

I really don't know - as I said - grub does not add random entries - they must be defined somewhere

Please check the file /etc/grub.d/40_custom if you should have some undesired content.

After you have verified the file is almost empty - update your grub

sudo update-grub

Also - if a file /boot/grub/custom.cfg should be present - verify if it is needed - it is loaded automatically - and unless specifically needed you can remove it.


That is why i asked :slight_smile:

Excellent. The link i provided mentions exactly the proper

To fix the dual boot with Windows, so i implied to check that.
Now, if my remark

Offended you then i'm really sorry ... but i will not apologize.

It's quite alright. I admit I overreacted. I guess I was a bit offended, because ever since I started using Linux, I have taken some pride in not being a vampire, and I usually do the research myself, trying to figure stuff out by using already provided solutions ā€“ and, usually, I always find the solution I need. That's what I love about using Linux, the fact that I have to tinker with it a bit. Today, I could not find the solution I was looking for, not even another thread about the same issue, so I decided to create a community user and ask a direct question. So, I will apologies for being a bit edgy. Thanks to both of you for providing some concrete guidance. I will try it out, and report back if I have any success.

1 Like

As this looks to be a UEFI system, in order to avoid any damage to be done to Grub after an update to Windows, you could create a new ESP for Manjaro and install Grub in there and modify /etc/fstab accordingly.

1 Like

Please, please you don't have to apologize either - i have no intention to offend anyone in this forum. Is not why i'm here. I perfectly understand you, and that is why i prefer to clarify things from the start to finish. I hope you solve the issue and things will go smooth from now on, and any time you will have an issue i'm 100% sure someone will be here to support you :slight_smile:
Cheers and welcome to Manjaro!

1 Like

Manjaro has exceeded my expectations already, and if it wasn't for one single work related application in Windows that has no viable open source alternative, I would do away with Windows immediately and not have to worry about dual booting. Thanks again!

Thank you for this. What I should have mentioned in my original post, which I did not, and I apologize for not having done so (speaking of specificity ...), is that I used Super Grub2 Disk to load grub, not the Manjaro livecd, because I didn't think it would matter per the instructions here (see highlighted text):
Based on your suggestion, I booted into the Manjaro livecd instead, and followed the instructions here to repair the bootloader. Now when grub is loaded, there are no extra entries for a non-existing Mac OS X. So could it be that because I used Super Grub2 Disk, somehow the extra entries for Max OS X were added? Either case, the issue is now solved, and I appreciate the quick response from all of you.

1 Like

I am afraid I cannot answer your question. Perhaps someone more familiar with ins and outs of Super Grub2 Disk will know something about it. Anyways I am gald that you finally could restore Grub and your system is up and running as it should.

1 Like

Yes it's probably specific to Super Grub2 Disk. Next time Windows decides to overwrite the bootloader, I'll make sure to use the Manjaro livecd from the beginning. All the best!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by