GRUB not showing up on UEFI pc

Hi all,

I have an Asus ROG GL502V and I have just installed Manjaro KDE in dual boot without any apparent issue, however when I started the machine the GRUB didn't show up and it just booted Windows 10.
Here's what I have done so far:

  • Disabled secure boot
  • Created a partition via windows
  • Created a live USB image of Manjaro KDE with Rufus on Windows 10, using the DD option
  • Started Manjaro KDE via USB, and started the calamare installation after a quick test of the desktop environment
  • In the partition options, I have created one partition for the OS (no swap and home, just all in one) in the root with ext4 file system
  • I then edited the /dev/sda1 partition with the boot loader by clicking on edit and setting the mount point to /boot/efi. Please note this is shown as a 260Mb "EFI System Partition" in windows with a fat32 file system so it should be good to host the GRUB?
  • I then concluded the installation process without issues

The only issue is that the GRUB is not there when I start the pc. It just boots windows 10!!
Can anyone help me please! I'm freaking out.
I checked the forum and there is a similar topic with a guy that solved the issue by enabling "launch PXE OProm" in the BIOS, but it's not working for me..

EDIT I’m reinstalling and in the installation summary it doesn’t say “install boot loader on /dev/sda1” what am I missing?
I have attached a screenshot of the summary

Thanks in advance


Because it doesn't do that on EFI systems. If after installation you can't find Manjaro from UEFI available list, follow this guide to repair it. Normally it should work fine, else it may be a bug to be reported at Calamares and/or Manjaro devs.

Thanks @AgentS
I booted the USB image that I have used for the install and noticed an option “detect EFI Bootloaders”. By selecting it, I am now able to load grub and get to choose between Manjaro and windows 10.

Once Manjaro is loaded, I have followed the instruction of the guide you linked (screenshot below).
Everything seemed fine but after reloading it still goes straight to windows 10 without grub.
The only way to load grub is by booting via the USB and select “detect efi bootloaders”.

Have I done something wrong?

At manjaro terminal, provide output of

sudo parted -l
sudo blkid
findmnt -s
efibootmgr -v

Hi @gohlip thanks for asking. See below

Model: ATA SanDisk SD8SNAT1 (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  274MB  273MB   fat32        EFI system partition          boot, esp
 2      274MB   290MB  16.8MB               Microsoft reserved partition  msftres
 3      290MB   101GB  101GB   ntfs         Basic data partition          msftdata
 5      101GB   128GB  26.2GB
 4      128GB   128GB  523MB   ntfs         Basic data partition          hidden, diag

Model: ATA HGST HTS721010A9 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  1000GB  1000GB  ntfs         Basic data partition  msftdata

Model: TOSHIBA TransMemory (scsi)
Disk /dev/sdc: 7750MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  2049MB  2049MB  primary               boot
 2      2049MB  2054MB  4194kB  primary               esp

/dev/sdb1: LABEL="DATA" UUID="DEBC328DBC326067" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="0e4542e7-dcd6-4d26-a8a6-8fead0a0b012"
/dev/sda1: LABEL="SYSTEM" UUID="D8F5-A16E" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="93991012-4175-426e-83e0-d5b1a4cc66ba"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="71c67f13-e035-4c56-aecc-68de825f5a51"
/dev/sda3: LABEL="OS" UUID="6A1EFC601EFC26AB" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="9c976914-050d-4afb-b894-30a2cd931d2f"
/dev/sda4: LABEL="RECOVERY" UUID="D80E30E60E30BEF6" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="99fe2fa9-b056-4666-acc8-cc748eeb147d"
/dev/sda5: UUID="faacbd7b-76ff-4bf5-aa2b-3967813e999c" TYPE="crypto_LUKS" PARTUUID="dcbc401e-e68c-4f6e-ab11-60976802588e"
/dev/sdc1: UUID="2018-03-27-19-11-24-00" LABEL="MJRO1717" TYPE="iso9660" PARTUUID="c706b9ca-01"
/dev/sdc2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="5C2A-FAE6" TYPE="vfat" PARTUUID="c706b9ca-02"
/dev/mapper/luks-faacbd7b-76ff-4bf5-aa2b-3967813e999c: UUID="b27bd0a1-ca5d-4cac-b71f-d5a4b53256d1" TYPE="ext4"

TARGET    SOURCE                                                FSTYPE OPTIONS
/boot/efi UUID=D8F5-A16E                                        vfat   defaults,noatime
/         /dev/mapper/luks-faacbd7b-76ff-4bf5-aa2b-3967813e999c ext4   defaults,noatime,discard
/tmp      tmpfs                                                 tmpfs  defaults,noatime,mode=1777

BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0000,0003,0001,0002
Boot0000* Windows Boot Manager  HD(1,GPT,93991012-4175-426e-83e0-d5b1a4cc66ba,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0001* Hard Drive    BBS(HD,,0x0)..GO..NO........o.S.a.n.D.i.s.k. .S.D.8.S.N.A.T.1.2.8.G.>..Gd-.;.A..MQ..L. . . . . . . . ........BO..NO........o.H.G.S.T. .H.T.S.>..Gd-.;.A..MQ..L. . . . . . .R.J.■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■■
Boot0002* Network Card  BBS(Network,,0x0)..GO..NO........k.R.e.a.l.t.e.k. .P.X.E. .B.0.3. .D.0.0.........................rN.D+..,.\...........<..Gd-.;.A..MQ..L.R.e.a.l.t.e.k. .P.X.E. .B.0.3. .D.0.0........BO
Boot0003* UEFI: TOSHIBA, Partition 2    PciRoot(0x0)/Pci(0x14,0x0)/USB(5,0)/HD(2,MBR,0xc706b9ca,0x3d1324,0x2000)..BO

You provided only 'sudo parted -l'.
Need the rest.
ehm... Manjaro in sda5? No filesystem?

ps: are you the same nedkelly ?
if yes, why new username?

Sorry @gohlip I have edited the post now it's correct.
Yes, Manjaro is in sda5. As for the filesystem, during the install I have chosen ext4 and encrypted so it should be LUKS. Not sure why it's not showing anything in the report.

No I have never posted here. Ned Kelly is a pretty popular nickname, especially in Australia :smiley:


Right. Got the rest.

o Your efibootmgr does not list manjaro. That's bad.
o We'll try to see if we can make it into the efibootmgr first.
o That may still fail (because of your firmware) and then we may do something more drastic.

So the first part....
Boot up Manjaro (any way , your current way is fine, I have my simpler way, the link that petsam provided, but never mind whichever way you choose), and at terminal, first verify that the manjaro disk is really sda (partition as /dev/sda5) using one of
findmnt /
lsblk -f
sudo blkid
sudo parted -l

If verified that it is indeed sda (partition /dev/sda5), continue..

sudo grub-install
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
sudo update-grub

Now, (and this is importsnt), verify that manjaro is listed in efibootmgr command


Now reboot.

If this does not reboot to manjaro grub menu, boot up manjaro (any way)
and confirm that manjaro is again missing in 'efibootmgr' command.
Then we can propose the 'drastic' method to be followed in the next post.

ps: noted the clarification of common Ozzie names. :grin:
it is very late now for you (except if you are in Perth)


Here's the 'drastic' second method. if the above fails.

Follow this (of course change the UUID listed in custom.cfg to your sda1 ($esp)).
And with benefit of hindsight from that link, just continue to do the custom.cfg when you reboot (no need to reboot again to check if windows is included in grub.cfg). If unsure, ask for clarification and wait for my response. Again, if you do not wish to do this 'drastic' method, I understand, but let us know.

ps: It's late here too (I think Adelaide time).
ps: the 'first' NedKelly here also has a Asus ROK

1 Like

What if he used

efibootmgr -t 8


That's the timeout. If the first entry in bootorder does not work, it goes to the second and so on after the set timeout. Without setting it, there is also a default timeout and it behaves the same way.

The problem is not the timeout because there is just no 'manjaro' bootentry to timeout to.
There is no 'manjaro' bootentry in efibootmgr.

Thanks @gohlip that solved the problem entirely! Cheers :smiley:

1 Like

Welcome, but which one? The first 'correct' method or the second 'drastic' method?

The first method fortunately

1 Like

Have you tried to access boot-list via keyboard before windows starts? On my pc is F8 but its often some other key.Personally I have manjaro without efi, just /boot with bootable flag on fat32 and it works fine.

Other thing that comes to my mind is that your primary disk could be not the sda, so your windows bootloader may be set on the other drive, and you would need to check up boot sequence in bios if its true.


And you have a bios-legacy system, not uefi.

Strongly suggest a /boot partition (flagged or not) not be on fat32 but on ext2 (ext4 is ok).
It may be fine now, won't be in future .
Preferably, do not have any /boot partition.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by