GRUB not showing

I Installed Windows 10 with all default settings (I dont know anything about Windows) onto SSD #1 and Installed Manjaro onto SSD #2 with a /boot/efi partition (boot flags boot and esp) and a default root partition (/). When I boot from either drive I don't get a choice of what OS to boot from. No boot loader and no grub. I tried a few fixes that I googled like this one but it doesn't do anything as far as I can tell. I tried both os-prober and update-grub with no cure. I found another topic similar to this (actually a couple but got stuck both times).

This is my first go at Manjaro however but I am a 5 year user of Linux (From Mint/Debian)

[gregory@PearOS ~]$ sudo parted -l
[sudo] password for gregory: 
Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 1      1049kB  525MB   524MB  primary  ntfs         boot
 2      525MB   1000GB  999GB  primary  ntfs
 3      1000GB  1000GB  547MB  primary  ntfs


Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sdb: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 2      17.4kB  2149MB  2149MB  fat32              msftdata
 1      2149MB  250GB   248GB   ext4


Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sdc: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start  End  Size  File system  Name  Flags

[gregory@PearOS ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
[sudo] password for gregory: 
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

Help to get grub on the manjaro /boot/efi partition (and grub to show back up) would be greatly appreciated.

cat /etc/default/grub

..but my guess would be you just need to hit shift or esc to see it.

Ok so here is the output.

[gregory@PearOS ~]$ cat /etc/default/grub
GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
[gregory@PearOS ~]$ 

When I boot to grub and select Manjaro by using shift I am able to select Manjaro but it goes to a black screen (no boot after it is selected).

I tried this too.

[gregory@PearOS ~]$ sudo os-prober ntfs-3g
[sudo] password for gregory: 
[gregory@PearOS ~]$ sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
[gregory@PearOS ~]$

I am not sure how to go about checking/solving that. I am using a GTX1070 and this is what it shows for drivers

[gregory@PearOS Desktop]$ screenfetch

 ██████████████████  ████████     gregory@PearOS
 ██████████████████  ████████     OS: Manjaro 18.1.4 Juhraya
 ██████████████████  ████████     Kernel: x86_64 Linux 5.4.2-1-MANJARO
 ██████████████████  ████████     Uptime: 18m
 ████████            ████████     Packages: 1068
 ████████  ████████  ████████     Shell: bash 5.0.11
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: GNOME 3.34.2
 ████████  ████████  ████████     WM: Mutter
 ████████  ████████  ████████     WM Theme: macOS Dark
 ████████  ████████  ████████     GTK Theme: macOS Dark [GTK2/3]
 ████████  ████████  ████████     Icon Theme: macOS Night Mode
 ████████  ████████  ████████     Font: Noto Sans 11
 ████████  ████████  ████████     Disk: 6.9G / 237G (4%)
                                  CPU: Intel Core i7-3820 @ 8x 3.6GHz [36.0°C]
                                  GPU: NV134
                                  RAM: 1910MiB / 15934MiB

[gregory@PearOS ~]$ glxinfo | grep OpenGL
OpenGL vendor string: nouveau
OpenGL renderer string: NV134
OpenGL core profile version string: 4.3 (Core Profile) Mesa 19.2.7
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.3 (Compatibility Profile) Mesa 19.2.7
OpenGL shading language version string: 4.30
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.2.7
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
[gregory@PearOS ~]$ 

~ >>> glxinfo | grep OpenGL                                                                                                      [3]
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 1060 6GB/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 435.21
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 435.21
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 435.21
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

You must install 'non-free' = Nvidia driver.

OK. How do I go about installing non-free drivers?

https://wiki.manjaro.org/index.php?title=Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup

2 Likes

That fixed booting into Manjaro!!! Now its just getting Windows to show up in Grub so I can dual boot. I tried running os-prober then grub-update again with no success.

https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

I will give it a wack and report back.
:grin:

Thank you

1 Like

welcome-01-sgs :wink:

1 Like

From the output of sudo parted -l , it looks as if you have Windows installed in legacy/mbr mode and Manjaro in UEFI ( that is if

 Number  Start   End     Size    File system  Name  Flags
 2      17.4kB  2149MB  2149MB  fat32 msftdata.

is an EFI system partition where you have installed Manjaro's Grub)

Thats why os-prober doesn't pick up your Windows. You would need to install both operating systems in the same mode.

2 Likes

Is there any way to convert one or the other? I am okay with reinstalling Manjaro since its fresh but not Windows.

I would think the easiest way would be to re-install Manjaro in legacy mode. You would need to boot up your live usb in legacy mode for that. The option in the bios boot menu will be the one with the name of the vendor without UEFI in front of it.

You would need to create a new partition table: msdos (use Gparted for that; OBS. this will erase your disk, so make sure that you pick up the correct disk in the drop-down menu at the top right of the gparted's window and to backup any data you might already have on you Manjaro install)

2019-12-17_18-20

Then you don't need an EFI partition. You just install the bootloader onto the drive which in this case would be /dev/sdb.

Okay. So when I get to the partition menu I do the following.

Drive #1:
ext2 - 2gb - /boot - flag: legacy-boot
ext4 - 100gb - / - no flags
ext4 - 148gb - /home - no flags

and drive 2 remains untouched since it has the Windows install.

Very much appreciate the help and I think this will finally sort everything out!
I like to change Grub to make it look less bad after an install will this still be possible?

Drive #1? You mean /dev/sdb? That's where Manjaro is installed currently. At any rate, please make sure to pick up the right disk.

You won't need a separate partition /boot unless you want to encrypt your system. My suggestion would be to do without if you don't have to.
Make one ext4 for /. Anything between 30-50 GB is more than enough. You could flag it boot.
Another one ext4 for /home of the size of your choice.
Possibly one for swap the size of your RAM if you plan on hibernating.

You could do all of this from gparted prior to launching the installer. Then you point the installer to the already created partitions.

Make sure you create a msdos partiton table for the legacy mode installation first.
And remeber to install Grub onto the drive (in this case /dev/sdb) and not in a particular partition.

I think this would be the subject for another thread.

Good luck wit the installation!

1 Like

So, the "Grub not showing" was solved.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by