GRUB now not loading. Reinstall produces /proc/devices issue

Hello forum,
I had a scan through the forum, but still at a loss.

My laptop used to work fine. Windows has it's own partition, and Manjaro's root was installed on another with the bootloader (dev/sda8). Everything was fine, but now on boot, the screen is black with only the word 'GRUB' on it.

I've tried mounting:
/dev/sda8 /mnt
/dev/sda8 /mnt/boot
/dev/sda8 /mnt/proc
/dev/sda8 /mnt/boot
sudo mount --bind /dev /mnt/dev

and then chroot /mnt to reinstall GRUB with sudo , but there are errors:
/proc/devices: fopen failed. No such file or directory, and then errors about the partition not having a BIOS boot partition, embedding is not possible, and it will not proceed with blocklists.

The laptop has legacy options on, and it worked for weeks, until today. I even ran a full reinstall with format options on dev/sda8, still the same problem.

I followed this post Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader, and wen it booted there was a message about grbnv missing, but I checked in the grub folder and it is there, but it only has

GRUB Environment Block


could you return

sudo fdisk -l

you have to re-install grub
be careful , if you have /boot/efi --> restore grub with efi
else restore grub

use your USB key
in terminal

manjaro-chroot -a

check if /boot/efi is ok ( good dev/sd* not the USB key )

for Bios only

grub-install /dev/sd* 

for EFI

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck /dev/sd*

you must have no errors with EFI

to leave chroot , type exit and reboot

1 Like

Thank you for replying.

I've tried re-installing grub using USB live session and mounting dev/sda8 and chroot.
Since then, I've been able to boot into the system by using grub on the USB.

I'm now in the installed system, and waiting for the databases to update, which has also started downloading package updates. It could be a while. When it's done I'll reinstall grub while in the installed OS.

No good.

grub-install: warning: this GPT partition label contains no BIOS boot partition; embedding won't be possible.
grub-install: warning: embedding is not possible. GRUB can only be used in this setup using blocklists. However, blocklists are UNRELIABLE and their use is discouraged...
grub-install: warning: will not proceed with blocklists.

I really don't understand this because the bootloader is there, well, something is, and is accessible via GRUB on a live USB by pressing 'c' and using:

grub> search -f /boot/intel-ucode.img --set=root
grub> configfile /boot/grub/grub.cfg

no good Bios or EFI ?
could you return
sudo fdisk -l

It means you are attempting to install to GPT partitions in bios-legacy mode.
To do this you need to have a bios_grub partition and flagged as such.
I would suggest you install to GPT in UEFI mode and not in bios-legacy mode.
If you want to install in bios-legacy mode, make the disk msdos (2TG notwithstanding).

You have not replied stephane's "sudo fdisk -l".

1 Like

I'll get fdisk output soon.

Here's the fdisk output:

Disk /dev/loop0: 48.4 MiB, 50741248 bytes, 99104 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 237.1 MiB, 248639488 bytes, 485624 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop2: 824.8 MiB, 864829440 bytes, 1689120 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop3: 387.4 MiB, 406159360 bytes, 793280 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 1B393D4A-9D79-42BA-BE0B-4A0EBAB9DAAB

Device         Start       End   Sectors  Size Type
/dev/sda1       2048   1026047   1024000  500M EFI System
/dev/sda2    1026048   1107967     81920   40M unknown
/dev/sda3    1107968   1370111    262144  128M Microsoft reserved
/dev/sda4    1370112   2906111   1536000  750M Windows recovery environment
/dev/sda5    2906112 210541323 207635212   99G Microsoft basic data
/dev/sda6  210542592 211574783   1032192  504M Windows recovery environment
/dev/sda7  211576832 212621311   1044480  510M Windows recovery environment
/dev/sda8  212621312 417421311 204800000 97.7G Microsoft basic data
/dev/sda9  422336512 632051711 209715200  100G Microsoft basic data
/dev/sda10 632051712 959240191 327188480  156G Microsoft basic data
/dev/sda11 959242240 976771119  17528880  8.4G Windows recovery environment
/dev/sda12 417421312 422336511   4915200  2.4G Linux swap

Partition table entries are not in disk order.

dev/dsa8 is the Manjaro installation (/).

Here's lsblk -f output as well:
loop0 squashf /run/miso/sfs/li
loop1 squashf /run/miso/sfs/mh
loop2 squashf /run/miso/sfs/de
loop3 squashf /run/miso/sfs/ro
├─sda1 vfat ESP 625C-BEB1
├─sda2 vfat DIAGS C4B8-3EC0
├─sda5 ntfs OS 4408BE5108BE422A
├─sda6 ntfs 743E3F183E3ED2BA
├─sda7 ntfs 7A40B76D40B72F2F
├─sda8 ext4 Linux Root d5dd47a5-ca09-484e-b79f-1da32acd3978
├─sda9 ntfs 新加卷 123E618A3E6167A5
├─sda10 ntfs 新加卷 2E24655A246525D5
├─sda11 ntfs PBR Image 66DE43C1DE4387EF
└─sda12 swap bb66b9e7-89fa-40f6-9f85-6f298dd1cd9b [SWAP]

I sort of understand some of that, but when I originally installed Manjaro, I didn't need to create any boot partitions, and certainly not UEFI, which is something I try to stay away from, which resulted in a working system. I'm not sure what could have happened between switching off the computer and switching it on again to cause grub to fall apart like that. A reinstall of Manjaro didn't change anything regarding GRUB. I assume then that GRUB is not formatted during a reinstall with format options.

Based on your fdisk -l (finally), your disk is definitely gpt. Now we can get moving.

It appears your windows is also booted in UEFI; unless you're very sure it is not, let us know.
If windows is in UEFI, make sure your Manjaro is also in UEFI.

As to your last post, I really don't understand what you're saying. Unless your windows (update) messed up your manjaro bootloader.

Assuming the above, and you can boot up Manjaro...

Boot up Manjaro this way but make sure your livecd is started (not booted) in UEFI mode this time and using configfile method.

And at the booted Manjaro installed OS (not livecd), provide the following output.

cat /etc/fstab
sudo blkid
test -d /sys/firmware/efi && echo UEFI || echo BIOS

Oh.. please print out your input command as well as the output.. and use LANG=C so we all can understand (though I can understand your LANG) like this....

pop@pop:~$ LANG=C
pop@pop:~$ test -d /sys/frimware/efi && echo UEFI || echo BIOS
pop@pop:~$ test -d /sys/firmware/efi && echo UEFI || echo BIOS

1 Like

Thank you for all of the commands, I'll do that tomorrow.
When I originally installed Manjaro, I may have done so not in UEFI mode. During the process, I did not need to create any special UEFI boot partitions and flag them, only root and swap were created.

Windows probably is UEFI because I use BIOS boot options to switch between UEFI and Legacy depending on the system being used.

Yes, that's the likely explanation.

I would strongly suggest you (re)install Manjaro in UEFI, but if you want to continue with Manjaro in bios-legacy and Windows in UEFI, that's what you would need to do (switch to boot either OS); but system will not be reliable as is happening now. And you need a bios_grub partition which may confuse windows as well. Not a good setup.

1 Like

Thank you both for helping. I now know more about UEFI.

I will reinstall the system as it might be less problematic considering the state of the hard drive partitions. If my wife didn't need all that stuff, I'd wipe the whole lot and start from scratch, but she doesn't like me tinkering.

Thanks again.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by