Grub Problem: error device /dev/mapper/luks-03xxxxxx not found

Hi,
I made an update on my packages and somehow something went really bad.

After the upgrade, it was not starting with my normal Linux, it only showed this:

error file /boot/vmlinuz-5.4-x_86_64 not found
error you need to load the kernel first.

I was now going through this forum and repaired it with this tutorials:


I also had to delete and reinstall some stuff, now it works a little bit better.

but it can't mount now my encrypted root stuff.

error device /dev/mapper/luks-03xxxxxx not found
skipping fsck
mount /new_root no filesystem type specified

image

I found also reinstalled lvm2 like mentioned here but still the same problem.

I really hope, somebody can help me...

from a live iso it looks like this when i do a lsblk -f

sda                                                                         
└─sda1
     crypto 1           a03f75ee-2af7-40f4-bba5-5d9d241afc73                
  └─luks-a03f75ee-2af7-40f4-bba5-5d9d241afc73
     ext4   1.0         a9b268a6-f403-4113-80a7-67f9650fc376  107.3G    46% /run/media

So, I push now all the files, maybe this helps.

I'm really trying everything I have found in the forum, but not working so far.

here is my grub.cfg file, i hope this helps https://anonymousfiles.io/KHcuklIW/
(sorry could only upload it to this provider)

I know finally managed to see my grub, so I can now start my Grub with different configs:

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Manjaro Linux' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-a9b268a6-f403-4113-80a7-67f9650fc376' {
	savedefault
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod cryptodisk
	insmod luks
	insmod gcry_rijndael
	insmod gcry_rijndael
	insmod gcry_sha256
	insmod ext2
	cryptomount -u a03f75ee2af740f4bba55d9d241afc73
	set root='cryptouuid/a03f75ee2af740f4bba55d9d241afc73'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint='cryptouuid/a03f75ee2af740f4bba55d9d241afc73'  a9b268a6-f403-4113-80a7-67f9650fc376
	else
	  search --no-floppy --fs-uuid --set=root a9b268a6-f403-4113-80a7-67f9650fc376
	fi
	linux	/boot/vmlinuz-5.4-x86_64 root=UUID=a9b268a6-f403-4113-80a7-67f9650fc376 rw  quiet cryptdevice=UUID=a03f75ee-2af7-40f4-bba5-5d9d241afc73:luks-a03f75ee-2af7-40f4-bba5-5d9d241afc73 root=/dev/mapper/luks-a03f75ee-2af7-40f4-bba5-5d9d241afc73 resume=/dev/mapper/luks-a03f75ee-2af7-40f4-bba5-5d9d241afc73 apparmor=1 security=apparmor udev.log_priority=3
	initrd	/boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
}

I read in this REDDIT POST that I can add the right arguments to my startup.

for me the UUID, if it's still encrypted is, as written above: a03f75ee-2af7-40f4-bba5-5d9d241afc73 but if it's decrypt it's, also written as above: a9b268a6-f403-4113-80a7-67f9650fc376

I have no idea what to change, that it's working again

I fixed it.
after everything I have done, I used this https://unix.stackexchange.com/questions/42587/grub2-unable-to-boot-encrypted-root

change from:

HOOKS="base udev autodetect modconf block filesystems keyboard fsck"

to

HOOKS="base udev autodetect modconf block encrypt filesystems keyboard fsck"

after this use mkinitcpio -p linux

after this I reinstalled grub again, and somehow it works.
I have now to answer 2 times the password for decryption, but now it works.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by