Grub problems. [solved]


I installed Artix to see how it works and after uninstall this system the grub was gone ...

I tried to get the grub back by installing the Manjaro i have in a USB, with this command:

# grub-mkconfig -o /boot/grub.cfg

(from the terminal of the system in which i want to have the new grub).

-- then, after this, i go to gparted and remove the Manjaro/USB from the partition, but after reboot ... the grub is gone.

I don't know what is wrong, how can i recover the Grub now?.


Use search function upper right, "grub gohlip restore" :wink:

Have you considered using the wiki?

You need to Install Grub, not update-grub (what you did).

If you are on MBR/MSDOS type booting, just install grub at your drive.
If you are on UEFI, check current options in efibootmgr and re-order entries to have Manjaro 1st.

Check this tutorial for general help and if you have problems, post info (as advised in the tutorial).

sudo grub install /dev/sda

sudo update-grub

It works!

Thanks everybody for the links.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by