Grub rescue - no such device - unknown filesystem after install


I had:
1/ win10 64 bits installed on a laptop (partitioned as sda1(I believed win10, while I believe sda3 win10 recovery) and data on sda5, sda6, sda7)
2/ Manjaro 18 rc3 XFCE booted from an USB key
3/ an USB external drive where it had previously Manjaro 17.1.10 XFCE

Booting from the USB key, I installed Manjaro 18rc3 on what I believe the partition of Manjaro 17.1.10 (I presumed I failed and Grub installed on the internal HDD and not on the usb external one, but this is only an assumption)

Reboot and I swith to
Grub rescue
error: no such device : 5bc...
error: unkown file system

I tried How to Fix error: unknown filesystem grub rescue in Windows 7/8.1/10 (Advanced Tutorial)
But apparently, all ls (hd0,msdosX) leads to "Filesystem is unknown"
See picture

Rebooting from the usb key, I see with Thunar that my win10 partition is there with all its files, maybe, but I'm not sure the partition has change name to "TI30876100A"

How to fix so that:

  • my laptop starts with win10 (there is no manjaro install on the internal HDD)?
  • subsequently, starts Manjaro from the external USB hdd when I plug it?


Lol windows causes this to why windows do such thing I dont know I don't use windows .it may be windows formated ext4 partition to NTFS.or while upgrading windows u force shut down

Start here:

Gparted of the internal hdd, everything seems to be as before install on the external driveGparted%20internal%20HDD

According to me, because there is no Manjaro on the laptop, but only on the external usd hdd, the grub install should be removed from the laptop internal hdd and exists only on the external one.
Booting from the external hdd does not work, only booting from the usb key

"Old" laptop, normally no uefi on this one

If I connect the usb external hdd, at boot I have now as hd1 my internal hdd, while hd0 for the external one and:
ls (hd0,msdos1)
Filesystem is ext2

Should I
set boot=(hd0,msdos1)
set prefix=(hd0,msdos1)/boot/grub
insmod normal

But, then how will I boot win10 without plugging the external hdd?

If you installed grub on the internal drive, you can only boot to WinOS with some external media. You may boot to WinOS and repair bootloader, after unplugging externals, but I don't know how.

To avoid a mistake on grub installation, always verify the current drive name with lsblk or other, as the names may change during boot, when plug/unplugging external media.

Grub should allow you to chose whether you boot to windows or linux every time you reboot. Set your laptop to boot from the external HD.

This is not what OP wants to have.

Well, I tried to boot the laptop together with the external hdd.
Here is what I get:
grub rescue> ls (hd0,msdos1)
(hd0,msdos1): Filesystem is ext2.
grub rescue> set boot=(hd0,msdos1)
grub rescue> set prefix=(hd0,msdos1)/boot/grub
grub rescue> insmod normal
error: symbol 'grub_key_is_interrupt' not found
grub rescue>

Found also Grub_key_is_interrupt

Boot again Live media installer and install again to your external drive, while this time take care to choose the proper drive for grub installation.

Well, I tried to re-install both with rc3, then rc4.

No change at all, I must boot with the external usb hdd drive on (previously with Manjaro 17.1.x XFCE I hadn't this issue)
Don't know why either, the trash bin is on the internal drive on partition sda7 - I woud have suppose on the same partition as Manjaro (sdb1)
The only option, I see would be to install Manjaro in dual boot on the internal drive.
I saw
But very reluctant to try, if it does mess up

[tosh@tosh-pc ~]$ lsblk -f
├─sda1 ntfs System 34FE44C5FE4480DA
├─sda2 ntfs TI30876100A 01CD82D80B502140
├─sda4 ntfs HDDRECOVERY A006918E06916656
├─sda5 ntfs DOCS ECDCA490DCA4571C
├─sda6 ntfs MMedia 7A2EAC312EABE47B
└─sda7 ntfs OS_WORK 01D46EEFE282F7A0 /run/media/tosh/OS_WORK
├─sdb1 ext4 c68e5d42-98df-40d1-8708-ddd5e5cdb68a /
├─sdb2 ntfs P2_NTFS E0A6AA67A6AA3DC2
└─sdb5 vfat PETIT AF99-165E
[tosh@tosh-pc ~]$

Please format terminal output as code. It's unreadable.
Follow this to repair your bootloader.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by