Grub restore after hardware swap

Hi! Recently I had to swap some faulty hardware, namely the motherboard and the cpu. I was hoping everything was fine because the models are the same, but now I can't choose the Manjaro Grub in the bios...

I have tried different things already. "grub-mkconfig" and "grub-install" comes to my mind. I can actually access my Manjaro instalation via a Linux Mint grub, but it's not ideal because it only lets me boot in some secure modes (intrafall back on an old kernel or something like that), and Manjaro's grub always worked wonders for me. So I don't think I need to chroot via usb live boot.

Here is some info about the setup. Thanks in advance

inxi -Fxxxza

System:    Host: ___ Kernel: 4.14.151-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-4.14-x86_64 root=UUID=f999169f-bb21-4dfe-94d8-7f594cc40aa4 rw quiet 
           Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: B250M PRO-VD (MS-7A74) v: 1.0 serial: <filter> UEFI: American Megatrends v: 1.A0 
           date: 02/27/2018 
CPU:       Topology: Quad Core model: Intel Core i7-7700 bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: 9 microcode: 70 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 57616 
           Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 4: 800 5: 800 6: 800 7: 800 8: 800 
           Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5912 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           resolution: 1680x1050~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 19.2.2 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a2f0 
           Sound Server: ALSA v: k4.14.151-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8168 
           v: 8.047.04-NAPI port: e000 bus ID: 01:00.0 chip ID: 10ec:8168 
           IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 230.80 GiB used: 55.08 GiB (23.9%) 
           ID-1: /dev/sda vendor: Kingston model: SUV400S37240G size: 223.57 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 96R9 scheme: GPT 
           ID-2: /dev/sdb type: USB vendor: Toshiba model: TransMemory size: 7.23 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 1.00 scheme: MBR 
Partition: ID-1: / raw size: 71.22 GiB size: 69.60 GiB (97.73%) used: 55.04 GiB (79.1%) fs: ext4 dev: /dev/sda8 
           ID-2: swap-1 size: 712.0 MiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 198 Uptime: 9m Memory: 7.69 GiB used: 1.08 GiB (14.0%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           clang: 9.0.0 Shell: bash v: 5.0.11 running in: xfce4-terminal inxi: 3.0.36 

and fdisk, from where I need options to boot sda4, sda7 and sda8, but manjaro usually does that search automatically when installing grub

Device         Start       End   Sectors   Size Type
/dev/sda1       2048    923647    921600   450M Windows recovery environment
/dev/sda2     923648   1128447    204800   100M EFI System
/dev/sda3    1128448   1161215     32768    16M Microsoft reserved
/dev/sda4    1161216 247676927 246515712 117,6G Microsoft basic data
/dev/sda5  247676928 249135103   1458176   712M Linux swap
/dev/sda6  249135104 249329663    194560    95M BIOS boot
/dev/sda7  249329664 319506431  70176768  33,5G Linux filesystem
/dev/sda8  319506690 468860927 149354238  71,2G Linux filesystem

You should find out which partition is your $esp (sda2?) looking for a Manjaro folder.
Then use efibootmgr to create a new UEFI option for Manjaro and then update grub again.

Read more relevant info

Hello, thanks for the reply. I tried some steps I found on that thread but I constantly get this error message using the UEFI additional commands, even tho I'm pretty sure I'm booting in UEFI...

EFI variables are not supported on this system.

Also, I have efibootmgr installed. My motherboard is MSI but I can't find the "secureboot" or "TPM" options.
I even tried the part " If grub is really messed up" but didn't work at all.

If I run the command efivar-tester I also get this same message, could that be the problem?

We are pretty sure you're not.

As per the link, provide the information required if you still have problems.
Start up the install media in uefi. Verify that it is - that link has instructions to check that.
I wish that topic (link) is simpler. Maybe it should, considering people don't read it fully.

ps: it was simpler, before 'quiet-grub'.

Hey! Thanks for the help to both of you. I ended up installing Manjaro again because I realized it was the easy way out. Now the grub is fixed and I can boot in every OS.

Still I'm having another issue, the desktop manager is broken right after I install Manjaro, so when I choose Manjaro on the grub options the screen just turns off. I can use ctrl+alt+f2 to use the command startx to load it perfectly, booting directly into my user account.

I've tried following this thread but don't really get the point... I'll open a new topic if it's needed.


Yeah, open a new topic, please.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by