Grub screen completely black

My grub screen is completely black. I can't see anything at all, but the system beeps when I get to it. I can press enter to boot normally or just wait five seconds and it will boot normally by itself, but there is absolutely nothing on the screen at all. Not even the background.png.

Please help me fix this. Here is the content of my grub file located at /etc/default/grub:

GRUB_DEFAULT="Manjaro Linux"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel to use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
export GRUB_COLOR_NORMAL="yellow/black"
export GRUB_COLOR_HIGHLIGHT="brown/cyan"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

I've tried grub-customizer, which doesn't effect a change, and startupmanager, which won't start at all.

Thanks in advance.

What good timing. I just rewrote this topic as our grub evolved to include


in /etc/default/grub. The edit is to separate out this and you can use this to fix your grub.
See the "If grub is really messed up" section at the first post. Uninstall grub-customizer before doing the commands. Reminder you need to install grub package again.

Please do not install grub-customizer again, anywhere.


Okay. I'm reading it now. I almost had to reinstall everything. Then I booted to my live USB and searched for EFI Bootloaders. I noticed something odd. I have two.

I can remember exactly what the paths were, but one said "Manjaro" and the other said "Boot". I picked Boot and the system came up as usual.

So now I'm going to read what you've written...

1 Like

Correct. Your grub-customizer messed 'manjaro' entry.
'boot' entry is not touched. My link tells you to set manjaro to 'boot' as well. After you have fixed it.

Stinking grub-customizer!

I'm going to reboot after following this procedure:

sudo mv /etc/default/grub /etc/default/grub.bad
sudo mv /etc/grub.d /etc/grub.d.bad
sudo pacman -S grub
sudo grub-install /dev/sda
sudo update-grub
sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create
sudo grub-editenv - set boot_success=0

That did it. You're certainly more knowledgeable than I am. Thank you.


After I installed Manjaro flagship xfce a few months ago, I got a completely black grub screen. Sounds like my problem may have been that I had only one kernel, and no other os's on the hard drive.

Following the procedure above I now can see my grub menu, so thanks!

However I have spent a lot of time customizing this install and I would like to get the grub perfect too. Grub (or something) is complaining that Error resume: no device specified for hibernation. I do have a swap partition, do I need to configure that somehow?

Thank you!

check the output of these

cat /etc/fstab
cat /etc/default/grub

make sure the UUID's match and if not, edit /etc/fstab as needed

Yes, but you either search and study manjaro wiki/forum, or Archwiki, or else start a new topic.


I have no grub screen at all. I even installed plymouth. No go. Nothing. (I don't really need it, but I might one day.)

this is not a bug, it's silent grub and it was added as a "feature" :face_vomiting:. if you want grub to come up keep tapping or hold down shift key and it will come up.

i requested the info needed to tell you how to fix this issue but you didnt post it so :man_shrugging:.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by