GUI Installation Failed and Removed All HD Partitions

Hi all,

I was attempting to install with Community Awesome 20.0 Minimal. Live USB boot worked fine. Though, from a previous attempt via the CLI, no mirrors could find the archlinux-keyring-202006-1-any package and I assume that was the case during my last installation attempt that removed all of my HDD's partitions.

Before this, my drive had these partitions:

  • Windows(pre-installed)

  • Windows Recovery

  • 30G ext4 for /

  • 4G swap

  • 60G ext4 for /home

  • 300M FAT32 EFI to be shared with Windows and Manjaro

I began the installation with the GUI installer. The installer was waiting for a single module to install; I assumed it was the keyring pkg that failed to install in my previous attempts via the CLI. After a few minutes of waiting for the module to resolve (i.e. all mirrors were tried), the installer allowed me to proceed. I don't know if the module was installed or if it gave up...

Get to the partitioning step. I choose manual partition. I attempt to declare where each partition should be mounted, but the installer forces me to reformat ext4 and swap drives if I want to mount them. I mounted EFI partition to /boot/efi, and it did not require reformatting, thankfully.

Before I confirmed the partition changes, the list of intended actions looked correct (only reformatting ext4 and swap drives then mounting them, mounting efi, not touching windows partitions). Confirm changes. Process begins then immediately fails (unfortunately, I don't remember the failure message... :pensive:). I thought it was a small issue, so I backed out to retry. At that point, every partition was gone (I hope not wiped...).

I am hoping to receive help with restoring the partitions, even though I don't know their exact start and end locations :pleading_face:. I am also hoping to receive advice on how to try again with safer methods.

PS any suggestions on the keyring pkg?

I am afraid I won't be able to be of much more help to you than pointing out a piece of software which might help you to recover your lost partitions:

Good luck!

1 Like

I was wrong... I'm not entirely sure what happened, but it seems the installation process failed soon after the process's unmounting of my drive's partitions; the BIOS wasn't even aware of the drive on reboot.

After a couple of reboots, all was well and everything was still there. I ended up going with a full install of an official Manjaro release, and it worked! I still am not sure what packages the minimal installations lacked for my machine, but I'm glad I have it now!

Now it's time to play around, customize, and parse it down to my needs.

Thank you Marte for your prompt response and suggestion. <3


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by