Guide: How to solve OpenTTD music issue

OpenTTD is a fun game but the game's MIDI musics are not playing. Here is what I did to solve this issue:

Open a terminal and Ctrl+C and Ctrl+Shift+V the commands below:

yaourt -S openttd-openmsx
(or install this package using Pamac)

sudo mousepad /etc/timidity++/timidity.cfg
(it will open a page, if you don't like mousepad choose another text editor and open as root)

Copy and paste inside timidity.cfg the two lines below, at the bottom of the page:

dir /usr/share/timidity/freepats
source /etc/timidity++/freepats/freepats.cfg

Save, close the editor.

Start the game and select OpenMSX on music game options(see image below, OpenMSX is near the orange cursor).

openttd

Create a new map or load your save.

Click on the sound icon located at the top right of your screen and press Play icon.


Pages that helped me create this guide and solve the issue(and dozens of forums' pages):
https://wiki.archlinux.org/index.php/OpenTTD#Troubleshooting
https://wiki.archlinux.org/index.php/Timidity#SoundFonts

2 Likes

good job! moved to tutorials section.

I don't think that running graphical applications as root is a good idea, as it can create files in your $HOME that are owned by root.

Forum kindly sponsored by