Hardware Compatibility

This is probably the easiest solution. Just try it out.

Like all Arch-based distros, the rapidly rolling nature of the packages means that updates will be fairly large. It isn't uncommon to get ~500MB updates, every week or two. If bandwidth utilization is a big issue for you, anything Arch-based is going to be challenging.

~600MB a week It depends on your package amount less you have less to update :slight_smile:
You just need to try it we can not know if it will work, I just ask why should not? If it is an older laptop it is better, bugs were solved on that machine years ago. I have one laptop from 2013 and second from 2016 I needed to fix some things but they work with Manjaro.
You can struggle with WiFi and with Nvidia but these are solvable just ask here with proper information when you have problem do not write wifi does not work. :slight_smile:
And remember Linux is highly configurable and KDE too, but it can be broken very easy if you do random things, I would suggest to install KDE and just use it for a while as it is, Manjaro edition is good and works no need to change anything for couple off weeks :slight_smile: then you will want to experiment, and update regularly!

1 Like

Honestly, the older your laptop, the better your compatibility will be.

The problem is actually in the new hardware, because linux in general has to wait on the bios, CPU, GPU, etc. manufacturers to give out support for it. (Note: A very simplified way to say that.)

I've got an S530F, and the only compatibility issue I have is that my fingerprint reader is not yet supported because it's too recent.

If your NVIDIA GPU doesn't supports PRIME, you might have some hassle with the drivers, but nothing that's not manageable. (keep in mind that I don't game on this laptop, so I don't know for sure on how well it works in that department.)

Everything went fine except few things.
Asus logo shows up three to four times during boot this wasn't the issue with Windows 10.
I can't find how to install optirun because my battery is draining like crazy. Vertical scroll for desktop switching isn't working.

I don't game. My battery isn't even lasting 2 hours and Bumblebee isn't working. I can't switch my GPU.Screenshot_20200611_151615

Alrighty,
Please post the output of inxi -Fxxxz first.
This post has the info about the proper formatting:


Now, let's see.

The proper NVIDIA drivers might solve this one, but if you could post the output of journalctl -b -p 3, just for some info, that'd be great!

You want to go to Manjaro Setings and then Hardware Configuration. This is the GUI of the mhwd tool which should be able to automatically install the appropriate drivers for your card. You want the proprietary drivers - either prime or bumblebee (if prime is not supported).

This page has additional info:
https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards

I will give you all the output after sometime. The battery didn't even last 1 hour. Also grub isn't appearing at the time of boot. I chose non-free drivers while installation and installed bumbleweed and some mesa stuff that was written in the Arch Forum.

inxi -Fxxxz
System:    Host: AsusROG Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           Desktop: KDE Plasma 5.18.5 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: GL552JX v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: GL552JX v: 1.0 serial: <filter> UEFI: American Megatrends v: GL552JX.207 
           date: 08/11/2015 
Battery:   ID-1: BAT0 charge: 18.7 Wh condition: 31.6/32.6 Wh (97%) volts: 14.8/14.8 model: ASUSTeK GL552JX 
           type: Li-ion serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-4750HQ bits: 64 type: MT MCP arch: Haswell rev: 1 
           L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31937 
           Speed: 1297 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 1297 2: 1298 3: 1297 4: 1297 5: 1299 
           6: 1298 7: 1297 8: 1299 
Graphics:  Device-1: Intel Crystal Well Integrated Graphics vendor: ASUSTeK driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0d26 
           Device-2: NVIDIA GM107M [GeForce GTX 950M] vendor: ASUSTeK driver: N/A bus ID: 01:00.0 
           chip ID: 10de:139a 
           Display: x11 server: X.Org 1.20.8 driver: modesetting alternate: fbdev,intel,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Iris Pro Graphics P5200 (HSW GT3) v: 4.5 Mesa 20.0.7 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Crystal Well HD Audio driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:0d0c 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
           Sound Server: ALSA v: k5
journalctl -b -p 3
-- Logs begin at Thu 2020-06-11 12:15:35 IST, end at Thu 2020-06-11 16:59:40 IST. --
Jun 11 16:52:18 AsusROG kernel: Bluetooth: hci0: unexpected event for opcode 0xfc2f
Jun 11 16:53:10 AsusROG kwin_x11[1332]: kwin_xkbcommon: XKB: couldn't find a Compose file for locale "en_IN"
Jun 11 16:53:19 AsusROG bluetoothd[857]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address alr>
Jun 11 16:53:19 AsusROG bluetoothd[857]: RFCOMM server failed for :1.53/Profile/HSPHS/00001108-0000-1000-8000-008>

By default, it is hidden but you can unhide it if you want.

There are packaging differences between Arch and Manjaro so be careful about following guidance from the Arch forum that relates to kernels, video drivers or network drivers.

If you don't game, do you need to switch GPUs? Why not just install the open source drivers and use the integrated GPU full-time? That should improve battery life.

I want Nvidia GPU for brute forcing passwords. I'm learning penetration testing. I only want to turn it on when I need it.

And even more than that depending on whatever extras software you may have installed on top of it.

I guess you're using JIO that's why 1.5GB per day ,right?
I have unlimited internet i can tell you'll be wasting so much data using arch or a rolling distro. Same goes for windows because of its background processes.
Try installing Pop OS it has Nvidia iso, it should work for you out of the box and updates will be less frequent.

You are right but I am going to get a fiber Wi-Fi connection. My issue is that I can't switch my Graphics Card.

I have a newer Asus ROG machine and the only way I got graphics to work where I can switch them was with Optimus Manager here is the guide I followed, Guide: Install and configure optimus-manager for hybrid GPU setups (Intel/NVIDIA)

As to Bumblebee not working it's because you tried to install... Bumbleweed. And before you simply typed bumblebee, which isn't a proper command. It looks you have no idea how processes on systemd work, hence the constant errors and no results.

So basically, you should check bumblebee daemon by:

sudo systemctl status bumblebeed.service

If it's active, then it should work, if it's inactive, then you need to start it and enable to start with boot, so:

sudo systemctl start bumblebeed.service

sudo systemctl enable bumblebeed.service

If bumblebee.service is not found, it means it's not installed. I wouldn't recommend installing bumblebee by yourself, better relay on mhwd setup (see manjaro wiki about mhwd). However, as @theremper said, the best way to use laptop with switchable graphic is to install optimus-manager, but that don't always work with every laptop, so if you don't game, bumblebee is an OK option.

When it comes to updates, if you have a lot of packages installed, there can be updates over 1,4GB, so it depends on what you have on your system. If the limitation is per day, you may consider using testing branch, where updates come frequently (once every few days) but are often smaller. However, this is for advanced users who know what they are doing, because some updates may mess up your system and you should be able to fix them. So for newbies, stable branch is the best one.

Manjaro in general is compatible with most popular laptops but it can always happen that some hardware compilation will work badly with Manjaro. We can't rule that out and the only way is to try yourself. There are too many laptop models to find those that are using the exact model as you do, so the chances finding someone are slim, but possible. In that case, it would be better to give the model number in the topic, otherwise how do you expect to attract those? It's not like every user of the forum is reading every topic that shows up. It's impossible.

Optimus-Manager-Qt worked fine. But it's showing a third option Hybrid Graphics. My graphics card is old and I don't think that correct drivers are installed on my Laptop which are causing this issue.
Also I have another problem that Asus logo appears 3-4 times during boot and also appears while switching GPUs and Grub isn't appearing at the time of boot.

Hybrid option will show no matter if you have supported drivers. If you don't, it will just work as usual Intel mode. However, I may be wrong, but GTX 950M should support newer drivers.

What is the output of:

mhwd -li

If you have 440xx or newer line of drivers, hybird should work with an additional environmental variable before launch command, like:

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia appname

So you can launch Steam using:

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia Steam

and then check in system info in Steam if the Nvidia is used as GPU.

This is another topic that was discussed in other threads. No point of repeating it. To sum it up, it all comes down to settings between: Grub, BIOS, plymouth, splash, DM. Since so many components govern different times of boot and what is displayed, it's hard to simply show you the right settings. You must play with all of them and get to know all of them if that is important to you. Please, search the forum for the proper topics.

My 950M defaulted to latest drivers. And can you please elaborate how can I fix that Asus Logo issue?

mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI


Warning: No installed USB configs!

Looks like you have the newest stable driver line so hybird mode will work for you properly. It will still use way more energy than Intel mode but less than full nvidia.
Again, in hybrid mode start app with:

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia appname

to use Nvidia in that app.

No, I can't, because this is off-topic and too long to explain. This is something you have to dig for yourself. There are topics on the forum discussing it and since there are too many variables, nothing can give you easy answer, because each computer is different.

I can only give you some pointers:

  • install grub-customizer for easy modifying grub settings, you can add your own wallpaper to grub or use chosen grub theme, then you decide if you want quiet boot or not
  • browse BIOS/UEFI settings and experiment with it if there are some settings related to displaying vendor logo
  • you can use quiet boot and install plymouth-git from AUR because plymouth in repo is somewhat broken and outdated:

yay -S plymouth-git

or

trizen -S plymouth-git

Find plymouth theme you want to use, copy unpacked plymouth directory with plymouth to:

/usr/share/plymouth/themes/

Add plymouth hook to mkinitcpio, edit:

/etc/mkinitcpio.conf

HOOKS=(base udev autodetect modconf block keyboard keymap plymouth resume filesystems fsck)

It must be added after base and udev for it to work.

To list all plymouth themes and check if the new one is detected:
plymouth-set-default-theme -l

To change theme:
sudo plymouth-set-default-theme <theme>

To rebuild initrd image:
sudo mkinitcpio -p <kernel present name>

Add read-write capability for potential logs:

/usr/bin/plymouth update-root-fs --read-write

To change theme and rebuild initrid image at the same time:

sudo plymouth-set-default-theme -R <theme>

Systemd services for plymouth (won't run without them, they are automatically activated, to deactivate mask them):

plymouth-start.service
plymouth-read-write.service

To disable plymouth:

  • remove hook from /etc/mkinitcpio.conf
  • remove quet splash from grub config
  • mask plymouth-start.service and plymouth-read-write.service
  • regenerate mkinitcpio: sudo mkinitcpio -p linux

Since I am on Alienware laptop, I like the Vendor's logo I get, so my plymouth and grub's background are also using Alienware logo. This creates very consistently looking boot with nice branding.

IMPORTANT NOTE: Be sure that you are installing plymouth meant for Arch systems! Plymouths meant for Debian based systems work differently and are installed in different paths - those won't work on Arch or Manjaro. So if you see in install instruction unfamiliar path, this is probably not Arch plymouth.

Forum kindly sponsored by