Hardware configuration hangs out

IMG_20190125_180944

I am new here my first post
Laptop - rog gl552vw
Manjaro KDE or xfce both hav same problem tat hardware configuration freezes out and mhwd doesnt work too

Scenario 1
if i choose free drivers the system installs and boots properly but i cant reboot, shutdown, go to lockscreen etc doing so gives me a black screen and going to hardware configuration hangs the window and mhwd command doesnt work, it says the command is running if i close terminal but it doesn't show any output

Scenario 2
if i choose non-free drivers at boot, the boot stucks at between, i attached a pic of where it stucks (started tlp service)
i cant copy all as it is in boot
i saw some commands in threads here and added command on boot like mhwd = live.service (something like tat i forgot actual) but no change

the same thing happens in kde and xfce
for other distros i had to add nomodeset to boot the os and then they worked fine (linux mint, elementary, tails)

According to this wiki
https://wiki.archlinux.org/index.php/ASUS_G55VW
you have to use
i915.i915_enable_rc6=1 drm.vblankoffdelay=1 i915.semaphores=1
as kernel boot parameter.

If the free drivers boots, then once in it, provide the
inxi -Fxz
so we know for sure if is a hybrid graphics or not ...

Typed tat code on boot, no change still stuck at started tlp startup shutdown
and inxi -Fxz gives no results just hangs out

to be sure i hav to type tat code on tat screen when it says boot manjaro kde right on live boot usb
there is a option to enter codes at boot tat where i typed them and i put spaces between codes just like u said

and my laptop model is gl552vw gaming laptop not 55vw

Then this is how you have to set the kernel boot parameter
https://bbs.archlinux.org/viewtopic.php?id=211771

1 Like

already did this but whatever i do the nonfree driver doesnt boot
only free drivers boot and even then i cant access mhwd or hardware config
but on booting with free drivers i can access mhwd and inxi command (only accessible in live boot)
i am giving you picture, plz guide me further

mhwd(live boot) - https://ibb.co/JtKQ1jV
inxi(live boot) - https://ibb.co/jh4gBMD

cant enter these command if i install manjaro it hangs terminal

You know you can copy and paste that text ? Pictures are not searchable ...
Anyway, the bios on your laptop is from 2016 and there is a newer BIOS
https://www.asus.com/us/ROG-Republic-Of-Gamers/ROG-GL552VW/HelpDesk_BIOS/

Install the system using the free driver option and make sure you solve the boot part first, then move to correctly install one of the options:

1 Like

return mhwd.run()

return None # <- Add this and comment the above line

this line was written in guide
i do not understand this line
shud i hav to replace mhwd.run() with "NONE" ??

What guide ? Let's try to put it in context ...

  1. Now before you start the install from the live session change the lines at the end of the file /lib/calamares/modules/mhwdcfg/main.py to match below
def run():
    """ Configure the hardware """
    
    mhwd = MhwdController()
    
    # return mhwd.run()
    return None # <- Add this and comment the above line

it is written like this
should i edit the main.py file exactly like its written? or that 'add this comment above line' line is trying to say something

sorry for being total noob i am new to linux

Ok, now i see what you do. :wink: is ok, as described.
And with that commented, the install still hangs?

i did it
installed drivers of nvidia
but i hav masione keyboard tat i always use and due to driver problem in that alt, win, ctrl key are working as shift buttom
means press these keys they capatilise the letters and dont do their intended function

maione keyboard model VMJ-02
In all linux distros, the special keys like ctrl, alt, win doesnt work and are mapped as shift
i tried so much to solve this in elementary os but failed after wasting 3 hrs
can you help ?
people finally told me to change my gaming keyboard and use standard keyboard tat i dont have

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by