Hardware Detection Issue

Good evening everyone,

I appear to be running into an issue I cannot find in the forums.

I am experiencing an issue where the computer hangs when it is rebooting, turning off, or switching user. I attributed this issue to possibly be with the graphics drivers.

When attempting to update said graphics drivers, common tools for identifying the hardware present and recognizing the drivers required are not working. MHWD and INXI are not producing output, the default settings > hardware configuration and manjaro-settings-manager are freezing the computer when attempting to recognize the hardware.

I am currently using a GIGABYTE AERO 15X, i7-8750H, and NVIDIA GTX 1060. I am on kernel 4.19.4-1. Given my newb status, I am unsure of what logs need to be provided to assist in the troubleshooting. Help me manjaro-bi-wan kenobi, you're my only hope.

Very Respectfully

Start by providing the inxi -Fxxxz from terminal.
AFAIK that AERO 15X has a dual hybrid GPU: one intel and one nvidia.
You either use bumblebee (also explainedhere) or prime. There are also other ways to "switch graphics", plenty of topics on that regard in the forum.

The mhwd command can freeze the system under very specific circumstances.

One user have solved the issue. You might find help from his solution post

The inxi command is not providing any output, just hanging. I will look into getting bumblebee configured properly tonight. Thank you!

Thank you very much! I will attempt this...still unsure why my inxi command is hanging, but I will look into it when I get home from work tonight.

I was able to implement the kernel change, but that directory /lib/calamares does not exist. I feel like I'm missing something...

not sure because of lack of info but i had similar issue with kde on my optimus(intel/invidia) laptop where desktop would load but if i tried anything mhwd or msm,inxi it would lock up. the solution for me was to boot to a tty and not load the desktop environment and then setup nvidia/prime using that link @bogdancovaciu provided. im not even sure your using kde i just thought i would take a semi-educated guess based on past experience with the same issue.
you might find it easier to manjaro-chroot from a liveusb so your able to copy and paste, or even run through the tutorial now from your somewhat working desktop, create all the config's and then reboot to tty and install nvidia proprietary drivers with mhwd.

I am running KDE on a laptop with an i7-8750H and GTX 1060. I wish I could provide info, but as you stated, the computer freezes when trying to gather it. I would try chrooting and making the modifications, but the directory that is referenced in the github post does not appear to be present on my computer. Not quite sure what I need for that.

Correction: I reread what you posted. I will try to set up prime through chroot

not that link, the one for the prime tutorial

you may be able to get bumblebee working as many others have, it's just never worked for me. my only solution may not be your only solution but prime should work for you regardless and that tutorial is simple enough to follow. since your on kde you follow the SDDM instruction when you get to step 5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by